add download-fonts-service.info for parser plugin
[platform/core/uifw/download-fonts-service.git] / packaging / download-fonts-service.spec
1 Name: download-fonts-service
2 Summary: Master Download fonts service
3 Version: 1.0.0
4 Release: 1
5 Group: Base/Package Management
6 License: Apache-2.0
7 Source0: %{name}-%{version}.tar.gz
8 Source1001: download-fonts-service.manifest
9 BuildRequires: cmake, gettext-tools, smack, coreutils
10 BuildRequires: pkgconfig(dlog)
11 BuildRequires: pkgconfig(fontconfig)
12 BuildRequires: pkgconfig(capi-system-system-settings)
13 BuildRequires: pkgconfig(elementary)
14 BuildRequires: pkgconfig(pkgmgr-info)
15 BuildRequires: pkgconfig(pkgmgr-installer)
16
17 %description
18 Master Download fonts service.
19
20 %prep
21 %setup -q
22 cp %{SOURCE1001} .
23
24 %build
25 %if 0%{?sec_build_binary_debug_enable}
26 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
27 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
28 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
29 %endif
30 %if 0%{?tizen_build_binary_release_type_eng}
31 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
32 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
33 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
34 %endif
35 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DDATADIR=%{_datadir}
36
37 CFLAGS="${CFLAGS} -Wall -Winline -Werror" LDFLAGS="${LDFLAGS}" make %{?jobs:-j%jobs}
38
39 %install
40 rm -rf %{buildroot}
41 %make_install
42
43 mkdir -p %{buildroot}%{_tmpfilesdir}
44
45 %files -n download-fonts-service
46 %manifest download-fonts-service.manifest
47 %defattr(-,root,root,-)
48 %{_datadir}/parser-plugins/download-fonts-service.info
49 /etc/package-manager/parserlib/category/*
50
51 # End of a file