update version to 0.0.8
[platform/core/uifw/download-fonts-service.git] / packaging / download-fonts-service.spec
1 Name: download-fonts-service
2 Summary: Master Download fonts service.
3 Version: 0.0.8
4 Release: 1
5 Group: TO_BE / FILLED_IN
6 License: Apache-2.0
7 Source0: %{name}-%{version}.tar.gz
8 BuildRequires: cmake, gettext-tools, smack, coreutils
9 BuildRequires: pkgconfig(dlog)
10 BuildRequires: pkgconfig(fontconfig)
11 BuildRequires: pkgconfig(capi-system-system-settings)
12 BuildRequires: pkgconfig(elementary)
13 BuildRequires: pkgconfig(pkgmgr-info)
14 BuildRequires: pkgconfig(security-server)
15
16 %description
17 Master Download fonts service.
18
19 %prep
20 %setup -q
21
22 %build
23 %if 0%{?sec_build_binary_debug_enable}
24 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
25 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
26 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
27 %endif
28 %if 0%{?tizen_build_binary_release_type_eng}
29 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
30 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
31 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
32 %endif
33 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DPRODUCT=private
34
35 CFLAGS="${CFLAGS} -Wall -Winline -Werror" LDFLAGS="${LDFLAGS}" make %{?jobs:-j%jobs}
36
37 %install
38 rm -rf %{buildroot}
39 %make_install
40
41 %files -n download-fonts-service
42 %manifest download-fonts-service.manifest
43 %defattr(-,root,root,-)
44 %{_prefix}/etc/package-manager/parserlib/category/*
45
46 # End of a file