[Tizen] Enable GBS build
[platform/core/uifw/dali-csharp-binder.git] / packaging / dali-csharp-binder.spec
1
2 Name: dali-csharp-binder
3 Version: 1.3.19+nui500
4 Release: 1
5 Summary: build dali csharp binder
6 License: Apache-2.0 and BSD-3-Clause and MIT
7 Group: uifw/graphic
8 Source: %{name}-%{version}.tar.xz
9
10 BuildRequires: pkgconfig(dali-core)
11 BuildRequires: pkgconfig(dali-adaptor)
12 BuildRequires: pkgconfig(dali-toolkit)
13 BuildRequires: pkgconfig(widget_viewer_dali)
14 %if 0%{?tizen_version_major} >= 5
15 BuildRequires: pkgconfig(ecore-wl2)
16 %else
17 BuildRequires:  pkgconfig(ecore-wayland)
18 %endif
19
20 %description
21 dali-csharp-binder
22
23 %if 0%{?tizen_version_major} >= 5
24 CFLAGS+=" -DECORE_WL2 -DEFL_BETA_API_SUPPORT"
25 CXXFLAGS+=" -DECORE_WL2 -DEFL_BETA_API_SUPPORT"
26 %endif
27
28 ##############################
29 # devel
30 ##############################
31 %package devel
32 Summary: build dali csharp binder
33 Group: Development/Building
34 Requires: %{name} = %{version}-%{release}
35
36 %description devel
37 This package includes developer files common to all packages.
38
39 ##############################
40 # Preparation
41 ##############################
42 %prep
43 %setup -q
44
45 ##############################
46 # Build
47 ##############################
48 %build
49 %autogen
50 # added for key grab binding only for tizen
51 %if 0%{?tizen_version_major} >= 5
52 %configure --enable-ecoreWl2=yes \
53            --enable-tizenBuild=yes
54 %else
55 %configure --enable-tizenBuild=yes
56 %endif
57
58 make %{?_smp_mflags}
59
60 ##############################
61 # Installation
62 ##############################
63 %install
64 %make_install
65
66 ##############################
67 # Files in Binary Packages
68 ##############################
69 %files -n %{name}
70 %manifest dali-csharp-binder.manifest     
71 %defattr(-,root,root,-)
72 %{_libdir}/lib%{name}.so*
73
74 %files devel
75 %defattr(-,root,root,-)
76 %dir %{_includedir}/%{name}/
77 %{_includedir}/%{name}/*
78 %{_libdir}/pkgconfig/%{name}.pc
79