ebb8d469847a5547c66a0cbe7f5cc3332f8037df
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    1.5.6
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30 Provides: libdali-adaptor-cxx11.so
31 Provides: libdali-adaptor-cxx11.so.0
32 Provides: libdali-adaptor-cxx11.so.0.0.0
33 Provides: libdali-adaptor.so
34 Provides: libdali-adaptor.so.0
35 Provides: libdali-adaptor.so.0.0.0
36
37 %define tizen_platform_config_supported 1
38 BuildRequires:  pkgconfig(libtzplatform-config)
39
40 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
41 # if wearable || "undefined"
42 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
43 BuildRequires:  pkgconfig(capi-appfw-watch-application)
44 BuildRequires:  pkgconfig(appcore-watch)
45 BuildRequires:  pkgconfig(screen_connector_provider)
46 %endif
47
48 BuildRequires:  pkgconfig(gles20)
49 BuildRequires:  pkgconfig(glesv2)
50 BuildRequires:  pkgconfig(ttrace)
51
52 BuildRequires:  dali-devel
53 BuildRequires:  dali-integration-devel
54
55 BuildRequires:  pkgconfig
56 BuildRequires:  gawk
57 BuildRequires:  cmake
58 BuildRequires:  giflib-devel
59 BuildRequires:  pkgconfig(fontconfig)
60 BuildRequires:  libjpeg-turbo-devel
61 BuildRequires:  pkgconfig(vconf)
62 BuildRequires:  tts-devel
63 BuildRequires:  pkgconfig(dlog)
64 BuildRequires:  libdrm-devel
65 BuildRequires:  pkgconfig(libexif)
66 BuildRequires:  pkgconfig(libpng)
67 BuildRequires:  pkgconfig(egl)
68 BuildRequires:  libcurl-devel
69 BuildRequires:  pkgconfig(harfbuzz)
70 BuildRequires:  fribidi-devel
71
72 BuildRequires:  pkgconfig(capi-system-info)
73 BuildRequires:  pkgconfig(capi-system-sensor)
74
75 BuildRequires:  pkgconfig(cairo)
76
77 BuildRequires:  pkgconfig(wayland-egl)
78 BuildRequires:  pkgconfig(wayland-client)
79 BuildRequires:  wayland-devel
80 BuildRequires:  wayland-extension-client-devel
81
82 # dali-adaptor uses ecore mainloop
83 %if 0%{?tizen_version_major} >= 5
84 BuildRequires:  pkgconfig(ecore-wl2)
85 BuildRequires:  pkgconfig(wayland-egl-tizen)
86 %else
87 BuildRequires:  pkgconfig(ecore-wayland)
88 %endif
89
90 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
91 BuildRequires:  pkgconfig(libtbm)
92
93 # for dali-adaptor
94 BuildRequires:  pkgconfig(appcore-ui)
95 BuildRequires:  pkgconfig(appcore-widget-base)
96 BuildRequires:  pkgconfig(bundle)
97 BuildRequires:  pkgconfig(capi-appfw-app-common)
98 BuildRequires:  pkgconfig(capi-appfw-app-control)
99 BuildRequires:  pkgconfig(ecore-imf)
100
101 BuildRequires:  pkgconfig(capi-system-system-settings)
102
103 # for autofill
104 %if 0%{?tizen_version_major} >= 5 && 0%{?tizen_version_minor} >= 5
105 BuildRequires:  pkgconfig(capi-ui-autofill)
106 %endif
107
108 # for feedback plugin
109 BuildRequires:  pkgconfig(mm-sound)
110 BuildRequires:  pkgconfig(feedback)
111
112 # for multiprofile
113 Requires:   %{name}-compat = %{version}-%{release}
114 Recommends: %{name}-profile_common = %{version}-%{release}
115
116 %description
117 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
118 platform abstraction and application shell
119
120 ###########################################
121 # Dali adapter for profiles
122 ###########################################
123
124 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
125 # if mobile || "undefined"
126 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
127 %package profile_mobile
128 Summary:        The DALi Tizen Adaptor for mobile
129 Provides:       %{name}-compat = %{version}-%{release}
130 Conflicts:      %{name}-profile_tv
131 Conflicts:      %{name}-profile_wearable
132 Conflicts:      %{name}-profile_ivi
133 Conflicts:      %{name}-profile_common
134 Requires:       %{name}
135 %description profile_mobile
136 The DALi Tizen Adaptor for mobile.
137 %endif
138
139 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
140 # if tv ||"undefined"
141 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
142 %package profile_tv
143 Summary:        The DALi Tizen Adaptor for tv
144 Provides:       %{name}-compat = %{version}-%{release}
145 Conflicts:      %{name}-profile_mobile
146 Conflicts:      %{name}-profile_wearable
147 Conflicts:      %{name}-profile_ivi
148 Conflicts:      %{name}-profile_common
149 Requires:       %{name}
150 %description profile_tv
151 The DALi Tizen Adaptor for tv.
152 %endif
153
154 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
155 # if wearable || "undefined"
156 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
157 %package profile_wearable
158 Summary:        The DALi Tizen Adaptor for wearable
159 Provides:       %{name}-compat = %{version}-%{release}
160 Conflicts:      %{name}-profile_mobile
161 Conflicts:      %{name}-profile_tv
162 Conflicts:      %{name}-profile_ivi
163 Conflicts:      %{name}-profile_common
164 Requires:       %{name}
165 %description profile_wearable
166 The DALi Tizen Adaptor for wearable.
167 %endif
168
169 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
170 # if ivi ||"undefined"
171 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
172 %package profile_ivi
173 Summary:        The DALi Tizen Adaptor for ivi
174 Provides:       %{name}-compat = %{version}-%{release}
175 Conflicts:      %{name}-profile_mobile
176 Conflicts:      %{name}-profile_wearable
177 Conflicts:      %{name}-profile_tv
178 Conflicts:      %{name}-profile_common
179 Requires:       %{name}
180 %description profile_ivi
181 The DALi Tizen Adaptor for ivi.
182 %endif
183
184 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
185 # if common ||"undefined"
186 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
187 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
188 %package profile_common
189 Summary:        The DALi Tizen Adaptor for common
190 Provides:       %{name}-compat = %{version}-%{release}
191 Conflicts:      %{name}-profile_mobile
192 Conflicts:      %{name}-profile_wearable
193 Conflicts:      %{name}-profile_tv
194 Conflicts:      %{name}-profile_ivi
195 Requires:       %{name}
196 %description profile_common
197 The DALi Tizen Adaptor for common.
198 %endif
199
200 ##############################
201 # devel
202 ##############################
203 %package devel
204 Summary:    Development components for the DALi Tizen Adaptor
205 Group:      Development/Building
206 Requires:   %{name} = %{version}-%{release}
207 Requires:   %{name}-integration-devel = %{version}-%{release}
208
209 %description devel
210 Development components for the DALi Tizen Adaptor - public headers and package configs
211
212 ##############################
213 # integration-devel
214 ##############################
215 %package integration-devel
216 Summary:    Integration development package for the Adaptor
217 Group:      Development/Building
218 Requires:   %{name} = %{version}-%{release}
219
220 %description integration-devel
221 Integration development package for the Adaptor - headers for integrating with an adaptor library.
222
223 ##############################
224 # Dali Feedback Plugin
225 ##############################
226 %package dali-feedback-plugin
227 Summary:    Plugin to play haptic and audio feedback for Dali
228 Group:      System/Libraries
229 Requires:   %{name} = %{version}-%{release}
230 %description dali-feedback-plugin
231 Feedback plugin to play haptic and audio feedback for Dali
232
233 ##############################
234 # Preparation
235 ##############################
236 %prep
237 %setup -q
238
239 #Use TZ_PATH when tizen version is 3.x or greater
240
241 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
242 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
243 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
244 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
245 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
246 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
247
248 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
249 %define dali_plugin_sound_files  /plugins/sounds/
250
251 ##############################
252 # Build
253 ##############################
254 %build
255 PREFIX+="/usr"
256 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
257 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
258
259 %ifarch %{arm}
260 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
261 %endif
262
263 CFLAGS+=" -DWAYLAND"
264 CXXFLAGS+=" -DWAYLAND"
265 cmake_flags=" -DENABLE_WAYLAND=ON"
266
267 # Use this conditional when Tizen version is 5.x or greater
268 %if 0%{?tizen_version_major} >= 5
269 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
270
271 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
272 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
273 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
274 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
275 %endif
276
277 %if 0%{?enable_debug}
278 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
279 %endif
280
281 %if 0%{?enable_trace}
282 cmake_flags+=" -DENABLE_TRACE=ON"
283 %endif
284
285 %if 0%{?enable_appfw}
286 cmake_flags+=" -DUSE_APPFW"
287 %endif
288
289 libtoolize --force
290 cd %{_builddir}/%{name}-%{version}/build/tizen
291
292 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
293 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
294 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
295 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
296 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
297 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
298 %if 0%{?tizen_platform_config_supported}
299 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
300 %endif
301
302 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
303 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
304 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
305 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
306 cmake_flags+=" -DENABLE_TIZEN_MINOR_VERSION=%{tizen_version_minor}"
307 cmake_flags+=" -DENABLE_FEEDBACK=YES"
308 cmake_flags+=" -DENABLE_APPFW=YES"
309
310 # Set up the build via Cmake
311 #######################################################################
312 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
313 # if mobile || "undefined"
314 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
315
316 mkdir mobile
317 pushd mobile
318
319 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
320
321 # Build.
322 make %{?jobs:-j%jobs}
323 popd
324
325 %endif
326
327 #######################################################################
328 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
329 # if tv ||"undefined"
330 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
331
332 mkdir tv
333 pushd tv
334
335 cmake -DENABLE_PROFILE=TV $cmake_flags ..
336
337 # Build.
338 make %{?jobs:-j%jobs}
339 popd
340
341 %endif
342
343 #######################################################################
344 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
345 # if wearable || "undefined"
346 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
347
348 mkdir wearable
349 pushd wearable
350
351 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
352
353 # Build.
354 make %{?jobs:-j%jobs}
355 popd
356
357 %endif
358
359 #######################################################################
360 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
361 # if ivi ||"undefined"
362 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
363
364 mkdir ivi
365 pushd ivi
366
367 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
368
369 # Build.
370 make %{?jobs:-j%jobs}
371 popd
372
373 %endif
374
375 #######################################################################
376 # common
377 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
378 # if common ||"undefined"
379 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
380
381 mkdir common
382 pushd common
383
384 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
385
386 # Build.
387 make %{?jobs:-j%jobs}
388 popd
389
390 %endif
391
392 ##############################
393 # Installation
394 ##############################
395 %install
396 rm -rf %{buildroot}
397
398 pushd %{_builddir}/%{name}-%{version}/build/tizen
399
400 # if mobile || "undefined"
401 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
402 pushd mobile
403 %make_install
404 %if "%{?profile}" != "mobile"
405 pushd  %{buildroot}%{_libdir}
406 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
407 popd
408 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
409 %endif
410 popd
411 %endif
412
413 # if tv ||"undefined"
414 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
415 pushd tv
416 %make_install
417 %if "%{?profile}" != "tv"
418 pushd  %{buildroot}%{_libdir}
419 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
420 popd
421 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
422 %endif
423 popd
424 %endif
425
426 # if wearable || "undefined"
427 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
428 pushd wearable
429 %make_install
430 %if "%{?profile}" != "wearable"
431 pushd  %{buildroot}%{_libdir}
432 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
433 popd
434 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
435 %endif
436 popd
437 %endif
438
439 # if ivi ||"undefined"
440 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
441 pushd ivi
442 %make_install
443 %if "%{?profile}" != "ivi"
444 pushd  %{buildroot}%{_libdir}
445 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
446 popd
447 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
448 %endif
449 popd
450 %endif
451
452 # if common ||"undefined"
453 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
454 pushd common
455 %make_install
456 # No clean so we can gather symbol/size information for the common profile
457 popd
458 %endif
459
460 # Create links to ensure linking with cxx11 library is preserved
461 pushd  %{buildroot}%{_libdir}
462 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so
463 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0
464 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0.0.0
465 popd
466
467 # Create a symbolic link in integration-api to preserve legacy repo build
468 pushd %{buildroot}%{_includedir}/dali/integration-api
469 ln -sf adaptor-framework adaptors
470 popd
471
472 ##############################
473 # Upgrade order:
474 # 1 - Pre Install new package
475 # 2 - Install new package
476 # 3 - Post install new package
477 # 4 - Pre uninstall old package
478 # 5 - Remove files not overwritten by new package
479 # 6 - Post uninstall old package
480 ##############################
481
482 ##############################
483 # Adaptor package Commands
484 %pre
485 exit 0
486
487 %post
488 pushd %{_libdir}
489 for i in mobile tv wearable ivi; do [[ -f libdali-adaptor.so.$i ]] && ln -sf libdali-adaptor.so.$i libdali-adaptor.so.0.0.0; done
490 popd
491 /sbin/ldconfig
492 exit 0
493
494 %preun
495 exit 0
496
497 %postun
498 /sbin/ldconfig
499 exit 0
500
501 ##############################
502 # Mobile Profile Commands
503 # if mobile || "undefined"
504 # No need to create a symbolic link on install required if only building this profile
505 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
506 %post profile_mobile
507 %if "%{?profile}" != "mobile"
508 pushd %{_libdir}
509 ln -sf libdali-adaptor.so.mobile libdali-adaptor.so.0.0.0
510 popd
511 %endif
512 /sbin/ldconfig
513 exit 0
514
515 %postun profile_mobile
516 /sbin/ldconfig
517 exit 0
518 %endif
519
520 ##############################
521 # TV Profile Commands
522 # No need to create a symbolic link on install required if only building this profile
523 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
524 %post profile_tv
525 %if "%{?profile}" != "tv"
526 pushd %{_libdir}
527 ln -sf libdali-adaptor.so.tv libdali-adaptor.so.0.0.0
528 popd
529 %endif
530 /sbin/ldconfig
531 exit 0
532
533 %postun profile_tv
534 /sbin/ldconfig
535 exit 0
536 %endif
537
538 ##############################
539 # Wearable Profile Commands
540 # No need to create a symbolic link on install required if only building this profile
541 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
542 %post profile_wearable
543 %if "%{?profile}" != "wearable"
544 pushd %{_libdir}
545 ln -sf libdali-adaptor.so.wearable libdali-adaptor.so.0.0.0
546 popd
547 %endif
548 /sbin/ldconfig
549 exit 0
550
551 %postun profile_wearable
552 /sbin/ldconfig
553 exit 0
554 %endif
555
556 ##############################
557 # IVI Profile Commands
558 # No need to create a symbolic link on install required if only building this profile
559 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
560 %post profile_ivi
561 %if "%{?profile}" != "ivi"
562 pushd %{_libdir}
563 ln -sf libdali-adaptor.so.ivi libdali-adaptor.so.0.0.0
564 popd
565 %endif
566 /sbin/ldconfig
567 exit 0
568
569 %postun profile_ivi
570 /sbin/ldconfig
571 exit 0
572 %endif
573
574 ##############################
575 # Common Profile Commands
576 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
577 %post profile_common
578 /sbin/ldconfig
579 exit 0
580
581 %postun profile_common
582 /sbin/ldconfig
583 exit 0
584 %endif
585
586 ##############################
587 # Files in Binary Packages
588 ##############################
589
590 %files
591 %manifest dali-adaptor.manifest
592 %defattr(-,root,root,-)
593 %dir %{user_shader_cache_dir}
594 %{_bindir}/*
595 %license LICENSE
596 %defattr(-,root,root,-)
597 %{_libdir}/libdali-adaptor-cxx11.so
598 %{_libdir}/libdali-adaptor-cxx11.so.0
599 %{_libdir}/libdali-adaptor-cxx11.so.0.0.0
600 %{_libdir}/libdali-adaptor.so
601 %{_libdir}/libdali-adaptor.so.0
602 %{_libdir}/libdali-adaptor.so.0.0.0
603
604 #################################################
605
606 %files dali-feedback-plugin
607 %manifest dali-adaptor.manifest
608 %defattr(-,root,root,-)
609 %{_libdir}/libdali-feedback-plugin-cxx11.so*
610 %{dali_plugin_sound_files}/*
611
612 #################################################
613
614 # if common ||"undefined"
615 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
616 %files profile_common
617 %manifest dali-adaptor.manifest
618 # default .so files are housed in the main pkg.
619 %endif
620
621 # if mobile || "undefined"
622 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
623 %files profile_mobile
624 %manifest dali-adaptor.manifest
625 %defattr(-,root,root,-)
626 %if "%{?profile}" != "mobile"
627 %{_libdir}/libdali-adaptor.so.mobile
628 %endif
629 %endif
630
631 # if tv ||"undefined"
632 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
633 %files profile_tv
634 %manifest dali-adaptor.manifest
635 %defattr(-,root,root,-)
636 %if "%{?profile}" != "tv"
637 %{_libdir}/libdali-adaptor.so.tv
638 %endif
639 %endif
640
641 # if wearable || "undefined"
642 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
643 %files profile_wearable
644 %manifest dali-adaptor.manifest
645 %defattr(-,root,root,-)
646 %if "%{?profile}" != "wearable"
647 %{_libdir}/libdali-adaptor.so.wearable
648 %endif
649 %endif
650
651 # if ivi ||"undefined"
652 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
653 %files profile_ivi
654 %manifest dali-adaptor.manifest
655 %defattr(-,root,root,-)
656 %if "%{?profile}" != "ivi"
657 %{_libdir}/libdali-adaptor.so.ivi
658 %endif
659 %endif
660
661 %files devel
662 %defattr(-,root,root,-)
663 %{_includedir}/dali/dali.h
664 %{_includedir}/dali/public-api/*
665 %{_includedir}/dali/devel-api/*
666 %{_includedir}/dali/doc/*
667 %{_libdir}/pkgconfig/dali-adaptor.pc
668
669 %files integration-devel
670 %defattr(-,root,root,-)
671 %{_includedir}/dali/integration-api/adaptor-framework/*
672 %{_includedir}/dali/integration-api/adaptors
673 %{_libdir}/pkgconfig/dali-adaptor-integration.pc