dc8add79623319d5759a58c05fb83a314b41c1a0
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 %bcond_with wayland
19
20 Name:       dali-adaptor
21 Summary:    The DALi Tizen Adaptor
22 Version:    1.2.52
23 Release:    1
24 Group:      System/Libraries
25 License:    Apache-2.0 and BSD-3-Clause and MIT
26 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
27 Source0:    %{name}-%{version}.tar.gz
28
29 Requires(post): /sbin/ldconfig
30 Requires(postun): /sbin/ldconfig
31 Requires:       giflib
32
33 #need libtzplatform-config for directory if tizen version is 3.x
34
35 %if 0%{?tizen_version_major} >= 3
36 %define tizen_platform_config_supported 1
37 BuildRequires:  pkgconfig(libtzplatform-config)
38 %endif
39
40 # Get the profile from tizen_profile_name if tizen version is 2.x and tizen_profile_name exists.
41
42 %if "%{tizen_version_major}" == "2" && 0%{?tizen_profile_name:1}
43 %define profile %{tizen_profile_name}
44 %endif
45
46 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
47 # if wearable || "undefined"
48 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
49 BuildRequires:  pkgconfig(capi-appfw-watch-application)
50 BuildRequires:  pkgconfig(appcore-watch)
51 BuildRequires:  pkgconfig(screen_connector_provider)
52 %endif
53
54 BuildRequires:  pkgconfig(gles20)
55 BuildRequires:  pkgconfig(glesv2)
56
57 BuildRequires:  pkgconfig
58 BuildRequires:  gawk
59 BuildRequires:  giflib-devel
60 BuildRequires:  pkgconfig(fontconfig)
61 BuildRequires:  libjpeg-turbo-devel
62 BuildRequires:  dali-devel
63 BuildRequires:  dali-integration-devel
64 BuildRequires:  pkgconfig(vconf)
65 BuildRequires:  tts-devel
66 BuildRequires:  pkgconfig(dlog)
67 BuildRequires:  libdrm-devel
68 BuildRequires:  pkgconfig(libexif)
69 BuildRequires:  pkgconfig(libpng)
70 BuildRequires:  pkgconfig(egl)
71 BuildRequires:  libcurl-devel
72 BuildRequires:  pkgconfig(harfbuzz)
73 BuildRequires:  fribidi-devel
74
75 BuildRequires:  pkgconfig(capi-system-info)
76 BuildRequires:  pkgconfig(capi-system-sensor)
77
78 %if %{with wayland}
79
80 ####### BUILDING FOR WAYLAND #######
81 BuildRequires:  pkgconfig(wayland-egl)
82 BuildRequires:  pkgconfig(wayland-client)
83 BuildRequires:  wayland-devel
84 BuildRequires:  wayland-extension-client-devel
85
86 # dali-adaptor uses ecore mainloop
87 BuildRequires:  pkgconfig(ecore-wayland)
88
89 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
90 BuildRequires:  pkgconfig(libtbm)
91
92 # tpkp-curl (certificate pinning for libcurl functions) is only available in Tizen 3.0
93 BuildRequires:  pkgconfig(tpkp-curl)
94
95 ####### BUILDING FOR X11#######
96 %else
97 BuildRequires:  pkgconfig(egl)
98 BuildRequires:  pkgconfig(xext)
99 BuildRequires:  pkgconfig(xi)
100 BuildRequires:  pkgconfig(xfixes)
101 BuildRequires:  pkgconfig(xdamage)
102 BuildRequires:  pkgconfig(utilX)
103 %endif
104
105 # for dali-adaptor
106 BuildRequires:  pkgconfig(evas)
107 BuildRequires:  pkgconfig(elementary)
108
109 %if 0%{?tizen_version_major} == 3
110 BuildRequires:  pkgconfig(capi-appfw-application)
111 %else
112 BuildRequires:  pkgconfig(appcore-ui)
113 BuildRequires:  pkgconfig(capi-appfw-app-common)
114 BuildRequires:  pkgconfig(capi-appfw-app-control)
115 %endif
116 BuildRequires:  pkgconfig(capi-system-system-settings)
117
118 # for feedback plugin
119 BuildRequires:  pkgconfig(mm-sound)
120 %if 0%{?tizen_version_major} >= 3
121 BuildRequires:  pkgconfig(feedback)
122 %endif
123
124 # for videoplayer Plugin
125 BuildRequires:  pkgconfig(capi-media-player)
126
127
128 # for multiprofile
129 Requires:   %{name}-compat = %{version}-%{release}
130 Recommends: %{name}-profile_common = %{version}-%{release}
131
132 %description
133 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
134 platform abstraction and application shell
135
136 ###########################################
137 # Dali adapter for profiles
138 ###########################################
139
140 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
141 # if mobile || "undefined"
142 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
143 %package profile_mobile
144 Summary:        The DALi Tizen Adaptor for mobile
145 Provides:       %{name}-compat = %{version}-%{release}
146 Conflicts:      %{name}-profile_tv
147 Conflicts:      %{name}-profile_wearable
148 Conflicts:      %{name}-profile_ivi
149 Conflicts:      %{name}-profile_common
150 %description profile_mobile
151 The DALi Tizen Adaptor for mobile.
152 %endif
153
154 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
155 # if tv ||"undefined"
156 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
157 %package profile_tv
158 Summary:        The DALi Tizen Adaptor for tv
159 Provides:       %{name}-compat = %{version}-%{release}
160 Conflicts:      %{name}-profile_mobile
161 Conflicts:      %{name}-profile_wearable
162 Conflicts:      %{name}-profile_ivi
163 Conflicts:      %{name}-profile_common
164 %description profile_tv
165 The DALi Tizen Adaptor for tv.
166 %endif
167
168 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
169 # if wearable || "undefined"
170 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
171 %package profile_wearable
172 Summary:        The DALi Tizen Adaptor for wearable
173 Provides:       %{name}-compat = %{version}-%{release}
174 Conflicts:      %{name}-profile_mobile
175 Conflicts:      %{name}-profile_tv
176 Conflicts:      %{name}-profile_ivi
177 Conflicts:      %{name}-profile_common
178 %description profile_wearable
179 The DALi Tizen Adaptor for wearable.
180 %endif
181
182 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
183 # if ivi ||"undefined"
184 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
185 %package profile_ivi
186 Summary:        The DALi Tizen Adaptor for ivi
187 Provides:       %{name}-compat = %{version}-%{release}
188 Conflicts:      %{name}-profile_mobile
189 Conflicts:      %{name}-profile_wearable
190 Conflicts:      %{name}-profile_tv
191 Conflicts:      %{name}-profile_common
192 %description profile_ivi
193 The DALi Tizen Adaptor for ivi.
194 %endif
195
196 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
197 # if common ||"undefined"
198 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
199 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
200 %package profile_common
201 %define tizen_2_2_compatibility 0
202 Summary:        The DALi Tizen Adaptor for common
203 Provides:       %{name}-compat = %{version}-%{release}
204 Conflicts:      %{name}-profile_mobile
205 Conflicts:      %{name}-profile_wearable
206 Conflicts:      %{name}-profile_tv
207 Conflicts:      %{name}-profile_ivi
208 %description profile_common
209 The DALi Tizen Adaptor for common.
210 %endif
211
212 ##############################
213 # devel
214 ##############################
215 %package devel
216 Summary:    Development components for the DALi Tizen Adaptor
217 Group:      Development/Building
218 Requires:   %{name} = %{version}-%{release}
219 Requires:   %{name}-integration-devel = %{version}-%{release}
220
221 %description devel
222 Development components for the DALi Tizen Adaptor - public headers and package configs
223
224 ##############################
225 # integration-devel
226 ##############################
227 %package integration-devel
228 Summary:    Integration development package for the Adaptor
229 Group:      Development/Building
230 Requires:   %{name} = %{version}-%{release}
231
232 %description integration-devel
233 Integration development package for the Adaptor - headers for integrating with an adaptor library.
234
235 ##############################
236 # Dali Feedback Plugin
237 ##############################
238 %package dali-feedback-plugin
239 Summary:    Plugin to play haptic and audio feedback for Dali
240 Group:      System/Libraries
241 Requires:   %{name} = %{version}-%{release}
242 %description dali-feedback-plugin
243 Feedback plugin to play haptic and audio feedback for Dali
244
245 ##############################
246 # Dali VideoPlayer Plugin
247 ##############################
248 %if %{with wayland}
249
250 %package dali-video-player-plugin
251 Summary:    Plugin to play a video file for Dali
252 Group:      System/Libraries
253 %description dali-video-player-plugin
254 VideoPlayer plugin to play a video file for Dali
255 %endif
256
257 ##############################
258 # Preparation
259 ##############################
260 %prep
261 %setup -q
262
263 #Use TZ_PATH when tizen version is 3.x or greater
264
265 %if 0%{?tizen_version_major} >= 3
266 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
267 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
268 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
269 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
270 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
271 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
272 %else
273 %define dali_data_rw_dir         /usr/share/dali/
274 %define dali_data_ro_dir         /usr/share/dali/
275 %define font_preloaded_path      /usr/share/fonts/
276 %define font_downloaded_path     /opt/share/fonts/
277 %define font_application_path    /usr/share/app_fonts/
278 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
279 %endif
280
281 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
282 %define dali_plugin_sound_files  /plugins/sounds/
283 %define dev_include_path %{_includedir}
284
285 ##############################
286 # Build
287 ##############################
288 %build
289 PREFIX+="/usr"
290 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
291 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
292
293 %ifarch %{arm}
294 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
295 %endif
296
297 %if %{with wayland}
298 CFLAGS+=" -DWAYLAND"
299 CXXFLAGS+=" -DWAYLAND"
300 configure_flags="--enable-wayland"
301 %endif
302
303 # Use this conditional when Tizen version is 4.x or greater
304 %if 0%{?tizen_version_major} >= 4
305 CXXFLAGS+=" -DOVER_TIZEN_VERSION_4"
306 %endif
307
308 %if 0%{?tizen_2_2_compatibility}
309 CFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
310 CXXFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
311 %endif
312
313 libtoolize --force
314 cd %{_builddir}/%{name}-%{version}/build/tizen
315 autoreconf --install
316
317 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
318 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
319 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
320 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
321 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
322 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
323 %if 0%{?tizen_platform_config_supported}
324 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
325 %endif
326
327 # Default to GLES 2.0 if not specified.
328 %define target_gles_version 20
329
330 # Set up the build via configure.
331 #######################################################################
332 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
333 # if mobile || "undefined"
334 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
335
336 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
337            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
338            --enable-tizen-major-version=%{tizen_version_major} \
339 %if 0%{?tizen_version_major} >= 3
340            --enable-feedback \
341 %endif
342            --enable-videoplayer \
343 %if 0%{?tizen_2_2_compatibility}
344            --with-tizen-2-2-compatibility \
345 %endif
346 %if %{with wayland}
347            --enable-efl=no \
348 %else
349            --enable-efl=yes \
350 %endif
351 %if 0%{?enable_debug}
352            --enable-debug \
353 %endif
354            --enable-appfw=yes \
355            $configure_flags --libdir=%{_libdir}
356
357 # Build.
358 make %{?jobs:-j%jobs}
359
360 pushd %{_builddir}/%{name}-%{version}/build/tizen
361 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
362 popd
363
364 pushd %{buildroot}%{_libdir}
365 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.mobile"; done
366 popd
367
368 make clean
369
370 %endif
371
372 #######################################################################
373 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
374 # if tv ||"undefined"
375 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
376
377 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
378            --enable-shaderbincache=DISABLE --enable-profile=TV \
379            --enable-tizen-major-version=%{tizen_version_major} \
380 %if 0%{?tizen_version_major} >= 3
381            --enable-feedback \
382 %endif
383            --enable-videoplayer \
384 %if 0%{?tizen_2_2_compatibility}
385            --with-tizen-2-2-compatibility \
386 %endif
387 %if %{with wayland}
388            --enable-efl=no \
389 %else
390            --enable-efl=yes \
391 %endif
392 %if 0%{?enable_debug}
393            --enable-debug \
394 %endif
395            --enable-appfw=yes \
396            $configure_flags --libdir=%{_libdir}
397
398 # Build.
399 make %{?jobs:-j%jobs}
400
401 pushd %{_builddir}/%{name}-%{version}/build/tizen
402 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
403 popd
404
405 pushd %{buildroot}%{_libdir}
406 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.tv"; done
407 popd
408
409 make clean
410 %endif
411
412 #######################################################################
413 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
414 # if wearable || "undefined"
415 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
416
417 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
418            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
419            --enable-tizen-major-version=%{tizen_version_major} \
420 %if 0%{?tizen_version_major} >= 3
421            --enable-feedback \
422 %endif
423            --enable-videoplayer \
424 %if 0%{?tizen_2_2_compatibility}
425            --with-tizen-2-2-compatibility \
426 %endif
427 %if %{with wayland}
428            --enable-efl=no \
429 %else
430            --enable-efl=yes \
431 %endif
432 %if 0%{?enable_debug}
433            --enable-debug \
434 %endif
435            --enable-appfw=yes \
436            $configure_flags --libdir=%{_libdir}
437
438 # Build.
439 make %{?jobs:-j%jobs}
440
441 pushd %{_builddir}/%{name}-%{version}/build/tizen
442 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
443 popd
444
445 pushd %{buildroot}%{_libdir}
446 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.wearable"; done
447 popd
448
449 make clean
450 %endif
451
452 #######################################################################
453 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
454 # if ivi ||"undefined"
455 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
456
457 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
458            --enable-shaderbincache=DISABLE --enable-profile=IVI \
459            --enable-tizen-major-version=%{tizen_version_major} \
460 %if 0%{?tizen_version_major} >= 3
461            --enable-feedback \
462 %endif
463            --enable-videoplayer \
464 %if 0%{?tizen_2_2_compatibility}
465            --with-tizen-2-2-compatibility \
466 %endif
467 %if %{with wayland}
468            --enable-efl=no \
469 %else
470            --enable-efl=yes \
471 %endif
472 %if 0%{?enable_debug}
473            --enable-debug \
474 %endif
475            --enable-appfw=yes \
476            $configure_flags --libdir=%{_libdir}
477
478 # Build.
479 make %{?jobs:-j%jobs}
480
481 pushd %{_builddir}/%{name}-%{version}/build/tizen
482 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
483 popd
484
485 pushd %{buildroot}%{_libdir}
486 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.ivi"; done
487 popd
488
489 make clean
490 %endif
491
492 #######################################################################
493 # common ( build dali_videoplayer_plugin for common uses )
494 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
495 # if common ||"undefined"
496 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
497
498 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
499            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
500            --enable-tizen-major-version=%{tizen_version_major} \
501 %if 0%{?tizen_version_major} >= 3
502            --enable-feedback \
503 %endif
504            --enable-videoplayer \
505 %if 0%{?tizen_2_2_compatibility}
506            --with-tizen-2-2-compatibility \
507 %endif
508 %if %{with wayland}
509            --enable-efl=no \
510 %else
511            --enable-efl=yes \
512 %endif
513 %if 0%{?enable_debug}
514            --enable-debug \
515 %endif
516            --enable-appfw=yes \
517            $configure_flags --libdir=%{_libdir}
518
519 # Build.
520 make %{?jobs:-j%jobs}
521
522 %endif
523
524
525 ##############################
526 # Installation
527 ##############################
528 %install
529 rm -rf %{buildroot}
530
531 pushd %{_builddir}/%{name}-%{version}/build/tizen
532 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
533
534
535 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
536 # !unified && (wearable || tv || ivi || mobile)
537 %if "%{?profile}" == "wearable" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "mobile"
538 rm -rf %{buildroot}%{_libdir}/libdali-adap*.so*
539 %endif
540
541 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
542 # wearable || tv || ivi || mobile || unified
543 %if "%{?profile}" != "common"
544 for FILE in libdali-*.so*; do mv "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
545 %endif
546 popd
547
548 ##############################
549 # Upgrade order:
550 # 1 - Pre Install new package
551 # 2 - Install new package
552 # 3 - Post install new package
553 # 4 - Pre uninstall old package
554 # 5 - Remove files not overwritten by new package
555 # 6 - Post uninstall old package
556 ##############################
557
558 %pre
559 exit 0
560
561 ##############################
562 #  Post Install new package
563 ##############################
564 %post
565 /sbin/ldconfig
566 exit 0
567
568 ##############################
569 #  Pre Uninstall old package
570 ##############################
571 %preun
572 exit 0
573
574 ##############################
575 #  Post Uninstall old package
576 ##############################
577 %postun
578 /sbin/ldconfig
579 exit 0
580
581 %if %{with wayland}
582 %post dali-video-player-plugin
583 /sbin/ldconfig
584 exit 0
585 %endif
586
587 %if %{with wayland}
588 %postun dali-video-player-plugin
589 /sbin/ldconfig
590 exit 0
591 %endif
592
593
594 ##############################
595
596 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
597 # if mobile || "undefined"
598 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
599 %post profile_mobile
600 pushd %{_libdir}
601 for FILE in libdali-adap*.so*.mobile; do ln -sf "$FILE" "${FILE%.mobile}"; done
602 popd
603 /sbin/ldconfig
604 exit 0
605
606 %postun profile_mobile
607 /sbin/ldconfig
608 exit 0
609 %endif
610
611 ##############################
612
613 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
614 # if tv ||"undefined"
615 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
616 %post profile_tv
617 pushd %{_libdir}
618 for FILE in libdali-adap*.so*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
619 popd
620 /sbin/ldconfig
621 exit 0
622
623 %postun profile_tv
624 /sbin/ldconfig
625 exit 0
626 %endif
627
628 ##############################
629
630 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
631 # if wearable || "undefined"
632 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
633 %post profile_wearable
634 pushd %{_libdir}
635 for FILE in libdali-adap*.so*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
636 popd
637 /sbin/ldconfig
638 exit 0
639
640 %postun profile_wearable
641 /sbin/ldconfig
642 exit 0
643 %endif
644
645 ##############################
646
647 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
648 # if ivi ||"undefined"
649 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
650 %post profile_ivi
651 pushd %{_libdir}
652 for FILE in libdali-adap*.so*.ivi; do ln -sf "$FILE" "${FILE%.ivi}"; done
653 popd
654 /sbin/ldconfig
655 exit 0
656
657 %postun profile_ivi
658 /sbin/ldconfig
659 exit 0
660 %endif
661
662
663 ##############################
664 # Files in Binary Packages
665 ##############################
666
667 %files
668 %manifest dali-adaptor.manifest
669 %defattr(-,root,root,-)
670 %defattr(-,app,app,-)
671 %dir %{user_shader_cache_dir}
672 %{_bindir}/*
673 %license LICENSE
674
675 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
676 # if common ||"undefined"
677 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
678 %defattr(-,root,root,-)
679 %{_libdir}/libdali-adap*.so*
680 %exclude %{_libdir}/libdali-adap*.so*.mobile
681 %exclude %{_libdir}/libdali-adap*.so*.wearable
682 %exclude %{_libdir}/libdali-adap*.so*.tv
683 %exclude %{_libdir}/libdali-adap*.so*.ivi
684 %endif
685
686 %if %{with wayland}
687 %files dali-video-player-plugin
688 %manifest dali-adaptor.manifest
689 %defattr(-,root,root,-)
690 %{_libdir}/libdali-video-player-plugin.so*
691 %license LICENSE
692 %endif
693
694 %if 0%{?tizen_version_major} >= 3
695 %files dali-feedback-plugin
696 %manifest dali-adaptor.manifest
697 %defattr(-,root,root,-)
698 %{_libdir}/libdali-feedback-plugin.so*
699 %{dali_plugin_sound_files}/*
700 %endif
701
702 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
703 # if common ||"undefined"
704 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
705 %files profile_common
706 # default .so files are housed in the main pkg.
707 %endif
708
709 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
710 # if mobile || "undefined"
711 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
712 %files profile_mobile
713 %manifest dali-adaptor.manifest
714 %defattr(-,root,root,-)
715 %{_libdir}/libdali-adap*.so*.mobile
716 %endif
717
718 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
719 # if tv ||"undefined"
720 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
721 %files profile_tv
722 %manifest dali-adaptor.manifest
723 %defattr(-,root,root,-)
724 %{_libdir}/libdali-adap*.so*.tv
725 %endif
726
727 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
728 # if wearable || "undefined"
729 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
730 %files profile_wearable
731 %manifest dali-adaptor.manifest
732 %defattr(-,root,root,-)
733 %{_libdir}/libdali-adap*.so*.wearable
734 %endif
735
736 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
737 # if ivi ||"undefined"
738 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
739 %files profile_ivi
740 %manifest dali-adaptor.manifest
741 %defattr(-,root,root,-)
742 %{_libdir}/libdali-adap*.so*.ivi
743 %endif
744
745
746 %files devel
747 %defattr(-,root,root,-)
748 %{dev_include_path}/dali/dali.h
749 %{dev_include_path}/dali/public-api/*
750 %{dev_include_path}/dali/devel-api/*
751 %{dev_include_path}/dali/doc/*
752 %{_libdir}/pkgconfig/dali-adaptor.pc
753
754 %files integration-devel
755 %defattr(-,root,root,-)
756 %{dev_include_path}/dali/integration-api/adaptors/*
757 %{_libdir}/pkgconfig/dali-adaptor-integration.pc