8bf1eecf9c907d60c018683cfa53ff2c03c2d1b4
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali2-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    2.1.20
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30
31 %define tizen_platform_config_supported 1
32 BuildRequires:  pkgconfig(libtzplatform-config)
33
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(capi-appfw-watch-application)
38 BuildRequires:  pkgconfig(appcore-watch)
39 %endif
40
41 BuildRequires:  pkgconfig(screen_connector_provider)
42 BuildRequires:  pkgconfig(gles20)
43 BuildRequires:  pkgconfig(glesv2)
44 BuildRequires:  pkgconfig(ttrace)
45
46 BuildRequires:  dali2-devel
47 BuildRequires:  dali2-integration-devel
48
49 BuildRequires:  pkgconfig
50 BuildRequires:  gawk
51 BuildRequires:  cmake
52 BuildRequires:  giflib-devel
53 BuildRequires:  pkgconfig(fontconfig)
54 BuildRequires:  libjpeg-turbo-devel
55 BuildRequires:  pkgconfig(vconf)
56 BuildRequires:  tts-devel
57 BuildRequires:  pkgconfig(dlog)
58 BuildRequires:  libdrm-devel
59 BuildRequires:  pkgconfig(libexif)
60 BuildRequires:  pkgconfig(libpng)
61 BuildRequires:  pkgconfig(egl)
62 BuildRequires:  libcurl-devel
63 BuildRequires:  pkgconfig(harfbuzz)
64 BuildRequires:  hyphen-devel
65 BuildRequires:  fribidi-devel
66
67 BuildRequires:  pkgconfig(capi-system-info)
68 BuildRequires:  pkgconfig(capi-system-sensor)
69
70 BuildRequires:  pkgconfig(cairo)
71
72 BuildRequires:  pkgconfig(wayland-egl)
73 BuildRequires:  pkgconfig(wayland-client)
74 BuildRequires:  pkgconfig(input-method-client)
75 BuildRequires:  wayland-devel
76 BuildRequires:  wayland-extension-client-devel
77
78 # WebP support only from Tizen 6 onwards
79 %if 0%{?tizen_version_major} >= 6
80 BuildRequires:  pkgconfig(libwebp)
81 BuildRequires:  pkgconfig(libwebpdecoder)
82 BuildRequires:  pkgconfig(libwebpdemux)
83 BuildRequires:  pkgconfig(libwebpmux)
84 %endif
85
86 # We use ecore mainloop
87 %if 0%{?tizen_version_major} >= 5
88 BuildRequires:  pkgconfig(ecore-wl2)
89 BuildRequires:  pkgconfig(wayland-egl-tizen)
90 %else
91 BuildRequires:  pkgconfig(ecore-wayland)
92 %endif
93
94 # We need tbm_surface in tizen 3.0 wayland
95 BuildRequires:  pkgconfig(libtbm)
96
97 # for the adaptor
98 BuildRequires:  pkgconfig(appcore-ui)
99 BuildRequires:  pkgconfig(appcore-widget-base)
100 BuildRequires:  pkgconfig(bundle)
101 BuildRequires:  pkgconfig(capi-appfw-app-common)
102 BuildRequires:  pkgconfig(capi-appfw-app-control)
103 BuildRequires:  pkgconfig(ecore-imf)
104
105 BuildRequires:  pkgconfig(capi-system-system-settings)
106
107 # for ATSPI (Accessibility) support
108 BuildRequires:  pkgconfig(eldbus)
109
110 # for feedback plugin
111 BuildRequires:  pkgconfig(mm-sound)
112 BuildRequires:  pkgconfig(feedback)
113 BuildRequires:  pkgconfig(component-based-core-base)
114
115
116 %if ( 0%{?tizen_version_major} == 6 && 0%{?tizen_version_minor} >= 5 ) || 0%{?tizen_version_major} >= 7
117 BuildRequires:  pkgconfig(thorvg)
118 %endif
119
120 # for multiprofile
121 Requires:   %{name}-compat = %{version}-%{release}
122 Recommends: %{name}-profile_common = %{version}-%{release}
123
124 %description
125 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
126 platform abstraction and application shell
127
128 ###########################################
129 # Dali adapter for profiles
130 ###########################################
131
132 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
133 # if mobile || "undefined"
134 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
135 %package profile_mobile
136 Summary:        The DALi Tizen Adaptor for mobile
137 Provides:       %{name}-compat = %{version}-%{release}
138 Conflicts:      %{name}-profile_tv
139 Conflicts:      %{name}-profile_wearable
140 Conflicts:      %{name}-profile_ivi
141 Conflicts:      %{name}-profile_common
142 Requires:       %{name}
143 %description profile_mobile
144 The DALi Tizen Adaptor for mobile.
145 %endif
146
147 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
148 # if tv ||"undefined"
149 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
150 %package profile_tv
151 Summary:        The DALi Tizen Adaptor for tv
152 Provides:       %{name}-compat = %{version}-%{release}
153 Conflicts:      %{name}-profile_mobile
154 Conflicts:      %{name}-profile_wearable
155 Conflicts:      %{name}-profile_ivi
156 Conflicts:      %{name}-profile_common
157 Requires:       %{name}
158 %description profile_tv
159 The DALi Tizen Adaptor for tv.
160 %endif
161
162 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
163 # if wearable || "undefined"
164 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
165 %package profile_wearable
166 Summary:        The DALi Tizen Adaptor for wearable
167 Provides:       %{name}-compat = %{version}-%{release}
168 Conflicts:      %{name}-profile_mobile
169 Conflicts:      %{name}-profile_tv
170 Conflicts:      %{name}-profile_ivi
171 Conflicts:      %{name}-profile_common
172 Requires:       %{name}
173 %description profile_wearable
174 The DALi Tizen Adaptor for wearable.
175 %endif
176
177 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
178 # if ivi ||"undefined"
179 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
180 %package profile_ivi
181 Summary:        The DALi Tizen Adaptor for ivi
182 Provides:       %{name}-compat = %{version}-%{release}
183 Conflicts:      %{name}-profile_mobile
184 Conflicts:      %{name}-profile_wearable
185 Conflicts:      %{name}-profile_tv
186 Conflicts:      %{name}-profile_common
187 Requires:       %{name}
188 %description profile_ivi
189 The DALi Tizen Adaptor for ivi.
190 %endif
191
192 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
193 # if common ||"undefined"
194 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
195 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
196 %package profile_common
197 Summary:        The DALi Tizen Adaptor for common
198 Provides:       %{name}-compat = %{version}-%{release}
199 Conflicts:      %{name}-profile_mobile
200 Conflicts:      %{name}-profile_wearable
201 Conflicts:      %{name}-profile_tv
202 Conflicts:      %{name}-profile_ivi
203 Requires:       %{name}
204 %description profile_common
205 The DALi Tizen Adaptor for common.
206 %endif
207
208 ##############################
209 # devel
210 ##############################
211 %package devel
212 Summary:    Development components for the DALi Tizen Adaptor
213 Group:      Development/Building
214 Requires:   %{name} = %{version}-%{release}
215 Requires:   %{name}-integration-devel = %{version}-%{release}
216
217 %description devel
218 Development components for the DALi Tizen Adaptor - public headers and package configs
219
220 ##############################
221 # integration-devel
222 ##############################
223 %package integration-devel
224 Summary:    Integration development package for the Adaptor
225 Group:      Development/Building
226 Requires:   %{name} = %{version}-%{release}
227
228 %description integration-devel
229 Integration development package for the Adaptor - headers for integrating with an adaptor library.
230
231 ##############################
232 # Dali Feedback Plugin
233 ##############################
234 %package dali2-feedback-plugin
235 Summary:    Plugin to play haptic and audio feedback for Dali
236 Group:      System/Libraries
237 Requires:   %{name} = %{version}-%{release}
238 %description dali2-feedback-plugin
239 Feedback plugin to play haptic and audio feedback for Dali
240
241 #Use TZ_PATH when tizen version is 3.x or greater
242 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
243 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
244 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
245 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
246 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
247 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
248
249 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
250 %define dali_plugin_sound_files  /plugins/sounds/
251
252 ##############################
253 # Preparation
254 ##############################
255 %prep
256 %setup -q
257
258
259 ##############################
260 # Build
261 ##############################
262 %build
263 PREFIX+="/usr"
264 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
265 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
266
267 %ifarch %{arm}
268 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
269 %endif
270
271 CFLAGS+=" -DWAYLAND"
272 CXXFLAGS+=" -DWAYLAND"
273 cmake_flags=" -DENABLE_WAYLAND=ON -DENABLE_ATSPI=ON -DENABLE_TRACE=ON"
274
275 # Use this conditional when Tizen version is 5.x or greater
276 %if 0%{?tizen_version_major} >= 5
277 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
278
279 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
280 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
281 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
282 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
283 %endif
284
285 # Use this conditional when Tizen version is 7.x or greater
286 %if 0%{?tizen_version_major} >= 7
287 CXXFLAGS+=" -DOVER_TIZEN_VERSION_7"
288 %endif
289
290 %if 0%{?enable_debug}
291 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
292 %endif
293
294 %if 0%{?enable_logging}
295 cmake_flags+=" -DENABLE_NETWORK_LOGGING=ON"
296 %endif
297
298 libtoolize --force
299 cd %{_builddir}/%{name}-%{version}/build/tizen
300
301 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
302 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
303 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
304 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
305 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
306 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
307 %if 0%{?tizen_platform_config_supported}
308 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
309 %endif
310
311 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
312 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
313 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
314 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
315 cmake_flags+=" -DENABLE_FEEDBACK=YES"
316 cmake_flags+=" -DENABLE_APPFW=YES"
317 cmake_flags+=" -DCOMPONENT_APPLICATION_SUPPORT=YES"
318
319 # Set up the build via Cmake
320 #######################################################################
321 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
322 # if mobile || "undefined"
323 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
324
325 mkdir -p mobile
326 pushd mobile
327
328 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
329
330 # Build.
331 make %{?jobs:-j%jobs}
332 popd
333
334 %endif
335
336 #######################################################################
337 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
338 # if tv ||"undefined"
339 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
340
341 mkdir -p tv
342 pushd tv
343
344 cmake -DENABLE_PROFILE=TV $cmake_flags ..
345
346 # Build.
347 make %{?jobs:-j%jobs}
348 popd
349
350 %endif
351
352 #######################################################################
353 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
354 # if wearable || "undefined"
355 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
356
357 mkdir -p wearable
358 pushd wearable
359
360 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
361
362 # Build.
363 make %{?jobs:-j%jobs}
364 popd
365
366 %endif
367
368 #######################################################################
369 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
370 # if ivi ||"undefined"
371 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
372
373 mkdir -p ivi
374 pushd ivi
375
376 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
377
378 # Build.
379 make %{?jobs:-j%jobs}
380 popd
381
382 %endif
383
384 #######################################################################
385 # common
386 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
387 # if common ||"undefined"
388 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
389
390 mkdir -p common
391 pushd common
392
393 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
394
395 # Build.
396 make %{?jobs:-j%jobs}
397 popd
398
399 %endif
400
401 ##############################
402 # Installation
403 ##############################
404 %install
405 rm -rf %{buildroot}
406
407 pushd %{_builddir}/%{name}-%{version}/build/tizen
408
409 # if mobile || "undefined"
410 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
411 pushd mobile
412 %make_install
413 %if "%{?profile}" != "mobile"
414 pushd  %{buildroot}%{_libdir}
415 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
416 popd
417 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
418 %endif
419 popd
420 %endif
421
422 # if tv ||"undefined"
423 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
424 pushd tv
425 %make_install
426 %if "%{?profile}" != "tv"
427 pushd  %{buildroot}%{_libdir}
428 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
429 popd
430 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
431 %endif
432 popd
433 %endif
434
435 # if wearable || "undefined"
436 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
437 pushd wearable
438 %make_install
439 %if "%{?profile}" != "wearable"
440 pushd  %{buildroot}%{_libdir}
441 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
442 popd
443 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
444 %endif
445 popd
446 %endif
447
448 # if ivi ||"undefined"
449 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
450 pushd ivi
451 %make_install
452 %if "%{?profile}" != "ivi"
453 pushd  %{buildroot}%{_libdir}
454 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
455 popd
456 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
457 %endif
458 popd
459 %endif
460
461 # if common ||"undefined"
462 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
463 pushd common
464 %make_install
465 # No clean so we can gather symbol/size information for the common profile
466 popd
467 %endif
468
469 # Create a symbolic link in integration-api to preserve legacy repo build
470 pushd %{buildroot}%{_includedir}/dali/integration-api
471 ln -sf adaptor-framework adaptors
472 popd
473
474 ##############################
475 # Upgrade order:
476 # 1 - Pre Install new package
477 # 2 - Install new package
478 # 3 - Post install new package
479 # 4 - Pre uninstall old package
480 # 5 - Remove files not overwritten by new package
481 # 6 - Post uninstall old package
482 ##############################
483
484 ##############################
485 # Adaptor package Commands
486 %pre
487 exit 0
488
489 %post
490 pushd %{_libdir}
491 for i in mobile tv wearable ivi; do [[ -f libdali2-adaptor.so.$i ]] && ln -sf libdali2-adaptor.so.$i libdali2-adaptor.so.2.0.0; done
492 popd
493 /sbin/ldconfig
494 exit 0
495
496 %preun
497 exit 0
498
499 %postun
500 /sbin/ldconfig
501 exit 0
502
503 ##############################
504 # Mobile Profile Commands
505 # if mobile || "undefined"
506 # No need to create a symbolic link on install required if only building this profile
507 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
508 %post profile_mobile
509 %if "%{?profile}" != "mobile"
510 pushd %{_libdir}
511 ln -sf libdali2-adaptor.so.mobile libdali2-adaptor.so.2.0.0
512 popd
513 %endif
514 /sbin/ldconfig
515 exit 0
516
517 %postun profile_mobile
518 /sbin/ldconfig
519 exit 0
520 %endif
521
522 ##############################
523 # TV Profile Commands
524 # No need to create a symbolic link on install required if only building this profile
525 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
526 %post profile_tv
527 %if "%{?profile}" != "tv"
528 pushd %{_libdir}
529 ln -sf libdali2-adaptor.so.tv libdali2-adaptor.so.2.0.0
530 popd
531 %endif
532 /sbin/ldconfig
533 exit 0
534
535 %postun profile_tv
536 /sbin/ldconfig
537 exit 0
538 %endif
539
540 ##############################
541 # Wearable Profile Commands
542 # No need to create a symbolic link on install required if only building this profile
543 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
544 %post profile_wearable
545 %if "%{?profile}" != "wearable"
546 pushd %{_libdir}
547 ln -sf libdali2-adaptor.so.wearable libdali2-adaptor.so.2.0.0
548 popd
549 %endif
550 /sbin/ldconfig
551 exit 0
552
553 %postun profile_wearable
554 /sbin/ldconfig
555 exit 0
556 %endif
557
558 ##############################
559 # IVI Profile Commands
560 # No need to create a symbolic link on install required if only building this profile
561 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
562 %post profile_ivi
563 %if "%{?profile}" != "ivi"
564 pushd %{_libdir}
565 ln -sf libdali2-adaptor.so.ivi libdali2-adaptor.so.2.0.0
566 popd
567 %endif
568 /sbin/ldconfig
569 exit 0
570
571 %postun profile_ivi
572 /sbin/ldconfig
573 exit 0
574 %endif
575
576 ##############################
577 # Common Profile Commands
578 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
579 %post profile_common
580 /sbin/ldconfig
581 exit 0
582
583 %postun profile_common
584 /sbin/ldconfig
585 exit 0
586 %endif
587
588 ##############################
589 # Files in Binary Packages
590 ##############################
591
592 %files
593 %manifest dali-adaptor.manifest
594 %defattr(-,root,root,-)
595 %dir %{user_shader_cache_dir}
596 %{_bindir}/*
597 %license LICENSE
598 %defattr(-,root,root,-)
599 %{_libdir}/libdali2-adaptor.so
600 %{_libdir}/libdali2-adaptor.so.2
601 %{_libdir}/libdali2-adaptor.so.2.0.0
602
603 #################################################
604
605 %files dali2-feedback-plugin
606 %manifest dali-adaptor.manifest
607 %defattr(-,root,root,-)
608 %{_libdir}/libdali2-feedback-plugin.so*
609 %{dali_plugin_sound_files}/*
610
611 #################################################
612
613 # if common ||"undefined"
614 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
615 %files profile_common
616 %manifest dali-adaptor.manifest
617 # default .so files are housed in the main pkg.
618 %endif
619
620 # if mobile || "undefined"
621 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
622 %files profile_mobile
623 %manifest dali-adaptor.manifest
624 %defattr(-,root,root,-)
625 %if "%{?profile}" != "mobile"
626 %{_libdir}/libdali2-adaptor.so.mobile
627 %endif
628 %endif
629
630 # if tv ||"undefined"
631 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
632 %files profile_tv
633 %manifest dali-adaptor.manifest
634 %defattr(-,root,root,-)
635 %if "%{?profile}" != "tv"
636 %{_libdir}/libdali2-adaptor.so.tv
637 %endif
638 %endif
639
640 # if wearable || "undefined"
641 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
642 %files profile_wearable
643 %manifest dali-adaptor.manifest
644 %defattr(-,root,root,-)
645 %if "%{?profile}" != "wearable"
646 %{_libdir}/libdali2-adaptor.so.wearable
647 %endif
648 %endif
649
650 # if ivi ||"undefined"
651 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
652 %files profile_ivi
653 %manifest dali-adaptor.manifest
654 %defattr(-,root,root,-)
655 %if "%{?profile}" != "ivi"
656 %{_libdir}/libdali2-adaptor.so.ivi
657 %endif
658 %endif
659
660 %files devel
661 %defattr(-,root,root,-)
662 %{_includedir}/dali/dali.h
663 %{_includedir}/dali/public-api/*
664 %{_includedir}/dali/devel-api/*
665 %{_includedir}/dali/doc/*
666 %{_libdir}/pkgconfig/dali2-adaptor.pc
667
668 %files integration-devel
669 %defattr(-,root,root,-)
670 %{_includedir}/dali/integration-api/adaptor-framework/*
671 %{_includedir}/dali/integration-api/adaptors
672 %{_libdir}/pkgconfig/dali2-adaptor-integration.pc