5c76fc25215a61817f1e0eecdd677fbc53501b0d
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 %bcond_with wayland
19
20 Name:       dali-adaptor
21 Summary:    The DALi Tizen Adaptor
22 Version:    1.2.42
23 Release:    1
24 Group:      System/Libraries
25 License:    Apache-2.0 and BSD-3-Clause and MIT
26 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
27 Source0:    %{name}-%{version}.tar.gz
28
29 Requires(post): /sbin/ldconfig
30 Requires(postun): /sbin/ldconfig
31 Requires:       giflib
32
33 #need libtzplatform-config for directory if tizen version is 3.x
34
35 %if 0%{?tizen_version_major} >= 3
36 %define tizen_platform_config_supported 1
37 BuildRequires:  pkgconfig(libtzplatform-config)
38 %endif
39
40
41 # Get the profile from tizen_profile_name if tizen version is 2.x and tizen_profile_name exists.
42
43 %if "%{tizen_version_major}" == "2" && 0%{?tizen_profile_name:1}
44 %define profile %{tizen_profile_name}
45 %endif
46
47 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
48 # if wearable || "undefined"
49 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
50 BuildRequires:  pkgconfig(capi-appfw-watch-application)
51 BuildRequires:  pkgconfig(appcore-watch)
52 %endif
53
54 BuildRequires:  pkgconfig(gles20)
55 BuildRequires:  pkgconfig(glesv2)
56
57 BuildRequires:  pkgconfig
58 BuildRequires:  gawk
59 BuildRequires:  pkgconfig(aul)
60 BuildRequires:  giflib-devel
61 BuildRequires:  pkgconfig(fontconfig)
62 BuildRequires:  libjpeg-turbo-devel
63 BuildRequires:  dali-devel
64 BuildRequires:  dali-integration-devel
65 BuildRequires:  pkgconfig(vconf)
66 BuildRequires:  tts-devel
67 BuildRequires:  pkgconfig(dlog)
68 BuildRequires:  libdrm-devel
69 BuildRequires:  pkgconfig(libexif)
70 BuildRequires:  pkgconfig(libpng)
71 BuildRequires:  pkgconfig(egl)
72 BuildRequires:  libcurl-devel
73 BuildRequires:  pkgconfig(harfbuzz)
74 BuildRequires:  fribidi-devel
75
76 BuildRequires:  pkgconfig(capi-system-info)
77 BuildRequires:  pkgconfig(capi-system-sensor)
78
79 # Tizen currently does not have libuv as a separate libuv package
80 # So we have to look into the uv headers bundled inside node-js
81 BuildRequires:  nodejs-devel
82
83
84 %if %{with wayland}
85
86 ####### BUILDING FOR WAYLAND #######
87 BuildRequires:  pkgconfig(wayland-egl)
88 BuildRequires:  pkgconfig(wayland-client)
89 BuildRequires:  wayland-devel
90 BuildRequires:  wayland-extension-client-devel
91
92 # dali-adaptor-uv uses libuv mainloop and has its own wayland client (it needs wayland-client headers).
93 BuildRequires:  libxkbcommon-devel
94
95 # dali-adaptor uses ecore mainloop
96 BuildRequires:  pkgconfig(ecore-wayland)
97
98 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
99 BuildRequires:  pkgconfig(libtbm)
100
101 # tpkp-curl (certificate pinning for libcurl functions) is only available in Tizen 3.0
102 BuildRequires:  pkgconfig(tpkp-curl)
103
104 ####### BUILDING FOR X11#######
105 %else
106 BuildRequires:  pkgconfig(egl)
107 BuildRequires:  pkgconfig(xext)
108 BuildRequires:  pkgconfig(xi)
109 BuildRequires:  pkgconfig(xfixes)
110 BuildRequires:  pkgconfig(xdamage)
111 BuildRequires:  pkgconfig(utilX)
112 %endif
113
114 # for dali-adaptor
115 BuildRequires:  pkgconfig(evas)
116 BuildRequires:  pkgconfig(elementary)
117 BuildRequires:  pkgconfig(capi-appfw-application)
118 BuildRequires:  pkgconfig(capi-system-system-settings)
119
120 # for feedback plugin
121 BuildRequires:  pkgconfig(mm-sound)
122 %if 0%{?tizen_version_major} >= 3
123 BuildRequires:  pkgconfig(feedback)
124 %endif
125
126 # for videoplayer Plugin
127 BuildRequires:  pkgconfig(capi-media-player)
128
129
130 # for multiprofile
131 Requires:   %{name}-compat = %{version}-%{release}
132 Recommends: %{name}-profile_common = %{version}-%{release}
133
134 %description
135 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
136 platform abstraction and application shell
137
138 ###########################################
139 # Dali adapter for profiles
140 ###########################################
141
142 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
143 # if mobile || "undefined"
144 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
145 %package profile_mobile
146 Summary:        The DALi Tizen Adaptor for mobile
147 Provides:       %{name}-compat = %{version}-%{release}
148 Conflicts:      %{name}-profile_tv
149 Conflicts:      %{name}-profile_wearable
150 Conflicts:      %{name}-profile_ivi
151 Conflicts:      %{name}-profile_common
152 %description profile_mobile
153 The DALi Tizen Adaptor for mobile.
154 %endif
155
156 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
157 # if tv ||"undefined"
158 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
159 %package profile_tv
160 Summary:        The DALi Tizen Adaptor for tv
161 Provides:       %{name}-compat = %{version}-%{release}
162 Conflicts:      %{name}-profile_mobile
163 Conflicts:      %{name}-profile_wearable
164 Conflicts:      %{name}-profile_ivi
165 Conflicts:      %{name}-profile_common
166 %description profile_tv
167 The DALi Tizen Adaptor for tv.
168 %endif
169
170 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
171 # if wearable || "undefined"
172 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
173 %package profile_wearable
174 Summary:        The DALi Tizen Adaptor for wearable
175 Provides:       %{name}-compat = %{version}-%{release}
176 Conflicts:      %{name}-profile_mobile
177 Conflicts:      %{name}-profile_tv
178 Conflicts:      %{name}-profile_ivi
179 Conflicts:      %{name}-profile_common
180 %description profile_wearable
181 The DALi Tizen Adaptor for wearable.
182 %endif
183
184 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
185 # if ivi ||"undefined"
186 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
187 %package profile_ivi
188 Summary:        The DALi Tizen Adaptor for ivi
189 Provides:       %{name}-compat = %{version}-%{release}
190 Conflicts:      %{name}-profile_mobile
191 Conflicts:      %{name}-profile_wearable
192 Conflicts:      %{name}-profile_tv
193 Conflicts:      %{name}-profile_common
194 %description profile_ivi
195 The DALi Tizen Adaptor for ivi.
196 %endif
197
198 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
199 # if common ||"undefined"
200 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
201 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
202 %package profile_common
203 %define tizen_2_2_compatibility 0
204 Summary:        The DALi Tizen Adaptor for common
205 Provides:       %{name}-compat = %{version}-%{release}
206 Conflicts:      %{name}-profile_mobile
207 Conflicts:      %{name}-profile_wearable
208 Conflicts:      %{name}-profile_tv
209 Conflicts:      %{name}-profile_ivi
210 %description profile_common
211 The DALi Tizen Adaptor for common.
212 %endif
213
214 ##############################
215 # devel
216 ##############################
217 %package devel
218 Summary:    Development components for the DALi Tizen Adaptor
219 Group:      Development/Building
220 Requires:   %{name} = %{version}-%{release}
221 Requires:   %{name}-integration-devel = %{version}-%{release}
222
223 %description devel
224 Development components for the DALi Tizen Adaptor - public headers and package configs
225
226 ##############################
227 # integration-devel
228 ##############################
229 %package integration-devel
230 Summary:    Integration development package for the Adaptor
231 Group:      Development/Building
232 Requires:   %{name} = %{version}-%{release}
233
234 %description integration-devel
235 Integration development package for the Adaptor - headers for integrating with an adaptor library.
236
237 ##############################
238 # Dali Feedback Plugin
239 ##############################
240 %package dali-feedback-plugin
241 Summary:    Plugin to play haptic and audio feedback for Dali
242 Group:      System/Libraries
243 Requires:   %{name} = %{version}-%{release}
244 %description dali-feedback-plugin
245 Feedback plugin to play haptic and audio feedback for Dali
246
247 ##############################
248 # Dali VideoPlayer Plugin
249 ##############################
250 %if %{with wayland}
251
252 %package dali-video-player-plugin
253 Summary:    Plugin to play a video file for Dali
254 Group:      System/Libraries
255 %description dali-video-player-plugin
256 VideoPlayer plugin to play a video file for Dali
257 %endif
258
259 ##############################
260 # Preparation
261 ##############################
262 %prep
263 %setup -q
264
265 #Use TZ_PATH when tizen version is 3.x or greater
266
267 %if 0%{?tizen_version_major} >= 3
268 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
269 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
270 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
271 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
272 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
273 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
274 %else
275 %define dali_data_rw_dir         /usr/share/dali/
276 %define dali_data_ro_dir         /usr/share/dali/
277 %define font_preloaded_path      /usr/share/fonts/
278 %define font_downloaded_path     /opt/share/fonts/
279 %define font_application_path    /usr/share/app_fonts/
280 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
281 %endif
282
283 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
284 %define dali_plugin_sound_files  /plugins/sounds/
285 %define dev_include_path %{_includedir}
286
287 ##############################
288 # Build
289 ##############################
290 %build
291 PREFIX+="/usr"
292 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
293 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
294
295 %ifarch %{arm}
296 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
297 %endif
298
299 %if %{with wayland}
300 CFLAGS+=" -DWAYLAND"
301 CXXFLAGS+=" -DWAYLAND"
302 configure_flags="--enable-wayland"
303 %endif
304
305 %if 0%{?tizen_2_2_compatibility}
306 CFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
307 CXXFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
308 %endif
309
310 libtoolize --force
311 cd %{_builddir}/%{name}-%{version}/build/tizen
312 autoreconf --install
313
314 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
315 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
316 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
317 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
318 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
319 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
320 %if 0%{?tizen_platform_config_supported}
321 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
322 %endif
323
324 # Default to GLES 2.0 if not specified.
325 %{!?target_gles_version: %define target_gles_version 20}
326
327 #--enable-efl=no \ # only affects dali-adaptor-uv
328 #--enable-appfw=yes \ # affects both dali-adaptor & dali-adaptor-uv
329 #--with-libuv=/usr/include/node/ \ # only affects dali-adaptor-uv
330
331
332 # Set up the build via configure.
333 #######################################################################
334 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
335 # if mobile || "undefined"
336 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
337 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
338            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
339 %if 0%{?tizen_version_major} >= 3
340            --enable-feedback \
341 %endif
342            --enable-videoplayer \
343 %if 0%{?tizen_2_2_compatibility}
344            --with-tizen-2-2-compatibility \
345 %endif
346 %if %{with wayland}
347            --enable-efl=no \
348 %else
349            --enable-efl=yes \
350 %endif
351 %if 0%{?enable_debug}
352            --enable-debug \
353 %endif
354            --enable-appfw=yes \
355            --with-libuv=/usr/include/node/ \
356            $configure_flags --libdir=%{_libdir}
357
358 # Build.
359 make %{?jobs:-j%jobs}
360
361 pushd %{_builddir}/%{name}-%{version}/build/tizen
362 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
363 popd
364
365 pushd %{buildroot}%{_libdir}
366 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.mobile"; done
367 popd
368
369 %endif
370
371 #######################################################################
372 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
373 # if tv ||"undefined"
374 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
375 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
376            --enable-shaderbincache=DISABLE --enable-profile=TV \
377 %if 0%{?tizen_version_major} >= 3
378            --enable-feedback \
379 %endif
380            --enable-videoplayer \
381 %if 0%{?tizen_2_2_compatibility}
382            --with-tizen-2-2-compatibility \
383 %endif
384 %if %{with wayland}
385            --enable-efl=no \
386 %else
387            --enable-efl=yes \
388 %endif
389 %if 0%{?enable_debug}
390            --enable-debug \
391 %endif
392            --enable-appfw=yes \
393            --with-libuv=/usr/include/node/ \
394            $configure_flags --libdir=%{_libdir}
395
396 # Build.
397 make %{?jobs:-j%jobs}
398
399 pushd %{_builddir}/%{name}-%{version}/build/tizen
400 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
401 popd
402
403 pushd %{buildroot}%{_libdir}
404 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.tv"; done
405 popd
406
407 %endif
408
409 #######################################################################
410 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
411 # if wearable || "undefined"
412 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
413 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
414            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
415 %if 0%{?tizen_version_major} >= 3
416            --enable-feedback \
417 %endif
418            --enable-videoplayer \
419 %if 0%{?tizen_2_2_compatibility}
420            --with-tizen-2-2-compatibility \
421 %endif
422 %if %{with wayland}
423            --enable-efl=no \
424 %else
425            --enable-efl=yes \
426 %endif
427 %if 0%{?enable_debug}
428            --enable-debug \
429 %endif
430            --enable-appfw=yes \
431            --with-libuv=/usr/include/node/ \
432            $configure_flags --libdir=%{_libdir}
433
434 # Build.
435 make %{?jobs:-j%jobs}
436
437 pushd %{_builddir}/%{name}-%{version}/build/tizen
438 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
439 popd
440
441 pushd %{buildroot}%{_libdir}
442 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.wearable"; done
443 popd
444
445 %endif
446
447 #######################################################################
448 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
449 # if ivi ||"undefined"
450 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
451 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
452            --enable-shaderbincache=DISABLE --enable-profile=IVI \
453 %if 0%{?tizen_version_major} >= 3
454            --enable-feedback \
455 %endif
456            --enable-videoplayer \
457 %if 0%{?tizen_2_2_compatibility}
458            --with-tizen-2-2-compatibility \
459 %endif
460 %if %{with wayland}
461            --enable-efl=no \
462 %else
463            --enable-efl=yes \
464 %endif
465 %if 0%{?enable_debug}
466            --enable-debug \
467 %endif
468            --enable-appfw=yes \
469            --with-libuv=/usr/include/node/ \
470            $configure_flags --libdir=%{_libdir}
471
472 # Build.
473 make %{?jobs:-j%jobs}
474
475 pushd %{_builddir}/%{name}-%{version}/build/tizen
476 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
477 popd
478
479 pushd %{buildroot}%{_libdir}
480 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.ivi"; done
481 popd
482
483 %endif
484
485 #######################################################################
486 # common ( build dali_videoplayer_plugin for common uses )
487 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
488 # if common ||"undefined"
489 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
490 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
491            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
492 %if 0%{?tizen_version_major} >= 3
493            --enable-feedback \
494 %endif
495            --enable-videoplayer \
496 %if 0%{?tizen_2_2_compatibility}
497            --with-tizen-2-2-compatibility \
498 %endif
499 %if %{with wayland}
500            --enable-efl=no \
501 %else
502            --enable-efl=yes \
503 %endif
504 %if 0%{?enable_debug}
505            --enable-debug \
506 %endif
507            --enable-appfw=yes \
508            --with-libuv=/usr/include/node/ \
509            $configure_flags --libdir=%{_libdir}
510
511 # Build.
512 make %{?jobs:-j%jobs}
513 %endif
514
515
516 ##############################
517 # Installation
518 ##############################
519 %install
520 rm -rf %{buildroot}
521
522 pushd %{_builddir}/%{name}-%{version}/build/tizen
523 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
524
525
526 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
527 # !unified && (wearable || tv || ivi || mobile)
528 %if "%{?profile}" == "wearable" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "mobile"
529 rm -rf %{buildroot}%{_libdir}/libdali-adap*.so*
530 %endif
531
532 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
533 # wearable || tv || ivi || mobile || unified
534 %if "%{?profile}" != "common"
535 for FILE in libdali-*.so*; do mv "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
536 %endif
537 popd
538
539 ##############################
540 # Upgrade order:
541 # 1 - Pre Install new package
542 # 2 - Install new package
543 # 3 - Post install new package
544 # 4 - Pre uninstall old package
545 # 5 - Remove files not overwritten by new package
546 # 6 - Post uninstall old package
547 ##############################
548
549 %pre
550 exit 0
551
552 ##############################
553 #  Post Install new package
554 ##############################
555 %post
556 /sbin/ldconfig
557 exit 0
558
559 ##############################
560 #  Pre Uninstall old package
561 ##############################
562 %preun
563 exit 0
564
565 ##############################
566 #  Post Uninstall old package
567 ##############################
568 %postun
569 /sbin/ldconfig
570 exit 0
571
572 %if %{with wayland}
573 %post dali-video-player-plugin
574 /sbin/ldconfig
575 exit 0
576 %endif
577
578 %if %{with wayland}
579 %postun dali-video-player-plugin
580 /sbin/ldconfig
581 exit 0
582 %endif
583
584
585 ##############################
586
587 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
588 # if mobile || "undefined"
589 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
590 %post profile_mobile
591 pushd %{_libdir}
592 for FILE in libdali-adap*.so*.mobile; do ln -sf "$FILE" "${FILE%.mobile}"; done
593 popd
594 /sbin/ldconfig
595 exit 0
596
597 %postun profile_mobile
598 /sbin/ldconfig
599 exit 0
600 %endif
601
602 ##############################
603
604 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
605 # if tv ||"undefined"
606 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
607 %post profile_tv
608 pushd %{_libdir}
609 for FILE in libdali-adap*.so*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
610 popd
611 /sbin/ldconfig
612 exit 0
613
614 %postun profile_tv
615 /sbin/ldconfig
616 exit 0
617 %endif
618
619 ##############################
620
621 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
622 # if wearable || "undefined"
623 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
624 %post profile_wearable
625 pushd %{_libdir}
626 for FILE in libdali-adap*.so*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
627 popd
628 /sbin/ldconfig
629 exit 0
630
631 %postun profile_wearable
632 /sbin/ldconfig
633 exit 0
634 %endif
635
636 ##############################
637
638 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
639 # if ivi ||"undefined"
640 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
641 %post profile_ivi
642 pushd %{_libdir}
643 for FILE in libdali-adap*.so*.ivi; do ln -sf "$FILE" "${FILE%.ivi}"; done
644 popd
645 /sbin/ldconfig
646 exit 0
647
648 %postun profile_ivi
649 /sbin/ldconfig
650 exit 0
651 %endif
652
653
654 ##############################
655 # Files in Binary Packages
656 ##############################
657
658 %files
659 %manifest dali-adaptor.manifest
660 %defattr(-,root,root,-)
661 %defattr(-,app,app,-)
662 %dir %{user_shader_cache_dir}
663 %{_bindir}/*
664 %license LICENSE
665
666 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
667 # if common ||"undefined"
668 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
669 %defattr(-,root,root,-)
670 %{_libdir}/libdali-adap*.so*
671 %exclude %{_libdir}/libdali-adap*.so*.mobile
672 %exclude %{_libdir}/libdali-adap*.so*.wearable
673 %exclude %{_libdir}/libdali-adap*.so*.tv
674 %exclude %{_libdir}/libdali-adap*.so*.ivi
675 %endif
676
677 %if %{with wayland}
678 %files dali-video-player-plugin
679 %manifest dali-adaptor.manifest
680 %defattr(-,root,root,-)
681 %{_libdir}/libdali-video-player-plugin.so*
682 %license LICENSE
683 %endif
684
685 %if 0%{?tizen_version_major} >= 3
686 %files dali-feedback-plugin
687 %manifest dali-adaptor.manifest
688 %defattr(-,root,root,-)
689 %{_libdir}/libdali-feedback-plugin.so*
690 %{dali_plugin_sound_files}/*
691 %endif
692
693 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
694 # if common ||"undefined"
695 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
696 %files profile_common
697 # default .so files are housed in the main pkg.
698 %endif
699
700 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
701 # if mobile || "undefined"
702 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
703 %files profile_mobile
704 %manifest dali-adaptor.manifest
705 %defattr(-,root,root,-)
706 %{_libdir}/libdali-adap*.so*.mobile
707 %endif
708
709 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
710 # if tv ||"undefined"
711 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
712 %files profile_tv
713 %manifest dali-adaptor.manifest
714 %defattr(-,root,root,-)
715 %{_libdir}/libdali-adap*.so*.tv
716 %endif
717
718 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
719 # if wearable || "undefined"
720 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
721 %files profile_wearable
722 %manifest dali-adaptor.manifest
723 %defattr(-,root,root,-)
724 %{_libdir}/libdali-adap*.so*.wearable
725 %endif
726
727 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
728 # if ivi ||"undefined"
729 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
730 %files profile_ivi
731 %manifest dali-adaptor.manifest
732 %defattr(-,root,root,-)
733 %{_libdir}/libdali-adap*.so*.ivi
734 %endif
735
736
737 %files devel
738 %defattr(-,root,root,-)
739 %{dev_include_path}/dali/dali.h
740 %{dev_include_path}/dali/public-api/*
741 %{dev_include_path}/dali/devel-api/*
742 %{dev_include_path}/dali/doc/*
743 %{_libdir}/pkgconfig/dali-adaptor.pc
744 %{_libdir}/pkgconfig/dali-adaptor-uv.pc
745
746 %files integration-devel
747 %defattr(-,root,root,-)
748 %{dev_include_path}/dali/integration-api/adaptors/*
749 %{_libdir}/pkgconfig/dali-adaptor-integration.pc