5610986ac7120781d3e135f61b2677e7cb63dceb
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    1.4.57
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30 Provides: libdali-adaptor-cxx11.so
31 Provides: libdali-adaptor-cxx11.so.0
32 Provides: libdali-adaptor-cxx11.so.0.0.0
33 Provides: libdali-adaptor.so
34 Provides: libdali-adaptor.so.0
35 Provides: libdali-adaptor.so.0.0.0
36
37 %define tizen_platform_config_supported 1
38 BuildRequires:  pkgconfig(libtzplatform-config)
39
40 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
41 # if wearable || "undefined"
42 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
43 BuildRequires:  pkgconfig(capi-appfw-watch-application)
44 BuildRequires:  pkgconfig(appcore-watch)
45 BuildRequires:  pkgconfig(screen_connector_provider)
46 %endif
47
48 BuildRequires:  pkgconfig(gles20)
49 BuildRequires:  pkgconfig(glesv2)
50 BuildRequires:  pkgconfig(ttrace)
51
52 BuildRequires:  dali-devel
53 BuildRequires:  dali-integration-devel
54
55 BuildRequires:  pkgconfig
56 BuildRequires:  gawk
57 BuildRequires:  cmake
58 BuildRequires:  giflib-devel
59 BuildRequires:  pkgconfig(fontconfig)
60 BuildRequires:  libjpeg-turbo-devel
61 BuildRequires:  pkgconfig(vconf)
62 BuildRequires:  tts-devel
63 BuildRequires:  pkgconfig(dlog)
64 BuildRequires:  libdrm-devel
65 BuildRequires:  pkgconfig(libexif)
66 BuildRequires:  pkgconfig(libpng)
67 BuildRequires:  pkgconfig(egl)
68 BuildRequires:  libcurl-devel
69 BuildRequires:  pkgconfig(harfbuzz)
70 BuildRequires:  fribidi-devel
71
72 BuildRequires:  pkgconfig(capi-system-info)
73 BuildRequires:  pkgconfig(capi-system-sensor)
74
75 BuildRequires:  pkgconfig(cairo)
76
77 BuildRequires:  pkgconfig(wayland-egl)
78 BuildRequires:  pkgconfig(wayland-client)
79 BuildRequires:  wayland-devel
80 BuildRequires:  wayland-extension-client-devel
81
82 # dali-adaptor uses ecore mainloop
83 %if 0%{?tizen_version_major} >= 5
84 BuildRequires:  pkgconfig(ecore-wl2)
85 BuildRequires:  pkgconfig(wayland-egl-tizen)
86 %else
87 BuildRequires:  pkgconfig(ecore-wayland)
88 %endif
89
90 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
91 BuildRequires:  pkgconfig(libtbm)
92
93 BuildRequires:  pkgconfig(tpkp-curl)
94
95 # for dali-adaptor
96 BuildRequires:  pkgconfig(appcore-ui)
97 BuildRequires:  pkgconfig(appcore-widget-base)
98 BuildRequires:  pkgconfig(bundle)
99 BuildRequires:  pkgconfig(capi-appfw-app-common)
100 BuildRequires:  pkgconfig(capi-appfw-app-control)
101 BuildRequires:  pkgconfig(ecore-imf)
102
103 BuildRequires:  pkgconfig(capi-system-system-settings)
104
105 # for feedback plugin
106 BuildRequires:  pkgconfig(mm-sound)
107 BuildRequires:  pkgconfig(feedback)
108
109 # for multiprofile
110 Requires:   %{name}-compat = %{version}-%{release}
111 Recommends: %{name}-profile_common = %{version}-%{release}
112
113 %description
114 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
115 platform abstraction and application shell
116
117 ###########################################
118 # Dali adapter for profiles
119 ###########################################
120
121 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
122 # if mobile || "undefined"
123 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
124 %package profile_mobile
125 Summary:        The DALi Tizen Adaptor for mobile
126 Provides:       %{name}-compat = %{version}-%{release}
127 Conflicts:      %{name}-profile_tv
128 Conflicts:      %{name}-profile_wearable
129 Conflicts:      %{name}-profile_ivi
130 Conflicts:      %{name}-profile_common
131 Requires:       %{name}
132 %description profile_mobile
133 The DALi Tizen Adaptor for mobile.
134 %endif
135
136 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
137 # if tv ||"undefined"
138 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
139 %package profile_tv
140 Summary:        The DALi Tizen Adaptor for tv
141 Provides:       %{name}-compat = %{version}-%{release}
142 Conflicts:      %{name}-profile_mobile
143 Conflicts:      %{name}-profile_wearable
144 Conflicts:      %{name}-profile_ivi
145 Conflicts:      %{name}-profile_common
146 Requires:       %{name}
147 %description profile_tv
148 The DALi Tizen Adaptor for tv.
149 %endif
150
151 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
152 # if wearable || "undefined"
153 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
154 %package profile_wearable
155 Summary:        The DALi Tizen Adaptor for wearable
156 Provides:       %{name}-compat = %{version}-%{release}
157 Conflicts:      %{name}-profile_mobile
158 Conflicts:      %{name}-profile_tv
159 Conflicts:      %{name}-profile_ivi
160 Conflicts:      %{name}-profile_common
161 Requires:       %{name}
162 %description profile_wearable
163 The DALi Tizen Adaptor for wearable.
164 %endif
165
166 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
167 # if ivi ||"undefined"
168 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
169 %package profile_ivi
170 Summary:        The DALi Tizen Adaptor for ivi
171 Provides:       %{name}-compat = %{version}-%{release}
172 Conflicts:      %{name}-profile_mobile
173 Conflicts:      %{name}-profile_wearable
174 Conflicts:      %{name}-profile_tv
175 Conflicts:      %{name}-profile_common
176 Requires:       %{name}
177 %description profile_ivi
178 The DALi Tizen Adaptor for ivi.
179 %endif
180
181 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
182 # if common ||"undefined"
183 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
184 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
185 %package profile_common
186 Summary:        The DALi Tizen Adaptor for common
187 Provides:       %{name}-compat = %{version}-%{release}
188 Conflicts:      %{name}-profile_mobile
189 Conflicts:      %{name}-profile_wearable
190 Conflicts:      %{name}-profile_tv
191 Conflicts:      %{name}-profile_ivi
192 Requires:       %{name}
193 %description profile_common
194 The DALi Tizen Adaptor for common.
195 %endif
196
197 ##############################
198 # devel
199 ##############################
200 %package devel
201 Summary:    Development components for the DALi Tizen Adaptor
202 Group:      Development/Building
203 Requires:   %{name} = %{version}-%{release}
204 Requires:   %{name}-integration-devel = %{version}-%{release}
205
206 %description devel
207 Development components for the DALi Tizen Adaptor - public headers and package configs
208
209 ##############################
210 # integration-devel
211 ##############################
212 %package integration-devel
213 Summary:    Integration development package for the Adaptor
214 Group:      Development/Building
215 Requires:   %{name} = %{version}-%{release}
216
217 %description integration-devel
218 Integration development package for the Adaptor - headers for integrating with an adaptor library.
219
220 ##############################
221 # Dali Feedback Plugin
222 ##############################
223 %package dali-feedback-plugin
224 Summary:    Plugin to play haptic and audio feedback for Dali
225 Group:      System/Libraries
226 Requires:   %{name} = %{version}-%{release}
227 %description dali-feedback-plugin
228 Feedback plugin to play haptic and audio feedback for Dali
229
230 ##############################
231 # Preparation
232 ##############################
233 %prep
234 %setup -q
235
236 #Use TZ_PATH when tizen version is 3.x or greater
237
238 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
239 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
240 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
241 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
242 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
243 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
244
245 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
246 %define dali_plugin_sound_files  /plugins/sounds/
247
248 ##############################
249 # Build
250 ##############################
251 %build
252 PREFIX+="/usr"
253 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
254 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
255
256 %ifarch %{arm}
257 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
258 %endif
259
260 CFLAGS+=" -DWAYLAND"
261 CXXFLAGS+=" -DWAYLAND"
262 cmake_flags=" -DENABLE_WAYLAND=ON"
263
264 # Use this conditional when Tizen version is 5.x or greater
265 %if 0%{?tizen_version_major} >= 5
266 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
267
268 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
269 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
270 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
271 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
272 %endif
273
274 %if 0%{?enable_debug}
275 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
276 %endif
277
278 %if 0%{?enable_trace}
279 cmake_flags+=" -DENABLE_TRACE=ON"
280 %endif
281
282 %if 0%{?enable_appfw}
283 cmake_flags+=" -DUSE_APPFW"
284 %endif
285
286 libtoolize --force
287 cd %{_builddir}/%{name}-%{version}/build/tizen
288
289 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
290 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
291 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
292 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
293 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
294 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
295 %if 0%{?tizen_platform_config_supported}
296 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
297 %endif
298
299 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
300 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
301 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
302 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
303 cmake_flags+=" -DENABLE_FEEDBACK=YES"
304 cmake_flags+=" -DENABLE_APPFW=YES"
305
306 # Set up the build via Cmake
307 #######################################################################
308 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
309 # if mobile || "undefined"
310 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
311
312 mkdir mobile
313 pushd mobile
314
315 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
316
317 # Build.
318 make %{?jobs:-j%jobs}
319 popd
320
321 %endif
322
323 #######################################################################
324 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
325 # if tv ||"undefined"
326 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
327
328 mkdir tv
329 pushd tv
330
331 cmake -DENABLE_PROFILE=TV $cmake_flags ..
332
333 # Build.
334 make %{?jobs:-j%jobs}
335 popd
336
337 %endif
338
339 #######################################################################
340 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
341 # if wearable || "undefined"
342 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
343
344 mkdir wearable
345 pushd wearable
346
347 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
348
349 # Build.
350 make %{?jobs:-j%jobs}
351 popd
352
353 %endif
354
355 #######################################################################
356 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
357 # if ivi ||"undefined"
358 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
359
360 mkdir ivi
361 pushd ivi
362
363 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
364
365 # Build.
366 make %{?jobs:-j%jobs}
367 popd
368
369 %endif
370
371 #######################################################################
372 # common
373 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
374 # if common ||"undefined"
375 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
376
377 mkdir common
378 pushd common
379
380 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
381
382 # Build.
383 make %{?jobs:-j%jobs}
384 popd
385
386 %endif
387
388 ##############################
389 # Installation
390 ##############################
391 %install
392 rm -rf %{buildroot}
393
394 pushd %{_builddir}/%{name}-%{version}/build/tizen
395
396 # if mobile || "undefined"
397 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
398 pushd mobile
399 %make_install
400 %if "%{?profile}" != "mobile"
401 pushd  %{buildroot}%{_libdir}
402 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
403 popd
404 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
405 %endif
406 popd
407 %endif
408
409 # if tv ||"undefined"
410 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
411 pushd tv
412 %make_install
413 %if "%{?profile}" != "tv"
414 pushd  %{buildroot}%{_libdir}
415 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
416 popd
417 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
418 %endif
419 popd
420 %endif
421
422 # if wearable || "undefined"
423 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
424 pushd wearable
425 %make_install
426 %if "%{?profile}" != "wearable"
427 pushd  %{buildroot}%{_libdir}
428 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
429 popd
430 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
431 %endif
432 popd
433 %endif
434
435 # if ivi ||"undefined"
436 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
437 pushd ivi
438 %make_install
439 %if "%{?profile}" != "ivi"
440 pushd  %{buildroot}%{_libdir}
441 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
442 popd
443 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
444 %endif
445 popd
446 %endif
447
448 # if common ||"undefined"
449 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
450 pushd common
451 %make_install
452 # No clean so we can gather symbol/size information for the common profile
453 popd
454 %endif
455
456 # Create links to ensure linking with cxx11 library is preserved
457 pushd  %{buildroot}%{_libdir}
458 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so
459 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0
460 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0.0.0
461 popd
462
463 # Create a symbolic link in integration-api to preserve legacy repo build
464 pushd %{buildroot}%{_includedir}/dali/integration-api
465 ln -sf adaptor-framework adaptors
466 popd
467
468 ##############################
469 # Upgrade order:
470 # 1 - Pre Install new package
471 # 2 - Install new package
472 # 3 - Post install new package
473 # 4 - Pre uninstall old package
474 # 5 - Remove files not overwritten by new package
475 # 6 - Post uninstall old package
476 ##############################
477
478 ##############################
479 # Adaptor package Commands
480 %pre
481 exit 0
482
483 %post
484 pushd %{_libdir}
485 for i in mobile tv wearable ivi; do [[ -f libdali-adaptor.so.$i ]] && ln -sf libdali-adaptor.so.$i libdali-adaptor.so.0.0.0; done
486 popd
487 /sbin/ldconfig
488 exit 0
489
490 %preun
491 exit 0
492
493 %postun
494 /sbin/ldconfig
495 exit 0
496
497 ##############################
498 # Mobile Profile Commands
499 # if mobile || "undefined"
500 # No need to create a symbolic link on install required if only building this profile
501 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
502 %post profile_mobile
503 %if "%{?profile}" != "mobile"
504 pushd %{_libdir}
505 ln -sf libdali-adaptor.so.mobile libdali-adaptor.so.0.0.0
506 popd
507 %endif
508 /sbin/ldconfig
509 exit 0
510
511 %postun profile_mobile
512 /sbin/ldconfig
513 exit 0
514 %endif
515
516 ##############################
517 # TV Profile Commands
518 # No need to create a symbolic link on install required if only building this profile
519 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
520 %post profile_tv
521 %if "%{?profile}" != "tv"
522 pushd %{_libdir}
523 ln -sf libdali-adaptor.so.tv libdali-adaptor.so.0.0.0
524 popd
525 %endif
526 /sbin/ldconfig
527 exit 0
528
529 %postun profile_tv
530 /sbin/ldconfig
531 exit 0
532 %endif
533
534 ##############################
535 # Wearable Profile Commands
536 # No need to create a symbolic link on install required if only building this profile
537 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
538 %post profile_wearable
539 %if "%{?profile}" != "wearable"
540 pushd %{_libdir}
541 ln -sf libdali-adaptor.so.wearable libdali-adaptor.so.0.0.0
542 popd
543 %endif
544 /sbin/ldconfig
545 exit 0
546
547 %postun profile_wearable
548 /sbin/ldconfig
549 exit 0
550 %endif
551
552 ##############################
553 # IVI Profile Commands
554 # No need to create a symbolic link on install required if only building this profile
555 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
556 %post profile_ivi
557 %if "%{?profile}" != "ivi"
558 pushd %{_libdir}
559 ln -sf libdali-adaptor.so.ivi libdali-adaptor.so.0.0.0
560 popd
561 %endif
562 /sbin/ldconfig
563 exit 0
564
565 %postun profile_ivi
566 /sbin/ldconfig
567 exit 0
568 %endif
569
570 ##############################
571 # Common Profile Commands
572 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
573 %post profile_common
574 /sbin/ldconfig
575 exit 0
576
577 %postun profile_common
578 /sbin/ldconfig
579 exit 0
580 %endif
581
582 ##############################
583 # Files in Binary Packages
584 ##############################
585
586 %files
587 %manifest dali-adaptor.manifest
588 %defattr(-,root,root,-)
589 %dir %{user_shader_cache_dir}
590 %{_bindir}/*
591 %license LICENSE
592 %defattr(-,root,root,-)
593 %{_libdir}/libdali-adaptor-cxx11.so
594 %{_libdir}/libdali-adaptor-cxx11.so.0
595 %{_libdir}/libdali-adaptor-cxx11.so.0.0.0
596 %{_libdir}/libdali-adaptor.so
597 %{_libdir}/libdali-adaptor.so.0
598 %{_libdir}/libdali-adaptor.so.0.0.0
599
600 #################################################
601
602 %files dali-feedback-plugin
603 %manifest dali-adaptor.manifest
604 %defattr(-,root,root,-)
605 %{_libdir}/libdali-feedback-plugin-cxx11.so*
606 %{dali_plugin_sound_files}/*
607
608 #################################################
609
610 # if common ||"undefined"
611 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
612 %files profile_common
613 %manifest dali-adaptor.manifest
614 # default .so files are housed in the main pkg.
615 %endif
616
617 # if mobile || "undefined"
618 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
619 %files profile_mobile
620 %manifest dali-adaptor.manifest
621 %defattr(-,root,root,-)
622 %if "%{?profile}" != "mobile"
623 %{_libdir}/libdali-adaptor.so.mobile
624 %endif
625 %endif
626
627 # if tv ||"undefined"
628 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
629 %files profile_tv
630 %manifest dali-adaptor.manifest
631 %defattr(-,root,root,-)
632 %if "%{?profile}" != "tv"
633 %{_libdir}/libdali-adaptor.so.tv
634 %endif
635 %endif
636
637 # if wearable || "undefined"
638 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
639 %files profile_wearable
640 %manifest dali-adaptor.manifest
641 %defattr(-,root,root,-)
642 %if "%{?profile}" != "wearable"
643 %{_libdir}/libdali-adaptor.so.wearable
644 %endif
645 %endif
646
647 # if ivi ||"undefined"
648 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
649 %files profile_ivi
650 %manifest dali-adaptor.manifest
651 %defattr(-,root,root,-)
652 %if "%{?profile}" != "ivi"
653 %{_libdir}/libdali-adaptor.so.ivi
654 %endif
655 %endif
656
657 %files devel
658 %defattr(-,root,root,-)
659 %{_includedir}/dali/dali.h
660 %{_includedir}/dali/public-api/*
661 %{_includedir}/dali/devel-api/*
662 %{_includedir}/dali/doc/*
663 %{_libdir}/pkgconfig/dali-adaptor.pc
664
665 %files integration-devel
666 %defattr(-,root,root,-)
667 %{_includedir}/dali/integration-api/adaptor-framework/*
668 %{_includedir}/dali/integration-api/adaptors
669 %{_libdir}/pkgconfig/dali-adaptor-integration.pc