55e7c3cd47ea2a73140b4281d35785d3c47e8950
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali2-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    2.0.37
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30
31 %define tizen_platform_config_supported 1
32 BuildRequires:  pkgconfig(libtzplatform-config)
33
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(capi-appfw-watch-application)
38 BuildRequires:  pkgconfig(appcore-watch)
39 BuildRequires:  pkgconfig(screen_connector_provider)
40 %endif
41
42 BuildRequires:  pkgconfig(gles20)
43 BuildRequires:  pkgconfig(glesv2)
44 BuildRequires:  pkgconfig(ttrace)
45
46 BuildRequires:  dali2-devel
47 BuildRequires:  dali2-integration-devel
48
49 BuildRequires:  pkgconfig
50 BuildRequires:  gawk
51 BuildRequires:  cmake
52 BuildRequires:  giflib-devel
53 BuildRequires:  pkgconfig(fontconfig)
54 BuildRequires:  libjpeg-turbo-devel
55 BuildRequires:  pkgconfig(vconf)
56 BuildRequires:  tts-devel
57 BuildRequires:  pkgconfig(dlog)
58 BuildRequires:  libdrm-devel
59 BuildRequires:  pkgconfig(libexif)
60 BuildRequires:  pkgconfig(libpng)
61 BuildRequires:  pkgconfig(egl)
62 BuildRequires:  libcurl-devel
63 BuildRequires:  pkgconfig(harfbuzz)
64 BuildRequires:  hyphen-devel
65 BuildRequires:  fribidi-devel
66
67 BuildRequires:  pkgconfig(capi-system-info)
68 BuildRequires:  pkgconfig(capi-system-sensor)
69
70 BuildRequires:  pkgconfig(cairo)
71
72 BuildRequires:  pkgconfig(wayland-egl)
73 BuildRequires:  pkgconfig(wayland-client)
74 BuildRequires:  pkgconfig(input-method-client)
75 BuildRequires:  wayland-devel
76 BuildRequires:  wayland-extension-client-devel
77
78 # WebP support only from Tizen 6 onwards
79 %if 0%{?tizen_version_major} >= 6
80 BuildRequires:  pkgconfig(libwebp)
81 BuildRequires:  pkgconfig(libwebpdecoder)
82 BuildRequires:  pkgconfig(libwebpdemux)
83 BuildRequires:  pkgconfig(libwebpmux)
84 %endif
85
86 # We use ecore mainloop
87 %if 0%{?tizen_version_major} >= 5
88 BuildRequires:  pkgconfig(ecore-wl2)
89 BuildRequires:  pkgconfig(wayland-egl-tizen)
90 %else
91 BuildRequires:  pkgconfig(ecore-wayland)
92 %endif
93
94 # We need tbm_surface in tizen 3.0 wayland
95 BuildRequires:  pkgconfig(libtbm)
96
97 # for the adaptor
98 BuildRequires:  pkgconfig(appcore-ui)
99 BuildRequires:  pkgconfig(appcore-widget-base)
100 BuildRequires:  pkgconfig(bundle)
101 BuildRequires:  pkgconfig(capi-appfw-app-common)
102 BuildRequires:  pkgconfig(capi-appfw-app-control)
103 BuildRequires:  pkgconfig(ecore-imf)
104
105 BuildRequires:  pkgconfig(capi-system-system-settings)
106
107 # for ATSPI (Accessibility) support
108 BuildRequires:  pkgconfig(eldbus)
109
110 # for feedback plugin
111 BuildRequires:  pkgconfig(mm-sound)
112 BuildRequires:  pkgconfig(feedback)
113 BuildRequires:  pkgconfig(component-based-core-base)
114
115
116 %if ( 0%{?tizen_version_major} == 6 && 0%{?tizen_version_minor} >= 5 ) || 0%{?tizen_version_major} >= 7
117 BuildRequires:  pkgconfig(thorvg)
118 %endif
119
120 # for multiprofile
121 Requires:   %{name}-compat = %{version}-%{release}
122 Recommends: %{name}-profile_common = %{version}-%{release}
123
124 %description
125 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
126 platform abstraction and application shell
127
128 ###########################################
129 # Dali adapter for profiles
130 ###########################################
131
132 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
133 # if mobile || "undefined"
134 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
135 %package profile_mobile
136 Summary:        The DALi Tizen Adaptor for mobile
137 Provides:       %{name}-compat = %{version}-%{release}
138 Conflicts:      %{name}-profile_tv
139 Conflicts:      %{name}-profile_wearable
140 Conflicts:      %{name}-profile_ivi
141 Conflicts:      %{name}-profile_common
142 Requires:       %{name}
143 %description profile_mobile
144 The DALi Tizen Adaptor for mobile.
145 %endif
146
147 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
148 # if tv ||"undefined"
149 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
150 %package profile_tv
151 Summary:        The DALi Tizen Adaptor for tv
152 Provides:       %{name}-compat = %{version}-%{release}
153 Conflicts:      %{name}-profile_mobile
154 Conflicts:      %{name}-profile_wearable
155 Conflicts:      %{name}-profile_ivi
156 Conflicts:      %{name}-profile_common
157 Requires:       %{name}
158 %description profile_tv
159 The DALi Tizen Adaptor for tv.
160 %endif
161
162 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
163 # if wearable || "undefined"
164 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
165 %package profile_wearable
166 Summary:        The DALi Tizen Adaptor for wearable
167 Provides:       %{name}-compat = %{version}-%{release}
168 Conflicts:      %{name}-profile_mobile
169 Conflicts:      %{name}-profile_tv
170 Conflicts:      %{name}-profile_ivi
171 Conflicts:      %{name}-profile_common
172 Requires:       %{name}
173 %description profile_wearable
174 The DALi Tizen Adaptor for wearable.
175 %endif
176
177 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
178 # if ivi ||"undefined"
179 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
180 %package profile_ivi
181 Summary:        The DALi Tizen Adaptor for ivi
182 Provides:       %{name}-compat = %{version}-%{release}
183 Conflicts:      %{name}-profile_mobile
184 Conflicts:      %{name}-profile_wearable
185 Conflicts:      %{name}-profile_tv
186 Conflicts:      %{name}-profile_common
187 Requires:       %{name}
188 %description profile_ivi
189 The DALi Tizen Adaptor for ivi.
190 %endif
191
192 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
193 # if common ||"undefined"
194 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
195 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
196 %package profile_common
197 Summary:        The DALi Tizen Adaptor for common
198 Provides:       %{name}-compat = %{version}-%{release}
199 Conflicts:      %{name}-profile_mobile
200 Conflicts:      %{name}-profile_wearable
201 Conflicts:      %{name}-profile_tv
202 Conflicts:      %{name}-profile_ivi
203 Requires:       %{name}
204 %description profile_common
205 The DALi Tizen Adaptor for common.
206 %endif
207
208 ##############################
209 # devel
210 ##############################
211 %package devel
212 Summary:    Development components for the DALi Tizen Adaptor
213 Group:      Development/Building
214 Requires:   %{name} = %{version}-%{release}
215 Requires:   %{name}-integration-devel = %{version}-%{release}
216
217 %description devel
218 Development components for the DALi Tizen Adaptor - public headers and package configs
219
220 ##############################
221 # integration-devel
222 ##############################
223 %package integration-devel
224 Summary:    Integration development package for the Adaptor
225 Group:      Development/Building
226 Requires:   %{name} = %{version}-%{release}
227
228 %description integration-devel
229 Integration development package for the Adaptor - headers for integrating with an adaptor library.
230
231 ##############################
232 # Dali Feedback Plugin
233 ##############################
234 %package dali2-feedback-plugin
235 Summary:    Plugin to play haptic and audio feedback for Dali
236 Group:      System/Libraries
237 Requires:   %{name} = %{version}-%{release}
238 %description dali2-feedback-plugin
239 Feedback plugin to play haptic and audio feedback for Dali
240
241 #Use TZ_PATH when tizen version is 3.x or greater
242 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
243 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
244 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
245 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
246 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
247 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
248
249 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
250 %define dali_plugin_sound_files  /plugins/sounds/
251
252 ##############################
253 # Preparation
254 ##############################
255 %prep
256 %setup -q
257
258
259 ##############################
260 # Build
261 ##############################
262 %build
263 PREFIX+="/usr"
264 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
265 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
266
267 %ifarch %{arm}
268 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
269 %endif
270
271 CFLAGS+=" -DWAYLAND"
272 CXXFLAGS+=" -DWAYLAND"
273 cmake_flags=" -DENABLE_WAYLAND=ON -DENABLE_ATSPI=ON"
274
275 # Use this conditional when Tizen version is 5.x or greater
276 %if 0%{?tizen_version_major} >= 5
277 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
278
279 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
280 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
281 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
282 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
283 %endif
284
285 %if 0%{?enable_debug}
286 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
287 %endif
288
289 %if 0%{?enable_trace}
290 cmake_flags+=" -DENABLE_TRACE=ON"
291 %endif
292
293 libtoolize --force
294 cd %{_builddir}/%{name}-%{version}/build/tizen
295
296 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
297 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
298 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
299 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
300 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
301 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
302 %if 0%{?tizen_platform_config_supported}
303 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
304 %endif
305
306 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
307 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
308 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
309 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
310 cmake_flags+=" -DENABLE_FEEDBACK=YES"
311 cmake_flags+=" -DENABLE_APPFW=YES"
312 cmake_flags+=" -DCOMPONENT_APPLICATION_SUPPORT=YES"
313
314 # Set up the build via Cmake
315 #######################################################################
316 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
317 # if mobile || "undefined"
318 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
319
320 mkdir -p mobile
321 pushd mobile
322
323 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
324
325 # Build.
326 make %{?jobs:-j%jobs}
327 popd
328
329 %endif
330
331 #######################################################################
332 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
333 # if tv ||"undefined"
334 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
335
336 mkdir -p tv
337 pushd tv
338
339 cmake -DENABLE_PROFILE=TV $cmake_flags ..
340
341 # Build.
342 make %{?jobs:-j%jobs}
343 popd
344
345 %endif
346
347 #######################################################################
348 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
349 # if wearable || "undefined"
350 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
351
352 mkdir -p wearable
353 pushd wearable
354
355 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
356
357 # Build.
358 make %{?jobs:-j%jobs}
359 popd
360
361 %endif
362
363 #######################################################################
364 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
365 # if ivi ||"undefined"
366 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
367
368 mkdir -p ivi
369 pushd ivi
370
371 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
372
373 # Build.
374 make %{?jobs:-j%jobs}
375 popd
376
377 %endif
378
379 #######################################################################
380 # common
381 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
382 # if common ||"undefined"
383 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
384
385 mkdir -p common
386 pushd common
387
388 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
389
390 # Build.
391 make %{?jobs:-j%jobs}
392 popd
393
394 %endif
395
396 ##############################
397 # Installation
398 ##############################
399 %install
400 rm -rf %{buildroot}
401
402 pushd %{_builddir}/%{name}-%{version}/build/tizen
403
404 # if mobile || "undefined"
405 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
406 pushd mobile
407 %make_install
408 %if "%{?profile}" != "mobile"
409 pushd  %{buildroot}%{_libdir}
410 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
411 popd
412 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
413 %endif
414 popd
415 %endif
416
417 # if tv ||"undefined"
418 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
419 pushd tv
420 %make_install
421 %if "%{?profile}" != "tv"
422 pushd  %{buildroot}%{_libdir}
423 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
424 popd
425 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
426 %endif
427 popd
428 %endif
429
430 # if wearable || "undefined"
431 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
432 pushd wearable
433 %make_install
434 %if "%{?profile}" != "wearable"
435 pushd  %{buildroot}%{_libdir}
436 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
437 popd
438 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
439 %endif
440 popd
441 %endif
442
443 # if ivi ||"undefined"
444 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
445 pushd ivi
446 %make_install
447 %if "%{?profile}" != "ivi"
448 pushd  %{buildroot}%{_libdir}
449 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
450 popd
451 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
452 %endif
453 popd
454 %endif
455
456 # if common ||"undefined"
457 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
458 pushd common
459 %make_install
460 # No clean so we can gather symbol/size information for the common profile
461 popd
462 %endif
463
464 # Create a symbolic link in integration-api to preserve legacy repo build
465 pushd %{buildroot}%{_includedir}/dali/integration-api
466 ln -sf adaptor-framework adaptors
467 popd
468
469 ##############################
470 # Upgrade order:
471 # 1 - Pre Install new package
472 # 2 - Install new package
473 # 3 - Post install new package
474 # 4 - Pre uninstall old package
475 # 5 - Remove files not overwritten by new package
476 # 6 - Post uninstall old package
477 ##############################
478
479 ##############################
480 # Adaptor package Commands
481 %pre
482 exit 0
483
484 %post
485 pushd %{_libdir}
486 for i in mobile tv wearable ivi; do [[ -f libdali2-adaptor.so.$i ]] && ln -sf libdali2-adaptor.so.$i libdali2-adaptor.so.2.0.0; done
487 popd
488 /sbin/ldconfig
489 exit 0
490
491 %preun
492 exit 0
493
494 %postun
495 /sbin/ldconfig
496 exit 0
497
498 ##############################
499 # Mobile Profile Commands
500 # if mobile || "undefined"
501 # No need to create a symbolic link on install required if only building this profile
502 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
503 %post profile_mobile
504 %if "%{?profile}" != "mobile"
505 pushd %{_libdir}
506 ln -sf libdali2-adaptor.so.mobile libdali2-adaptor.so.2.0.0
507 popd
508 %endif
509 /sbin/ldconfig
510 exit 0
511
512 %postun profile_mobile
513 /sbin/ldconfig
514 exit 0
515 %endif
516
517 ##############################
518 # TV Profile Commands
519 # No need to create a symbolic link on install required if only building this profile
520 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
521 %post profile_tv
522 %if "%{?profile}" != "tv"
523 pushd %{_libdir}
524 ln -sf libdali2-adaptor.so.tv libdali2-adaptor.so.2.0.0
525 popd
526 %endif
527 /sbin/ldconfig
528 exit 0
529
530 %postun profile_tv
531 /sbin/ldconfig
532 exit 0
533 %endif
534
535 ##############################
536 # Wearable Profile Commands
537 # No need to create a symbolic link on install required if only building this profile
538 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
539 %post profile_wearable
540 %if "%{?profile}" != "wearable"
541 pushd %{_libdir}
542 ln -sf libdali2-adaptor.so.wearable libdali2-adaptor.so.2.0.0
543 popd
544 %endif
545 /sbin/ldconfig
546 exit 0
547
548 %postun profile_wearable
549 /sbin/ldconfig
550 exit 0
551 %endif
552
553 ##############################
554 # IVI Profile Commands
555 # No need to create a symbolic link on install required if only building this profile
556 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
557 %post profile_ivi
558 %if "%{?profile}" != "ivi"
559 pushd %{_libdir}
560 ln -sf libdali2-adaptor.so.ivi libdali2-adaptor.so.2.0.0
561 popd
562 %endif
563 /sbin/ldconfig
564 exit 0
565
566 %postun profile_ivi
567 /sbin/ldconfig
568 exit 0
569 %endif
570
571 ##############################
572 # Common Profile Commands
573 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
574 %post profile_common
575 /sbin/ldconfig
576 exit 0
577
578 %postun profile_common
579 /sbin/ldconfig
580 exit 0
581 %endif
582
583 ##############################
584 # Files in Binary Packages
585 ##############################
586
587 %files
588 %manifest dali-adaptor.manifest
589 %defattr(-,root,root,-)
590 %dir %{user_shader_cache_dir}
591 %{_bindir}/*
592 %license LICENSE
593 %defattr(-,root,root,-)
594 %{_libdir}/libdali2-adaptor.so
595 %{_libdir}/libdali2-adaptor.so.2
596 %{_libdir}/libdali2-adaptor.so.2.0.0
597
598 #################################################
599
600 %files dali2-feedback-plugin
601 %manifest dali-adaptor.manifest
602 %defattr(-,root,root,-)
603 %{_libdir}/libdali2-feedback-plugin.so*
604 %{dali_plugin_sound_files}/*
605
606 #################################################
607
608 # if common ||"undefined"
609 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
610 %files profile_common
611 %manifest dali-adaptor.manifest
612 # default .so files are housed in the main pkg.
613 %endif
614
615 # if mobile || "undefined"
616 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
617 %files profile_mobile
618 %manifest dali-adaptor.manifest
619 %defattr(-,root,root,-)
620 %if "%{?profile}" != "mobile"
621 %{_libdir}/libdali2-adaptor.so.mobile
622 %endif
623 %endif
624
625 # if tv ||"undefined"
626 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
627 %files profile_tv
628 %manifest dali-adaptor.manifest
629 %defattr(-,root,root,-)
630 %if "%{?profile}" != "tv"
631 %{_libdir}/libdali2-adaptor.so.tv
632 %endif
633 %endif
634
635 # if wearable || "undefined"
636 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
637 %files profile_wearable
638 %manifest dali-adaptor.manifest
639 %defattr(-,root,root,-)
640 %if "%{?profile}" != "wearable"
641 %{_libdir}/libdali2-adaptor.so.wearable
642 %endif
643 %endif
644
645 # if ivi ||"undefined"
646 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
647 %files profile_ivi
648 %manifest dali-adaptor.manifest
649 %defattr(-,root,root,-)
650 %if "%{?profile}" != "ivi"
651 %{_libdir}/libdali2-adaptor.so.ivi
652 %endif
653 %endif
654
655 %files devel
656 %defattr(-,root,root,-)
657 %{_includedir}/dali/dali.h
658 %{_includedir}/dali/public-api/*
659 %{_includedir}/dali/devel-api/*
660 %{_includedir}/dali/doc/*
661 %{_libdir}/pkgconfig/dali2-adaptor.pc
662
663 %files integration-devel
664 %defattr(-,root,root,-)
665 %{_includedir}/dali/integration-api/adaptor-framework/*
666 %{_includedir}/dali/integration-api/adaptors
667 %{_libdir}/pkgconfig/dali2-adaptor-integration.pc