2c7b06fc68379d39eeed0e02263cacfded0a01eb
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali2-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    2.3.2
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30
31 %define tizen_platform_config_supported 1
32 BuildRequires:  pkgconfig(libtzplatform-config)
33
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(capi-appfw-watch-application)
38 BuildRequires:  pkgconfig(appcore-watch)
39 %endif
40
41 BuildRequires:  pkgconfig(screen_connector_provider)
42 BuildRequires:  pkgconfig(gles20)
43 BuildRequires:  pkgconfig(glesv2)
44 BuildRequires:  pkgconfig(ttrace)
45
46 BuildRequires:  dali2-devel
47 BuildRequires:  dali2-integration-devel
48
49 BuildRequires:  pkgconfig
50 BuildRequires:  gawk
51 BuildRequires:  cmake
52 BuildRequires:  giflib-devel
53 BuildRequires:  pkgconfig(fontconfig)
54 BuildRequires:  libjpeg-turbo-devel
55 BuildRequires:  pkgconfig(vconf)
56 BuildRequires:  tts-devel
57 BuildRequires:  pkgconfig(dlog)
58 BuildRequires:  libdrm-devel
59 BuildRequires:  pkgconfig(libexif)
60 BuildRequires:  pkgconfig(libpng)
61 BuildRequires:  pkgconfig(egl)
62 BuildRequires:  libcurl-devel
63 BuildRequires:  pkgconfig(harfbuzz)
64 BuildRequires:  hyphen-devel
65 BuildRequires:  fribidi-devel
66
67 BuildRequires:  pkgconfig(capi-system-info)
68 BuildRequires:  pkgconfig(capi-system-sensor)
69
70 BuildRequires:  pkgconfig(cairo)
71
72 BuildRequires:  pkgconfig(wayland-egl)
73 BuildRequires:  pkgconfig(wayland-client)
74 BuildRequires:  pkgconfig(input-method-client)
75 BuildRequires:  wayland-devel
76 BuildRequires:  wayland-extension-client-devel
77
78 # WebP support only from Tizen 6 onwards
79 %if 0%{?tizen_version_major} >= 6
80 BuildRequires:  pkgconfig(libwebp)
81 BuildRequires:  pkgconfig(libwebpdecoder)
82 BuildRequires:  pkgconfig(libwebpdemux)
83 BuildRequires:  pkgconfig(libwebpmux)
84 %endif
85
86 # We use ecore mainloop
87 %if 0%{?tizen_version_major} >= 5
88 BuildRequires:  pkgconfig(ecore-wl2)
89 BuildRequires:  pkgconfig(wayland-egl-tizen)
90 %else
91 BuildRequires:  pkgconfig(ecore-wayland)
92 %endif
93
94 # We need tbm_surface in tizen 3.0 wayland
95 BuildRequires:  pkgconfig(libtbm)
96
97 # for the adaptor
98 BuildRequires:  pkgconfig(app-core-ui-cpp)
99 BuildRequires:  pkgconfig(appcore-widget-base)
100 BuildRequires:  pkgconfig(bundle)
101 BuildRequires:  pkgconfig(capi-appfw-app-common)
102 BuildRequires:  pkgconfig(capi-appfw-app-control)
103 BuildRequires:  pkgconfig(ecore-imf)
104
105 BuildRequires:  pkgconfig(capi-system-system-settings)
106
107 # for ATSPI (Accessibility) support
108 BuildRequires:  pkgconfig(eldbus)
109
110 # for feedback plugin
111 BuildRequires:  pkgconfig(mm-sound)
112 BuildRequires:  pkgconfig(feedback)
113 BuildRequires:  pkgconfig(component-based-core-base)
114
115
116 %if ( 0%{?tizen_version_major} == 6 && 0%{?tizen_version_minor} >= 5 ) || 0%{?tizen_version_major} >= 7
117 BuildRequires:  pkgconfig(thorvg)
118 %endif
119
120 # for multiprofile
121 Requires:   %{name}-compat = %{version}-%{release}
122 Recommends: %{name}-profile_common = %{version}-%{release}
123
124 %description
125 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
126 platform abstraction and application shell
127
128 ###########################################
129 # Dali adapter for profiles
130 ###########################################
131
132 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
133 # if mobile || "undefined"
134 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
135 %package profile_mobile
136 Summary:        The DALi Tizen Adaptor for mobile
137 Provides:       %{name}-compat = %{version}-%{release}
138 Conflicts:      %{name}-profile_tv
139 Conflicts:      %{name}-profile_wearable
140 Conflicts:      %{name}-profile_ivi
141 Conflicts:      %{name}-profile_common
142 Requires:       %{name}
143 %description profile_mobile
144 The DALi Tizen Adaptor for mobile.
145 %endif
146
147 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
148 # if tv ||"undefined"
149 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
150 %package profile_tv
151 Summary:        The DALi Tizen Adaptor for tv
152 Provides:       %{name}-compat = %{version}-%{release}
153 Conflicts:      %{name}-profile_mobile
154 Conflicts:      %{name}-profile_wearable
155 Conflicts:      %{name}-profile_ivi
156 Conflicts:      %{name}-profile_common
157 Requires:       %{name}
158 %description profile_tv
159 The DALi Tizen Adaptor for tv.
160 %endif
161
162 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
163 # if wearable || "undefined"
164 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
165 %package profile_wearable
166 Summary:        The DALi Tizen Adaptor for wearable
167 Provides:       %{name}-compat = %{version}-%{release}
168 Conflicts:      %{name}-profile_mobile
169 Conflicts:      %{name}-profile_tv
170 Conflicts:      %{name}-profile_ivi
171 Conflicts:      %{name}-profile_common
172 Requires:       %{name}
173 %description profile_wearable
174 The DALi Tizen Adaptor for wearable.
175 %endif
176
177 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
178 # if ivi ||"undefined"
179 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
180 %package profile_ivi
181 Summary:        The DALi Tizen Adaptor for ivi
182 Provides:       %{name}-compat = %{version}-%{release}
183 Conflicts:      %{name}-profile_mobile
184 Conflicts:      %{name}-profile_wearable
185 Conflicts:      %{name}-profile_tv
186 Conflicts:      %{name}-profile_common
187 Requires:       %{name}
188 %description profile_ivi
189 The DALi Tizen Adaptor for ivi.
190 %endif
191
192 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
193 # if common ||"undefined"
194 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
195 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
196 %package profile_common
197 Summary:        The DALi Tizen Adaptor for common
198 Provides:       %{name}-compat = %{version}-%{release}
199 Conflicts:      %{name}-profile_mobile
200 Conflicts:      %{name}-profile_wearable
201 Conflicts:      %{name}-profile_tv
202 Conflicts:      %{name}-profile_ivi
203 Requires:       %{name}
204 %description profile_common
205 The DALi Tizen Adaptor for common.
206 %endif
207
208 ##############################
209 # devel
210 ##############################
211 %package devel
212 Summary:    Development components for the DALi Tizen Adaptor
213 Group:      Development/Building
214 Requires:   %{name} = %{version}-%{release}
215 Requires:   %{name}-integration-devel = %{version}-%{release}
216
217 %description devel
218 Development components for the DALi Tizen Adaptor - public headers and package configs
219
220 ##############################
221 # integration-devel
222 ##############################
223 %package integration-devel
224 Summary:    Integration development package for the Adaptor
225 Group:      Development/Building
226 Requires:   %{name} = %{version}-%{release}
227
228 %description integration-devel
229 Integration development package for the Adaptor - headers for integrating with an adaptor library.
230
231 ##############################
232 # Dali Feedback Plugin
233 ##############################
234 %package dali2-feedback-plugin
235 Summary:    Plugin to play haptic and audio feedback for Dali
236 Group:      System/Libraries
237 Requires:   %{name} = %{version}-%{release}
238 %description dali2-feedback-plugin
239 Feedback plugin to play haptic and audio feedback for Dali
240
241 #Use TZ_PATH when tizen version is 3.x or greater
242 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
243 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
244 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
245 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
246 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
247 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
248
249 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
250 %define dali_plugin_sound_files  /plugins/sounds/
251
252 ##############################
253 # Preparation
254 ##############################
255 %prep
256 %setup -q
257
258
259 ##############################
260 # Build
261 ##############################
262 %build
263 PREFIX+="/usr"
264 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
265 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
266
267 %ifarch %{arm}
268 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
269 %endif
270
271 CFLAGS+=" -DWAYLAND"
272 CXXFLAGS+=" -DWAYLAND"
273 cmake_flags=" -DENABLE_WAYLAND=ON -DENABLE_ATSPI=ON -DENABLE_TRACE=ON"
274
275 # Use this conditional when Tizen version is 5.x or greater
276 %if 0%{?tizen_version_major} >= 5
277 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
278
279 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
280 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
281 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
282 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
283 %endif
284
285 # Use this conditional when Tizen version is 7.x or greater
286 %if 0%{?tizen_version_major} >= 7
287 CXXFLAGS+=" -DOVER_TIZEN_VERSION_7"
288 %endif
289
290 # Use this conditional when Tizen version is 8.x or greater
291 %if 0%{?tizen_version_major} >= 8
292 CXXFLAGS+=" -DOVER_TIZEN_VERSION_8"
293 %endif
294
295 %if 0%{?enable_debug}
296 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
297 %endif
298
299 %if 0%{?enable_logging}
300 cmake_flags+=" -DENABLE_NETWORK_LOGGING=ON"
301 %endif
302
303 libtoolize --force
304 cd %{_builddir}/%{name}-%{version}/build/tizen
305
306 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
307 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
308 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
309 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
310 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
311 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
312 %if 0%{?tizen_platform_config_supported}
313 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
314 %endif
315
316 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
317 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
318 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
319 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
320 cmake_flags+=" -DENABLE_FEEDBACK=YES"
321 cmake_flags+=" -DENABLE_APPFW=YES"
322 cmake_flags+=" -DCOMPONENT_APPLICATION_SUPPORT=YES"
323
324 # Set up the build via Cmake
325 #######################################################################
326 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
327 # if mobile || "undefined"
328 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
329
330 mkdir -p mobile
331 pushd mobile
332
333 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
334
335 # Build.
336 make %{?jobs:-j%jobs}
337 popd
338
339 %endif
340
341 #######################################################################
342 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
343 # if tv ||"undefined"
344 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
345
346 mkdir -p tv
347 pushd tv
348
349 cmake -DENABLE_PROFILE=TV $cmake_flags ..
350
351 # Build.
352 make %{?jobs:-j%jobs}
353 popd
354
355 %endif
356
357 #######################################################################
358 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
359 # if wearable || "undefined"
360 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
361
362 mkdir -p wearable
363 pushd wearable
364
365 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
366
367 # Build.
368 make %{?jobs:-j%jobs}
369 popd
370
371 %endif
372
373 #######################################################################
374 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
375 # if ivi ||"undefined"
376 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
377
378 mkdir -p ivi
379 pushd ivi
380
381 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
382
383 # Build.
384 make %{?jobs:-j%jobs}
385 popd
386
387 %endif
388
389 #######################################################################
390 # common
391 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
392 # if common ||"undefined"
393 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
394
395 mkdir -p common
396 pushd common
397
398 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
399
400 # Build.
401 make %{?jobs:-j%jobs}
402 popd
403
404 %endif
405
406 ##############################
407 # Installation
408 ##############################
409 %install
410 rm -rf %{buildroot}
411
412 pushd %{_builddir}/%{name}-%{version}/build/tizen
413
414 # if mobile || "undefined"
415 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
416 pushd mobile
417 %make_install
418 %if "%{?profile}" != "mobile"
419 pushd  %{buildroot}%{_libdir}
420 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
421 popd
422 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
423 %endif
424 popd
425 %endif
426
427 # if tv ||"undefined"
428 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
429 pushd tv
430 %make_install
431 %if "%{?profile}" != "tv"
432 pushd  %{buildroot}%{_libdir}
433 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
434 popd
435 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
436 %endif
437 popd
438 %endif
439
440 # if wearable || "undefined"
441 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
442 pushd wearable
443 %make_install
444 %if "%{?profile}" != "wearable"
445 pushd  %{buildroot}%{_libdir}
446 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
447 popd
448 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
449 %endif
450 popd
451 %endif
452
453 # if ivi ||"undefined"
454 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
455 pushd ivi
456 %make_install
457 %if "%{?profile}" != "ivi"
458 pushd  %{buildroot}%{_libdir}
459 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
460 popd
461 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
462 %endif
463 popd
464 %endif
465
466 # if common ||"undefined"
467 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
468 pushd common
469 %make_install
470 # No clean so we can gather symbol/size information for the common profile
471 popd
472 %endif
473
474 # Create a symbolic link in integration-api to preserve legacy repo build
475 pushd %{buildroot}%{_includedir}/dali/integration-api
476 ln -sf adaptor-framework adaptors
477 popd
478
479 ##############################
480 # Upgrade order:
481 # 1 - Pre Install new package
482 # 2 - Install new package
483 # 3 - Post install new package
484 # 4 - Pre uninstall old package
485 # 5 - Remove files not overwritten by new package
486 # 6 - Post uninstall old package
487 ##############################
488
489 ##############################
490 # Adaptor package Commands
491 %pre
492 exit 0
493
494 %post
495 pushd %{_libdir}
496 for i in mobile tv wearable ivi; do [[ -f libdali2-adaptor.so.$i ]] && ln -sf libdali2-adaptor.so.$i libdali2-adaptor.so.2.0.0; done
497 popd
498 /sbin/ldconfig
499 exit 0
500
501 %preun
502 exit 0
503
504 %postun
505 /sbin/ldconfig
506 exit 0
507
508 ##############################
509 # Mobile Profile Commands
510 # if mobile || "undefined"
511 # No need to create a symbolic link on install required if only building this profile
512 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
513 %post profile_mobile
514 %if "%{?profile}" != "mobile"
515 pushd %{_libdir}
516 ln -sf libdali2-adaptor.so.mobile libdali2-adaptor.so.2.0.0
517 popd
518 %endif
519 /sbin/ldconfig
520 exit 0
521
522 %postun profile_mobile
523 /sbin/ldconfig
524 exit 0
525 %endif
526
527 ##############################
528 # TV Profile Commands
529 # No need to create a symbolic link on install required if only building this profile
530 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
531 %post profile_tv
532 %if "%{?profile}" != "tv"
533 pushd %{_libdir}
534 ln -sf libdali2-adaptor.so.tv libdali2-adaptor.so.2.0.0
535 popd
536 %endif
537 /sbin/ldconfig
538 exit 0
539
540 %postun profile_tv
541 /sbin/ldconfig
542 exit 0
543 %endif
544
545 ##############################
546 # Wearable Profile Commands
547 # No need to create a symbolic link on install required if only building this profile
548 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
549 %post profile_wearable
550 %if "%{?profile}" != "wearable"
551 pushd %{_libdir}
552 ln -sf libdali2-adaptor.so.wearable libdali2-adaptor.so.2.0.0
553 popd
554 %endif
555 /sbin/ldconfig
556 exit 0
557
558 %postun profile_wearable
559 /sbin/ldconfig
560 exit 0
561 %endif
562
563 ##############################
564 # IVI Profile Commands
565 # No need to create a symbolic link on install required if only building this profile
566 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
567 %post profile_ivi
568 %if "%{?profile}" != "ivi"
569 pushd %{_libdir}
570 ln -sf libdali2-adaptor.so.ivi libdali2-adaptor.so.2.0.0
571 popd
572 %endif
573 /sbin/ldconfig
574 exit 0
575
576 %postun profile_ivi
577 /sbin/ldconfig
578 exit 0
579 %endif
580
581 ##############################
582 # Common Profile Commands
583 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
584 %post profile_common
585 /sbin/ldconfig
586 exit 0
587
588 %postun profile_common
589 /sbin/ldconfig
590 exit 0
591 %endif
592
593 ##############################
594 # Files in Binary Packages
595 ##############################
596
597 %files
598 %manifest dali-adaptor.manifest
599 %defattr(-,root,root,-)
600 %dir %{user_shader_cache_dir}
601 %{_bindir}/*
602 %license LICENSE
603 %defattr(-,root,root,-)
604 %{_libdir}/libdali2-adaptor.so
605 %{_libdir}/libdali2-adaptor.so.2
606 %{_libdir}/libdali2-adaptor.so.2.0.0
607
608 #################################################
609
610 %files dali2-feedback-plugin
611 %manifest dali-adaptor.manifest
612 %defattr(-,root,root,-)
613 %{_libdir}/libdali2-feedback-plugin.so*
614 %{dali_plugin_sound_files}/*
615
616 #################################################
617
618 # if common ||"undefined"
619 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
620 %files profile_common
621 %manifest dali-adaptor.manifest
622 # default .so files are housed in the main pkg.
623 %endif
624
625 # if mobile || "undefined"
626 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
627 %files profile_mobile
628 %manifest dali-adaptor.manifest
629 %defattr(-,root,root,-)
630 %if "%{?profile}" != "mobile"
631 %{_libdir}/libdali2-adaptor.so.mobile
632 %endif
633 %endif
634
635 # if tv ||"undefined"
636 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
637 %files profile_tv
638 %manifest dali-adaptor.manifest
639 %defattr(-,root,root,-)
640 %if "%{?profile}" != "tv"
641 %{_libdir}/libdali2-adaptor.so.tv
642 %endif
643 %endif
644
645 # if wearable || "undefined"
646 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
647 %files profile_wearable
648 %manifest dali-adaptor.manifest
649 %defattr(-,root,root,-)
650 %if "%{?profile}" != "wearable"
651 %{_libdir}/libdali2-adaptor.so.wearable
652 %endif
653 %endif
654
655 # if ivi ||"undefined"
656 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
657 %files profile_ivi
658 %manifest dali-adaptor.manifest
659 %defattr(-,root,root,-)
660 %if "%{?profile}" != "ivi"
661 %{_libdir}/libdali2-adaptor.so.ivi
662 %endif
663 %endif
664
665 %files devel
666 %defattr(-,root,root,-)
667 %{_includedir}/dali/dali.h
668 %{_includedir}/dali/public-api/*
669 %{_includedir}/dali/devel-api/*
670 %{_includedir}/dali/doc/*
671 %{_libdir}/pkgconfig/dali2-adaptor.pc
672
673 %files integration-devel
674 %defattr(-,root,root,-)
675 %{_includedir}/dali/integration-api/adaptor-framework/*
676 %{_includedir}/dali/integration-api/adaptors
677 %{_libdir}/pkgconfig/dali2-adaptor-integration.pc