Merge branch 'mgorse' of git+ssh://git.codethink.co.uk/git/atspi-dbus into rework
[platform/core/uifw/at-spi2-atk.git] / xml / Makefile.am
index ba3c9c6..64b9207 100644 (file)
@@ -25,10 +25,13 @@ XML_SPEC= \
        org.freedesktop.atspi.Value.xml
 
 spec.xml: $(XML_SPEC)
-       xsltproc --xinclude ../tools/identity.xsl $< >$@
+       xsltproc --xinclude $(top_srcdir)/tools/identity.xsl $< >$@
 
 EXTRA_DIST = $(XML_SPEC)
 
+BUILT_SOURCES = spec.xml
+CLEANFILES = spec.xml
+
 INTROSPECT_FILES = $(addprefix introspection/,$(patsubst %.xml,%,$(filter org.freedesktop.atspi%,$(XML_SPEC))))
 
 $(INTROSPECT_FILES): introspection/%: %.xml ../tools/spec-to-introspect.xsl