Added initial implementations of DeviceEventController and KeystrokeListener.
[platform/core/uifw/at-spi2-atk.git] / libspi / Makefile.am
index af5a601..ea022d1 100644 (file)
@@ -15,11 +15,22 @@ CFLAGS += $(DEBUG_CFLAGS)
 libspiincludedir = $(includedir)/libspi
 
 libspiinclude_HEADERS = accessible.h       \
-                       component.h        \
+                       action.h\
                         application.h      \
+                       component.h\
                         desktop.h          \
-                        listener.h         \
+                       editabletext.h\
+                       hyperlink.h\
+                       hypertext.h\
+                       image.h\
+                       selection.h\
+                       table.h\
+                       text.h\
+                       value.h\
+                        listener.h   \
+                       keystrokelistener.h     \
                        accessibleeventlistener.h       \
+                       deviceeventcontroller.h \
                         registry.h         \
                         Accessibility.h
 
@@ -41,12 +52,34 @@ CLEANFILES+=$(IDL_OUT) Accessibility-imodule.c
 
 libspi_la_SOURCES = accessible.c         \
                     accessible.h         \
-                    application.c        \
+                    action.c\
+                   action.h\
+                   application.c        \
                     application.h        \
                    component.c          \
                    component.h          \
                     desktop.c            \
                     desktop.h            \
+                   deviceeventcontroller.c \
+                   deviceeventcontroller.h \
+                   editabletext.c\
+                   editabletext.h\
+                   hyperlink.c\
+                   hyperlink.h\
+                   hypertext.c\
+                   hypertext.h\
+                   image.c\
+                   image.h\
+                   keystrokelistener.c\
+                   keystrokelistener.h\
+                   selection.c\
+                   selection.h\
+                   table.c\
+                   table.h\
+                   text.c\
+                   text.h\
+                   value.c\
+                   value.h\
                     listener.c           \
                     listener.h           \
                    accessibleeventlistener.c   \