Removed po directory from Makefile.am for now.
[platform/core/uifw/at-spi2-atk.git] / libspi / Makefile.am
index f6a626a..b71fb1c 100644 (file)
@@ -2,87 +2,107 @@ lib_LTLIBRARIES = libspi.la
 
 INCLUDES = -I $(top_srcdir)           \
            -I $(top_builddir)         \
-           -I $(top_srcdir)/libspi    \
-           -I $(top_builddir)/libspi  \
            $(LIBSPI_CFLAGS)
 
-LDFLAGS = $(LIBSPI_LIBS) @LT_VERSION_INFO@
+LDFLAGS = $(LIBSPI_LIBS) $(XTST_LIBS) @LT_VERSION_INFO@
 
-DEBUG_CFLAGS=-DSPI_DEBUG
+#DEBUG_CFLAGS=-DSPI_DEBUG
 
 CFLAGS += $(DEBUG_CFLAGS)
 
-libspiincludedir = $(includedir)/libspi
-
-libspiinclude_HEADERS = accessible.h       \
-                        application.h      \
-                        atksimpleobject.h  \
-                        desktop.h          \
-                        listener.h         \
-                        registry.h         \
-                        Accessible.h       \
-                        Application.h      \
-                        Desktop.h          \
-                        Event.h            \
-                        Registry.h         \
-                        Relation.h         \
-                        Role.h             \
-                        State.h
-
-Accessible_IDLOUT = Accessible.h Accessible-stubs.c Accessible-skels.c Accessible-common.c
-Application_IDLOUT = Application.h Application-stubs.c Application-skels.c Application-common.c
-Desktop_IDLOUT = Desktop.h Desktop-stubs.c Desktop-skels.c Desktop-common.c
-Event_IDLOUT = Event.h Event-stubs.c Event-skels.c Event-common.c
-Registry_IDLOUT = Registry.h Registry-stubs.c Registry-skels.c Registry-common.c
-Relation_IDLOUT = Relation.h Relation-stubs.c Relation-skels.c Relation-common.c
-Role_IDLOUT = Role.h Role-stubs.c Role-skels.c Role-common.c
-State_IDLOUT = State.h State-stubs.c State-skels.c State-common.c
-
-BUILT_SOURCES = $(Accessible_IDLOUT)     \
-                $(Application_IDLOUT)    \
-                $(Desktop_IDLOUT)        \
-                $(Event_IDLOUT)          \
-                $(Registry_IDLOUT)      \
-                $(Relation_IDLOUT)       \
-                $(Role_IDLOUT)           \
-                $(State_IDLOUT)
+libspiincludedir = $(includedir)/at-spi-1.0/libspi
+
+libspiinclude_HEADERS = Accessibility.h \
+                       accessible.h \
+                       eventlistener.h \
+                       action.h \
+                        application.h \
+                       base.h \
+                       component.h \
+                       deviceeventcontroller.h \
+                       editabletext.h\
+                       hyperlink.h\
+                       hypertext.h\
+                       image.h \
+                       keystrokelistener.h \
+                       keymasks.h \
+                       libspi.h \
+                        listener.h \
+                       relation.h \
+                       selection.h \
+                       table.h \
+                       text.h \
+                       value.h
+
+IDL_OUT = Accessibility.h Accessibility-stubs.c Accessibility-skels.c Accessibility-common.c
+
+IDL = \
+       $(top_srcdir)/idl/Accessibility.idl \
+       $(top_srcdir)/idl/Accessible.idl    \
+       $(top_srcdir)/idl/Application.idl   \
+       $(top_srcdir)/idl/Desktop.idl       \
+       $(top_srcdir)/idl/Event.idl         \
+       $(top_srcdir)/idl/Registry.idl      \
+       $(top_srcdir)/idl/Relation.idl      \
+       $(top_srcdir)/idl/Role.idl          \
+       $(top_srcdir)/idl/State.idl
+
+BUILT_SOURCES = $(IDL_OUT) Accessibility-imodule.c
+CLEANFILES+=$(IDL_OUT) Accessibility-imodule.c
 
 libspi_la_SOURCES = accessible.c         \
                     accessible.h         \
-                    application.c        \
+                    action.c\
+                   action.h\
+                   application.c        \
                     application.h        \
-                    atksimpleobject.c    \
-                    atksimpleobject.h    \
+                   base.c               \
+                   component.c          \
+                   component.h          \
                     desktop.c            \
                     desktop.h            \
+                   deviceeventcontroller.c \
+                   deviceeventcontroller.h \
+                   editabletext.c\
+                   editabletext.h\
+                   hyperlink.c\
+                   hyperlink.h\
+                   hypertext.c\
+                   hypertext.h\
+                   image.c\
+                   image.h\
+                   keystrokelistener.c\
+                   keystrokelistener.h\
+                   relation.c\
+                   relation.h\
+                   selection.c\
+                   selection.h\
+                   table.c\
+                   table.h\
+                   text.c\
+                   text.h\
+                   value.c\
+                   value.h\
                     listener.c           \
                     listener.h           \
+                   eventlistener.c      \
                     registry.c           \
                     registry.h           \
-                    $(BUILT_SOURCES)
-
-IDLFLAGS = -I$(OAF_IDL_DIR) -I$(LIBBONOBO_IDL_DIR) -I$(top_srcdir)/idl --noimodule
-
-$(Accessible_IDLOUT): $(top_srcdir)/idl/Accessible.idl $(ORBIT_IDL)
-       $(ORBIT_IDL) -D__ACCESSIBILITY_ACCESSIBLE_COMPILATION $(IDLFLAGS) $(top_srcdir)/idl/Accessible.idl
-
-$(Application_IDLOUT): $(top_srcdir)/idl/Application.idl $(ORBIT_IDL)
-       $(ORBIT_IDL) -D__ACCESSIBILITY_APPLICATION_COMPILATION $(IDLFLAGS) $(top_srcdir)/idl/Application.idl
-
-$(Desktop_IDLOUT): $(top_srcdir)/idl/Desktop.idl $(ORBIT_IDL)
-       $(ORBIT_IDL) -D__ACCESSIBILITY_DESKTOP_COMPILATION $(IDLFLAGS) $(top_srcdir)/idl/Desktop.idl
-
-$(Event_IDLOUT): $(top_srcdir)/idl/Event.idl $(ORBIT_IDL)
-       $(ORBIT_IDL) -D__ACCESSIBILITY_EVENT_COMPILATION $(IDLFLAGS) $(top_srcdir)/idl/Event.idl
+                   keymasks.h          \
+                    $(IDL_OUT)
 
-$(Registry_IDLOUT): $(top_srcdir)/idl/Registry.idl $(ORBIT_IDL)
-       $(ORBIT_IDL) -D__ACCESSIBILITY_REGISTRY_COMPILATION $(IDLFLAGS) $(top_srcdir)/idl/Registry.idl
+IDLFLAGS = -I$(BONOBO_ACTIVATION_IDL_DIR) \
+          -I$(LIBBONOBO_IDL_DIR)         \
+          -I$(top_srcdir)/idl            \
+          --add-imodule
 
-$(Relation_IDLOUT): $(top_srcdir)/idl/Relation.idl $(ORBIT_IDL)
-       $(ORBIT_IDL) -D__ACCESSIBILITY_RELATION_COMPILATION $(IDLFLAGS) $(top_srcdir)/idl/Relation.idl
+$(IDL_OUT) Accessibility-imodule.c : $(IDL) $(ORBIT_IDL)
+       $(ORBIT_IDL) -D__ACCESSIBILITY_COMPILATION__ $(IDLFLAGS) $(top_srcdir)/idl/Accessibility.idl
 
-$(Role_IDLOUT): $(top_srcdir)/idl/Role.idl $(ORBIT_IDL)
-       $(ORBIT_IDL) -D__ACCESSIBILITY_ROLE_COMPILATION $(IDLFLAGS) $(top_srcdir)/idl/Role.idl
+orbittypelibdir = $(libdir)/orbit-2.0
+orbittypelib_LTLIBRARIES = Accessibility_module.la
 
-$(State_IDLOUT): $(top_srcdir)/idl/State.idl $(ORBIT_IDL)
-       $(ORBIT_IDL) -D__ACCESSIBILITY_STATE_COMPILATION $(IDLFLAGS) $(top_srcdir)/idl/State.idl
+Accessibility_module_la_LDFLAGS = \
+       -export-dynamic -module
+Accessibility_module_la_SOURCES = \
+       Accessibility-imodule.c