2001-12-11 Michael Meeks <michael@ximian.com>
[platform/core/uifw/at-spi2-atk.git] / libspi / Makefile.am
index dd02937..a7e9df9 100644 (file)
@@ -2,52 +2,62 @@ lib_LTLIBRARIES = libspi.la
 
 INCLUDES = -I $(top_srcdir)           \
            -I $(top_builddir)         \
-           -I $(top_srcdir)/libspi    \
-           -I $(top_builddir)/libspi  \
            $(LIBSPI_CFLAGS)
 
-LDFLAGS = $(LIBSPI_LIBS) -lXtst @LT_VERSION_INFO@
+LDFLAGS = $(LIBSPI_LIBS) $(XTST_LIBS) @LT_VERSION_INFO@
 
-DEBUG_CFLAGS=-DSPI_DEBUG
+#DEBUG_CFLAGS=-DSPI_DEBUG
 
 CFLAGS += $(DEBUG_CFLAGS)
 
 libspiincludedir = $(includedir)/at-spi-1.0/libspi
 
-libspiinclude_HEADERS = accessible.h       \
-                       action.h\
-                        application.h      \
-                       component.h\
-                        desktop.h          \
+libspiinclude_HEADERS = Accessibility.h \
+                       accessible.h \
+                       eventlistener.h \
+                       action.h \
+                        application.h \
+                       base.h \
+                       component.h \
                        editabletext.h\
                        hyperlink.h\
                        hypertext.h\
-                       image.h\
-                       relation.h\
-                       selection.h\
-                       table.h\
-                       text.h\
-                       value.h\
-                        listener.h   \
-                       keystrokelistener.h     \
-                       accessibleeventlistener.h       \
-                       deviceeventcontroller.h \
-                        registry.h         \
-                       keymasks.h      \
-                        Accessibility.h
+                       image.h \
+                       keystrokelistener.h \
+                       keymasks.h \
+                       libspi.h \
+                        listener.h \
+                       relation.h \
+                       selection.h \
+                       table.h \
+                       text.h \
+                       value.h
 
 IDL_OUT = Accessibility.h Accessibility-stubs.c Accessibility-skels.c Accessibility-common.c
 
-IDL = \
-       $(top_srcdir)/idl/Accessibility.idl \
-       $(top_srcdir)/idl/Accessible.idl    \
-       $(top_srcdir)/idl/Application.idl   \
-       $(top_srcdir)/idl/Desktop.idl       \
-       $(top_srcdir)/idl/Event.idl         \
-       $(top_srcdir)/idl/Registry.idl      \
-       $(top_srcdir)/idl/Relation.idl      \
-       $(top_srcdir)/idl/Role.idl          \
-       $(top_srcdir)/idl/State.idl
+IDL_DEPS = \
+       $(top_srcdir)/idl/Accessibility.idl                     \
+       $(top_srcdir)/idl/Accessibility_Accessible.idl          \
+       $(top_srcdir)/idl/Accessibility_Action.idl              \
+       $(top_srcdir)/idl/Accessibility_Application.idl         \
+       $(top_srcdir)/idl/Accessibility_Component.idl           \
+       $(top_srcdir)/idl/Accessibility_Desktop.idl             \
+       $(top_srcdir)/idl/Accessibility_EditableText.idl        \
+       $(top_srcdir)/idl/Accessibility_Event.idl               \
+       $(top_srcdir)/idl/Accessibility_Hyperlink.idl           \
+       $(top_srcdir)/idl/Accessibility_Hypertext.idl           \
+       $(top_srcdir)/idl/Accessibility_Image.idl               \
+       $(top_srcdir)/idl/Accessibility_Registry.idl            \
+       $(top_srcdir)/idl/Accessibility_Relation.idl            \
+       $(top_srcdir)/idl/Accessibility_Role.idl                \
+       $(top_srcdir)/idl/Accessibility_Selection.idl           \
+       $(top_srcdir)/idl/Accessibility_State.idl               \
+       $(top_srcdir)/idl/Accessibility_StreamableContent.idl   \
+       $(top_srcdir)/idl/Accessibility_Table.idl               \
+       $(top_srcdir)/idl/Accessibility_Text.idl                \
+       $(top_srcdir)/idl/Accessibility_Value.idl
+
+
 
 BUILT_SOURCES = $(IDL_OUT) Accessibility-imodule.c
 CLEANFILES+=$(IDL_OUT) Accessibility-imodule.c
@@ -58,12 +68,9 @@ libspi_la_SOURCES = accessible.c         \
                    action.h\
                    application.c        \
                     application.h        \
+                   base.c               \
                    component.c          \
                    component.h          \
-                    desktop.c            \
-                    desktop.h            \
-                   deviceeventcontroller.c \
-                   deviceeventcontroller.h \
                    editabletext.c\
                    editabletext.h\
                    hyperlink.c\
@@ -86,10 +93,7 @@ libspi_la_SOURCES = accessible.c         \
                    value.h\
                     listener.c           \
                     listener.h           \
-                   accessibleeventlistener.c   \
-                   accessibleeventlistener.h   \
-                    registry.c           \
-                    registry.h           \
+                   eventlistener.c      \
                    keymasks.h          \
                     $(IDL_OUT)
 
@@ -98,7 +102,7 @@ IDLFLAGS = -I$(BONOBO_ACTIVATION_IDL_DIR) \
           -I$(top_srcdir)/idl            \
           --add-imodule
 
-$(IDL_OUT) Accessibility-imodule.c : $(IDL) $(ORBIT_IDL)
+$(IDL_OUT) Accessibility-imodule.c : $(IDL_DEPS) $(ORBIT_IDL)
        $(ORBIT_IDL) -D__ACCESSIBILITY_COMPILATION__ $(IDLFLAGS) $(top_srcdir)/idl/Accessibility.idl
 
 orbittypelibdir = $(libdir)/orbit-2.0