Added initial support for multiple interfaces on Accessible objects
[platform/core/uifw/at-spi2-atk.git] / libspi / Makefile.am
index d8d7a6e..89e3055 100644 (file)
@@ -15,6 +15,7 @@ CFLAGS += $(DEBUG_CFLAGS)
 libspiincludedir = $(includedir)/libspi
 
 libspiinclude_HEADERS = accessible.h       \
+                       component.h        \
                         application.h      \
                         desktop.h          \
                         listener.h         \
@@ -41,6 +42,8 @@ libspi_la_SOURCES = accessible.c         \
                     accessible.h         \
                     application.c        \
                     application.h        \
+                   component.c          \
+                   component.h          \
                     desktop.c            \
                     desktop.h            \
                     listener.c           \
@@ -49,7 +52,7 @@ libspi_la_SOURCES = accessible.c         \
                     registry.h           \
                     $(IDL_OUT)
 
-IDLFLAGS = -I$(OAF_IDL_DIR) -I$(LIBBONOBO_IDL_DIR) -I$(top_srcdir)/idl
+IDLFLAGS = -I$(BONOBO_ACTIVATION_IDL_DIR) -I$(LIBBONOBO_IDL_DIR) -I$(top_srcdir)/idl
 
 $(IDL_OUT) : $(IDL) $(ORBIT_IDL)
        $(ORBIT_IDL) -D__ACCESSIBILITY_COMPILATION__ $(IDLFLAGS) $(top_srcdir)/idl/Accessibility.idl