Removed the extra boolean parameter added to know when to unref the
[platform/core/uifw/at-spi2-atk.git] / atk-adaptor / Makefile.am
index 18efb50..490461d 100644 (file)
@@ -1,38 +1,16 @@
-gtkmoduledir = $(libdir)/$(GTK_MODULE_DIR)
-gtkmodule_LTLIBRARIES = libspiatk.la
+SUBDIRS=adaptors gtk-2.0 gtk-3.0
 
-libspiatk_la_CFLAGS = $(DBUS_GLIB_CFLAGS) $(ATK_CFLAGS) -I$(top_srcdir)
+if RELOCATE
+    gtkpathdir = $(libdir)/gtk-2.0/modules/at-spi-dbus
+gnomeautostartdir = $(datadir)/gnome/autostart
+gnomeautostart_DATA = atk-bridge.desktop
+endif
 
-libspiatk_la_LDFLAGS = -no-undefined       \
-                      -module             \
-                      -avoid-version      \
-                      -rpath $(gtkmoduledir)
+EXTRA_DIST = atk-bridge.desktop.in \
+       Makefile.include
 
-libspiatk_la_LIBADD = $(DBUS_GLIB_LIBS)                        \
-                     $(ATK_LIBS)                       \
-                     $(top_builddir)/droute/libdroute.la       \
-                     $(top_builddir)/spi-common/libspicommon.la
+CLEANFILES = atk-bridge.desktop
 
-libspiatk_la_SOURCES =         \
-       accessible.h            \
-       accessible.c            \
-       bitarray.h              \
-       action.c                \
-       application.c           \
-       bridge.c                \
-       component.c             \
-       document.c              \
-       editabletext.c          \
-       hyperlink.c             \
-       hypertext.c             \
-       atk-dbus.c              \
-       image.c                 \
-       keymasks.h              \
-       selection.c             \
-       spi-private.h           \
-       table.c                 \
-       text.c                  \
-       tree.c                  \
-       util.c                  \
-       value.c                 \
-       introspectable.c 
+%.desktop: %.desktop.in Makefile.am
+       sed -e "s,\@gtkpathdir\@,$(gtkpathdir)," \
+       < $< > $@