Removed the extra boolean parameter added to know when to unref the
[platform/core/uifw/at-spi2-atk.git] / atk-adaptor / Makefile.am
index 129f491..490461d 100644 (file)
@@ -1,56 +1,15 @@
-gtkmoduledir = $(libdir)/$(GTK_MODULE_DIR)
-gtkmodule_LTLIBRARIES = libatk-bridge.la
+SUBDIRS=adaptors gtk-2.0 gtk-3.0
 
-libatk_bridge_la_CFLAGS = $(DBUS_GLIB_CFLAGS) \
-                         $(ATK_CFLAGS)       \
-                         $(DBIND_CFLAGS)     \
-                         $(DROUTE_CFLAGS)    \
-                         -I$(top_srcdir)     \
-                         -DATSPI_INTROSPECTION_PATH=\"$(pkgdatadir)/$(DEFAULT_ATSPI_INTROSPECTION_PATH)\"
-
-libatk_bridge_la_LDFLAGS = -no-undefined  \
-                          -module        \
-                          -avoid-version \
-                          -rpath $(gtkmoduledir)
-
-libatk_bridge_la_LIBADD = $(DBUS_GLIB_LIBS) \
-                         $(ATK_LIBS)       \
-                         $(DBIND_LIBS)     \
-                         $(DROUTE_LIBS)    \
-                         $(top_builddir)/common/libspicommon.la
-
-libatk_bridge_la_SOURCES =     \
-       accessible-adaptor.c    \
-       accessible-marshaller.c \
-       accessible-marshaller.h \
-       accessible-register.c   \
-       accessible-register.h   \
-       action-adaptor.c        \
-       adaptors.h              \
-       application-adaptor.c   \
-       bridge.c                \
-       bridge.h                \
-       collection-adaptor.c    \
-       component-adaptor.c     \
-       document-adaptor.c      \
-       editabletext-adaptor.c  \
-       event.c                 \
-       event.h                 \
-       hyperlink-adaptor.c     \
-       hypertext-adaptor.c     \
-       image-adaptor.c         \
-       selection-adaptor.c     \
-       table-adaptor.c         \
-       text-adaptor.c          \
-       tree-adaptor.c          \
-       tree-adaptor.h          \
-       value-adaptor.c
-
-gtkpathdir = $(gtkmoduledir)/..
+if RELOCATE
+    gtkpathdir = $(libdir)/gtk-2.0/modules/at-spi-dbus
 gnomeautostartdir = $(datadir)/gnome/autostart
 gnomeautostart_DATA = atk-bridge.desktop
-EXTRA_DIST = atk-bridge.desktop.in
-CLEANFILES = $(gnome_autostart_DATA)
+endif
+
+EXTRA_DIST = atk-bridge.desktop.in \
+       Makefile.include
+
+CLEANFILES = atk-bridge.desktop
 
 %.desktop: %.desktop.in Makefile.am
        sed -e "s,\@gtkpathdir\@,$(gtkpathdir)," \