Fix daemon crash issue
[platform/core/telephony/tel-plugin-vmodem.git] / packaging / tel-plugin-vmodem.spec
1 %define major 0
2 %define minor 1
3 %define patchlevel 26
4
5 Name:           tel-plugin-vmodem
6 Version:        %{major}.%{minor}.%{patchlevel}
7 Release:        1
8 License:        Apache-2.0
9 Summary:        Telephony AT Virtual Modem library
10 Group:          System/Libraries
11 Source0:        tel-plugin-vmodem-%{version}.tar.gz
12
13 %if "%{profile}" == "tv"
14 ExcludeArch: %{arm} %ix86 x86_64
15 %endif
16
17 %if "%{_with_emulator}" != "1"
18 ExcludeArch: %{arm} aarch64
19 %endif
20
21 BuildRequires:  cmake
22 BuildRequires:  pkgconfig(glib-2.0)
23 BuildRequires:  pkgconfig(dlog)
24 BuildRequires:  pkgconfig(tcore)
25 Requires(post): /sbin/ldconfig
26 Requires(postun): /sbin/ldconfig
27
28 %description
29 Telephony AT Modem library
30
31 %prep
32 %setup -q
33
34 %build
35 versionint=$[%{major} * 1000000 + %{minor} * 1000 + %{patchlevel}]
36 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
37         -DLIB_INSTALL_DIR=%{_libdir} \
38         -DVERSION=$versionint
39 make %{?_smp_mflags}
40
41 %post
42 /sbin/ldconfig
43
44 %postun -p /sbin/ldconfig
45
46 %install
47 %make_install
48 mkdir -p %{buildroot}/usr/share/license
49
50 %files
51 %manifest tel-plugin-vmodem.manifest
52 %defattr(644,root,root,-)
53 #%doc COPYING
54 %{_libdir}/telephony/plugins/vmodem-plugin*
55 /usr/share/license/tel-plugin-vmodem