fe33031f8a20f0edec473196cf53e5538e2c12a9
[platform/core/telephony/tel-plugin-indicator.git] / packaging / tel-plugin-indicator.spec
1 %define major 3
2 %define minor 0
3 %define patchlevel 1
4
5 Name:       tel-plugin-indicator
6 Summary:    Telephony Indicator plugin
7 Version:        %{major}.%{minor}.%{patchlevel}
8 Release:    1
9 Group:      System/Libraries
10 License:    Apache-2.0
11 Source0:    tel-plugin-indicator-%{version}.tar.gz
12 Source1001:     tel-plugin-indicator.manifest
13 Requires(post): /sbin/ldconfig
14 Requires(postun): /sbin/ldconfig
15 BuildRequires:  cmake
16 BuildRequires:  pkgconfig(glib-2.0)
17 BuildRequires:  pkgconfig(tcore)
18 BuildRequires:  pkgconfig(dlog)
19
20 %description
21 Telephony Indicator plugin
22
23 %prep
24 %setup -q
25 cp %{SOURCE1001} .
26
27 %build
28 %cmake .
29 make %{?jobs:-j%jobs}
30
31 %post 
32 /sbin/ldconfig
33
34 %postun -p /sbin/ldconfig
35
36 %install
37 %make_install
38 mkdir -p %{buildroot}/usr/share/license
39 cp LICENSE %{buildroot}/usr/share/license/%{name}
40
41 %files
42 %manifest %{name}.manifest
43 %defattr(-,root,root,-)
44 %{_libdir}/telephony/plugins/indicator-plugin*
45 /usr/share/license/%{name}