Sync from SPIN branch
[platform/core/telephony/tel-plugin-indicator.git] / packaging / tel-plugin-indicator.spec
1 %define major 0
2 %define minor 1
3 %define patchlevel 68
4
5 Name:           tel-plugin-indicator
6 Version:        %{major}.%{minor}.%{patchlevel}
7 Release:        5
8 License:        Apache-2.0
9 Summary:        Telephony Indicator plugin
10 Group:          System/Libraries
11 Source0:        tel-plugin-indicator-%{version}.tar.gz
12 BuildRequires:  cmake
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(glib-2.0)
15 BuildRequires:  pkgconfig(tcore)
16 Requires(post): /sbin/ldconfig
17 Requires(postun): /sbin/ldconfig
18
19 %description
20 Telephony Indicator plugin
21
22 %prep
23 %setup -q
24
25 %build
26 versionint=$[%{major} * 1000000 + %{minor} * 1000 + %{patchlevel}]
27
28 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
29         -DLIB_INSTALL_DIR=%{_libdir} \
30         -DVERSION=$versionint \
31
32 make %{?_smp_mflags}
33
34 %post
35 /sbin/ldconfig
36
37 %postun -p /sbin/ldconfig
38
39 %install
40 %make_install
41 mkdir -p %{buildroot}/usr/share/license
42 cp LICENSE %{buildroot}/usr/share/license/%{name}
43
44 %files
45 %manifest tel-plugin-indicator.manifest
46 %defattr(644,system,system,-)
47 %{_libdir}/telephony/plugins/indicator-plugin*
48 /usr/share/license/%{name}