Fix parse warnings
[platform/core/telephony/tel-plugin-indicator.git] / packaging / tel-plugin-indicator.spec
1 %define major 0
2 %define minor 1
3 %define patchlevel 74
4
5 Name:           tel-plugin-indicator
6 Version:        %{major}.%{minor}.%{patchlevel}
7 Release:        5
8 License:        Apache-2.0
9 Summary:        Telephony Indicator plugin
10 Group:          System/Libraries
11 Source0:        tel-plugin-indicator-%{version}.tar.gz
12
13 BuildRequires:  cmake
14 BuildRequires:  pkgconfig(dlog)
15 BuildRequires:  pkgconfig(glib-2.0)
16 BuildRequires:  pkgconfig(tcore)
17 Requires(post): /sbin/ldconfig
18 Requires(postun): /sbin/ldconfig
19
20 %description
21 Telephony Indicator plugin
22
23 %prep
24 %setup -q
25
26 %build
27 versionint=$[%{major} * 1000000 + %{minor} * 1000 + %{patchlevel}]
28
29 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
30         -DLIB_INSTALL_DIR=%{_libdir} \
31         -DVERSION=$versionint \
32
33 make %{?_smp_mflags}
34
35 %post
36 /sbin/ldconfig
37
38 %postun -p /sbin/ldconfig
39
40 %install
41 %make_install
42
43 %files
44 %manifest tel-plugin-indicator.manifest
45 %defattr(644,root,root,-)
46 %{_libdir}/telephony/plugins/indicator-plugin*
47 %license LICENSE