Code Sync up from tizen_2.4
[platform/core/telephony/tel-plugin-indicator.git] / packaging / tel-plugin-indicator.spec
1 %define major 0
2 %define minor 1
3 %define patchlevel 62
4
5 Name:           tel-plugin-indicator
6 Version:        %{major}.%{minor}.%{patchlevel}
7 Release:        5
8 License:        Apache-2.0
9 Summary:        Telephony Indicator plugin
10 Group:          System/Libraries
11 Source0:        tel-plugin-indicator-%{version}.tar.gz
12 BuildRequires:  cmake
13 BuildRequires:  pkgconfig(deviced)
14 BuildRequires:  pkgconfig(dlog)
15 BuildRequires:  pkgconfig(glib-2.0)
16 BuildRequires:  pkgconfig(vconf)
17 BuildRequires:  pkgconfig(tcore)
18 Requires(post): /sbin/ldconfig
19 Requires(postun): /sbin/ldconfig
20
21 %description
22 Telephony Indicator plugin
23
24 %prep
25 %setup -q
26
27 %build
28 versionint=$[%{major} * 1000000 + %{minor} * 1000 + %{patchlevel}]
29
30 %cmake . -DVERSION=$versionint \
31
32 make %{?_smp_mflags}
33
34 %post
35 /sbin/ldconfig
36
37 ##setting vconf key##
38 vconftool set -t bool memory/testmode/fast_dormancy 0 -i -f -s telephony_framework::vconf
39 vconftool set -t bool memory/testmode/fast_dormancy2 0 -i -f -s telephony_framework::vconf
40
41 %postun -p /sbin/ldconfig
42
43 %install
44 %make_install
45 mkdir -p %{buildroot}/usr/share/license
46 cp LICENSE %{buildroot}/usr/share/license/%{name}
47
48 %files
49 %manifest tel-plugin-indicator.manifest
50 %defattr(-,root,root,-)
51 %{_libdir}/telephony/plugins/indicator-plugin*
52 /usr/share/license/%{name}