264f4ffcac4fa5e2a45b58db2dbf16f871270a4a
[platform/core/telephony/tel-plugin-indicator.git] / packaging / tel-plugin-indicator.spec
1 %define major 3
2 %define minor 0
3 %define patchlevel 1
4
5 Name:       tel-plugin-indicator
6 Summary:    Telephony Indicator plugin
7 Version:        %{major}.%{minor}.%{patchlevel}
8 Release:    1
9 Group:      System/Libraries
10 License:    Apache-2.0
11 Source0:    tel-plugin-indicator-%{version}.tar.gz
12 Source1001:     tel-plugin-indicator.manifest
13 Requires(post): /sbin/ldconfig
14 Requires(postun): /sbin/ldconfig
15 BuildRequires:  cmake
16 BuildRequires:  pkgconfig(glib-2.0)
17 BuildRequires:  pkgconfig(tcore)
18
19 %description
20 Telephony Indicator plugin
21
22 %prep
23 %setup -q
24 cp %{SOURCE1001} .
25
26 %build
27 %cmake .
28 make %{?jobs:-j%jobs}
29
30 %post 
31 /sbin/ldconfig
32
33 %postun -p /sbin/ldconfig
34
35 %install
36 %make_install
37 mkdir -p %{buildroot}/usr/share/license
38 cp LICENSE %{buildroot}/usr/share/license/%{name}
39
40 %files
41 %manifest %{name}.manifest
42 %defattr(-,root,root,-)
43 %{_libdir}/telephony/plugins/indicator-plugin*
44 /usr/share/license/%{name}