[Internal: License name changed]
[platform/core/system/sync-agent.git] / test / dummy_project / packaging / dummy-agent.spec
1 Name:       dummy-agent
2 Summary:    dummy-agent daemon for data sync
3 Version:    0.1.1
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Apache License, Version 2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post): /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10 BuildRequires:  pkgconfig(glib-2.0)
11 BuildRequires:  pkgconfig(sync-agent)
12 BuildRequires:  pkgconfig(libwbxml2)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(sqlite3)
15 BuildRequires:  expat-devel
16 BuildRequires:  cmake
17
18
19 %description
20 dummy-agent daemon (development headers)
21
22 %package -n dummy-plugins
23 Summary:    dummy Plugins
24 Group:      TO_BE_FILLED
25
26 %description -n dummy-plugins
27 dummy plugins for sync-agent
28
29
30 %prep
31 %setup -q
32
33
34 %build
35 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
36 make %{?jobs:-j%jobs}
37
38
39 %install
40 rm -rf %{buildroot}
41 %make_install
42
43
44 %clean
45 rm -rf %{buildroot}
46
47
48 %post
49
50
51 %preun
52
53
54 %postun
55
56 rm -f /tmp/agent_fw_event_omads*
57 rm -f /tmp/agent_fw_noti_reply_omads*
58
59 rm -rf /usr/share/oma-ds-cfg
60
61
62 %files
63 %manifest dummy-agent.manifest
64 %defattr(-,root,root,-)
65
66 /usr/bin/dummy-agent
67
68 /usr/share/dummy-cfg/*
69
70
71 %files -n dummy-plugins
72 %manifest dummy-plugins.manifest
73 %defattr(-,root,root,-)
74 /usr/lib/sync-agent/dummy/*