Fix for 64 bit compatibility.
[platform/core/system/haptic-module-tizen.git] / packaging / haptic-module-tizen.spec
1 #sbs-git:slp/pkgs/d/devman devman 0.1.6 5bf2e95e0bb15c43ff928f7375e1978b0accb0f8
2 Name:       haptic-module-tizen
3 Summary:    Haptic Module library
4 Version:    0.1.0
5 Release:    9
6 Group:      System/Libraries
7 License:    APLv2
8 Source0:    %{name}-%{version}.tar.gz
9 BuildRequires: cmake
10 BuildRequires: pkgconfig(dlog)
11 BuildRequires: pkgconfig(vconf)
12 BuildRequires: pkgconfig(haptic-plugin)
13 BuildRequires: pkgconfig(device-node)
14
15 Requires(post): /sbin/ldconfig
16 Requires(postun): /sbin/ldconfig
17
18 %description
19
20 %prep
21 %setup -q
22
23 %build
24 %if 0%{?simulator}
25 %cmake . -DSIMULATOR=yes
26 %else
27 %ifarch %{ix86}
28 CFLAGS=`echo %{optflags} |sed 's/\-fexceptions//g'`
29 %endif
30 %cmake . -DSIMULATOR=no
31 %endif
32 make %{?jobs:-j%jobs}
33
34 %install
35 rm -rf %{buildroot}
36 %make_install
37
38 %post -p /sbin/ldconfig
39
40 %postun -p /sbin/ldconfig
41
42 %files
43 %{_libdir}/libhaptic-module.so