8eb0094548d41b9d4b1d7dd527c362738ca9dcc7
[platform/core/security/drm-service-core-tizen.git] / packaging / drm-service-core-sapps.spec
1 Name:       drm-service-core-sapps
2 Summary:    The plugin library for installing drm-service-core-sapps.so
3 Version:    0.2.8
4 Release:    0
5 Group:      TO_BE/FILLED_IN
6 License:    Flora
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9
10 Provides: libdrm-service-core-sapps.so.0
11
12 Requires(post): /sbin/ldconfig  
13 Requires(postun): /sbin/ldconfig
14
15 %description
16 The plugin library for installing drm-service-core-sapps.so
17
18 %package devel
19 Summary:    The plugin library for drm-service-core-sapps(Development)
20 Group:      TO_BE/FILLED_IN
21 Requires:   %{name} = %{version}-%{release}
22
23 %description devel
24 The plugin library for installing drm-service-core-sapps.so and header files.
25
26 %prep
27 %setup -q
28
29 %build
30 %ifarch %{arm}
31 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DARCH=arm
32 %else
33 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DARCH=ix86
34 %endif
35 make
36 #make %{?jobs:-j%jobs}
37
38 %install
39 rm -rf %{buildroot}
40
41 %make_install
42
43 %post
44 /bin/rm -f /etc/ld.so.cache
45 /sbin/ldconfig
46
47 %{_bindir}/drm_sapps_initialize
48
49 ln -s -f %{_libdir}/libdrm-service-core-sapps.so.0.2.8 %{_libdir}/libdrm-service-core-sapps.so.0
50 ln -s -f %{_libdir}/libdrm-service-core-sapps.so.0 %{_libdir}/libdrm-service-core-sapps.so
51
52 %postun -p /sbin/ldconfig
53
54 %files
55 %manifest drm-service-core-sapps.manifest
56 %defattr(-,root,root,-)
57 %{_libdir}/libdrm-service-core-sapps.so*
58 %{_bindir}/drm_sapps_initialize
59
60 %files devel
61 %defattr(-,root,root,-)
62 %{_libdir}/pkgconfig/drm-service-core-sapps.pc
63 %{_includedir}/drm-sapps/drm-oem-sapps.h
64
65 %clean
66 rm -rf drm_sapps_initialize
67 rm -rf libdrm-service-core-sapps.so*