Clean spec file for yocto compliance.
[platform/core/multimedia/libmm-ta.git] / packaging / libmm-ta.spec
1 Name:       libmm-ta
2 Summary:    Multimedia Framework Time Analysis Lib
3 Version:    0.1.4
4 Release:    0
5 Group:      System/Libraries
6 License:    Apache-2.0
7 Source0:    libmm-ta-%{version}.tar.gz
8 Source1001: libmm-ta.manifest
9
10 %description
11 Multimedia Framework Time Analysis Library
12
13 %package devel
14 Summary:    Dev. components for the libmm-ta package (devel)
15 Group:      Development/Libraries
16 Requires:   %{name} = %{version}-%{release}
17
18 %description devel
19 Development components for the libmm-ta package (devel)
20
21 %prep
22 %setup -q 
23 cp %{SOURCE1001} .
24
25 %build
26 %reconfigure --disable-static
27 %__make %{?_smp_mflags}
28
29 %install
30 rm -rf %{buildroot}
31 %make_install
32
33 %post -p /sbin/ldconfig
34
35 %postun -p /sbin/ldconfig
36
37 %files
38 %manifest %{name}.manifest
39 %defattr(-,root,root,-)
40 %{_libdir}/libmm_ta.so.*
41
42 %files devel
43 %manifest %{name}.manifest
44 %defattr(-,root,root,-)
45 %{_includedir}/mm_ta/*.h
46 %{_libdir}/*.so
47 %{_libdir}/pkgconfig/*.pc