Add multi-user support
[platform/core/location/liblocation-appman.git] / packaging / liblocation-appman.spec
1 %define _optdir /opt
2 Name:       liblocation-appman
3 Summary:    Location DB controler
4 Version:    0.1.6
5 Release:    0
6 Group:      System/Libraries
7 License:    Apache-2.0
8 Source0:    %{name}-%{version}.tar.gz
9 Source1001: liblocation-appman.manifest
10
11 Requires(post): sqlite
12 BuildRequires:  cmake
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(dlog)
15 BuildRequires:  pkgconfig(sqlite3)
16 BuildRequires:  pkgconfig(libxml-2.0)
17 BuildRequires:  pkgconfig(capi-appfw-app-manager)
18 BuildRequires:  libtzplatform-config-devel
19 BuildRequires:  libgcrypt-devel
20
21 %description
22 Description: Location DB controller library
23
24
25 %package devel
26 Summary:    Location DB controller (Development files)
27 Group:      System/Libraries
28 Requires:   %{name} = %{version}-%{release}
29
30 %description devel
31 Description : Location DB controller Development Package
32
33
34 %prep
35 %setup -q -n %{name}-%{version}
36 cp %{SOURCE1001} .
37
38
39 %build
40 %cmake . -DTZ_SYS_DB=%{TZ_SYS_DB}
41
42 # Call make instruction with smp support
43 make %{?jobs:-j%jobs}
44
45 %post
46 /sbin/ldconfig
47
48
49 %postun -p /sbin/ldconfig
50
51 %install
52 rm -rf %{buildroot}
53 %make_install
54
55
56 %clean
57 rm -rf %{buildroot}
58
59 %files
60 %manifest %{name}.manifest
61 %defattr(-,root,root,-)
62 %{_libdir}/liblocation-appman.so*
63 %attr(664,root,%{TZ_SYS_USER_GROUP}) %{TZ_SYS_DB}/.location-appman.db*
64
65 %files devel
66 %manifest %{name}.manifest
67 %{_includedir}/location-appman/*.h
68 %{_libdir}/pkgconfig/*.pc