033e28b49c7f64b26e865b916999c8e0cb72c07c
[platform/core/location/liblocation-appman.git] / packaging / liblocation-appman.spec
1 %define _optdir /opt
2 Name:       liblocation-appman
3 Summary:    Location DB controler
4 Version:    0.1.6
5 Release:    1
6 Group:      System/Libraries
7 License:    TBD
8 Source0:    %{name}-%{version}.tar.gz
9
10 Requires(post): sqlite
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(sqlite3)
15 BuildRequires:  pkgconfig(libxml-2.0)
16 BuildRequires:  pkgconfig(capi-appfw-app-manager)
17 BuildRequires:  libgcrypt-devel
18
19 %description
20 Description: Location DB controller library
21
22
23 %package devel
24 Summary:    Location DB controller (Development files)
25 Group:      System/Libraries
26 Requires:   %{name} = %{version}-%{release}
27
28 %description devel
29 Description : Location DB controller Development Package
30
31
32 %prep
33 %setup -q -n %{name}-%{version}
34
35
36 %build
37 cmake . -DCMAKE_INSTALL_PREFIX=/usr
38
39 # Call make instruction with smp support
40 make %{?jobs:-j%jobs}
41
42 %post
43 /sbin/ldconfig
44
45 chown 0:5000 /opt/dbspace/.location-appman.db*
46 chmod 664 /opt/dbspace/.location-appman.db*
47 if [ -f /usr/lib/rpm-plugins/msm.so ]
48 then
49 chsmack -a 'location_fw::db' /opt/dbspace/.location-appman.db*
50 fi
51
52 %postun -p /sbin/ldconfig
53
54 %install
55 rm -rf %{buildroot}
56 %make_install
57
58
59 %clean
60 rm -rf %{buildroot}
61
62 %files
63 %manifest liblocation-appman.manifest
64 %defattr(-,root,root,-)
65 %{_libdir}/liblocation-appman.so*
66 %{_optdir}/dbspace/.location-appman.db*
67
68 %files devel
69 %{_includedir}/location-appman/*.h
70 %{_libdir}/pkgconfig/*.pc