Add watch-application initial Code
[platform/core/csapi/watch-application.git] / packaging / csapi-watch-application.spec
1 Name:       csapi-watch-application
2 Summary:    Tizen Watch Application API for C#
3 Version:    1.0.0
4 Release:    1
5 Group:      Development/Libraries
6 License:    Apache-2.0
7 URL:        https://www.tizen.org
8 Source0:    %{name}-%{version}.tar.gz
9 Source1:    %{name}.manifest
10
11 AutoReqProv: no
12 ExcludeArch: aarch64
13
14 BuildRequires: dotnet-build-tools
15
16 # C# API Requires
17 BuildRequires: csapi-tizen-nuget
18 BuildRequires: csapi-application-common-nuget
19 BuildRequires: elm-sharp-nuget
20
21 %define Assemblies Tizen.Applications.WatchApplication
22
23 %description
24 %{summary}
25
26 %dotnet_import_sub_packages
27
28 %prep
29 %setup -q
30 cp %{SOURCE1} .
31
32 %build
33 for ASM in %{Assemblies}; do
34 %dotnet_build $ASM
35 %dotnet_pack $ASM/$ASM.nuspec %{version}
36 done
37
38 %install
39 for ASM in %{Assemblies}; do
40 %dotnet_install $ASM
41 done
42
43 %files
44 %manifest %{name}.manifest
45 %license LICENSE
46 %attr(644,root,root) %{dotnet_assembly_files}