Change Exceptions and Properties and Add API level
[platform/core/csapi/uix-stt.git] / packaging / csapi-uix-stt.spec
1 Name:       csapi-uix-stt
2 Summary:    Tizen STT Uix API for C#
3 Version:    1.0.3
4 Release:    1
5 Group:      Development/Libraries
6 License:    Apache-2.0
7 URL:        https://www.tizen.org
8 Source0:    %{name}-%{version}.tar.gz
9 Source1:    %{name}.manifest
10
11 BuildRequires: dotnet-build-tools
12
13 # C# API Requires
14 BuildRequires: csapi-tizen-nuget
15
16 AutoReqProv: no
17 ExcludeArch: aarch64
18
19 %description
20 Tizen Uix API for C#
21
22 %dotnet_import_sub_packages
23
24 %prep
25 %setup -q
26 cp %{SOURCE1} .
27
28 %define Assemblies Tizen.Uix.Stt
29
30 %build
31 for ASM in %{Assemblies}; do
32 %dotnet_build $ASM
33 %dotnet_pack $ASM
34 done
35
36 %install
37 for ASM in %{Assemblies}; do
38 %dotnet_install $ASM
39 done
40
41 %files
42 %manifest %{name}.manifest
43 %license LICENSE
44 %attr(644,root,root) %{dotnet_assembly_files}