[TCSACR-74] Add property and modify method for user consent
[platform/core/csapi/maps.git] / packaging / csapi-maps.spec
1 Name:       csapi-maps
2 Summary:    Tizen Map Service API for C#
3 Version:    1.0.16
4 Release:    1
5 Group:      Development/Libraries
6 License:    Apache-2.0 and SAMSUNG
7 URL:        https://www.tizen.org
8 Source0:    %{name}-%{version}.tar.gz
9 Source1:    %{name}.manifest
10
11 AutoReqProv: no
12 ExcludeArch: aarch64
13
14 BuildRequires: dotnet-build-tools
15
16 # NuGet for Dependencies
17 BuildRequires: csapi-tizen-nuget
18 BuildRequires: elm-sharp-nuget
19
20 %define Assemblies Tizen.Maps
21
22 %description
23 %{summary}
24
25 %dotnet_import_sub_packages
26
27 %prep
28 %setup -q
29 cp %{SOURCE1} .
30
31 %build
32 for ASM in %{Assemblies}; do
33 %dotnet_build $ASM
34 %dotnet_pack $ASM
35 done
36
37 %install
38 mkdir -p %{buildroot}%{dotnet_assembly_path}/res
39 for ASM in %{Assemblies}; do
40 %dotnet_install $ASM
41 install -p -m 644 $ASM/res/*.png %{buildroot}%{dotnet_assembly_path}/res
42 done
43
44 %files
45 %manifest %{name}.manifest
46 %license LICENSE
47 %attr(644,root,root) %{dotnet_assembly_files}
48 %attr(644,root,root) %{dotnet_assembly_path}/res/*.png