Release version 1.1.0
[platform/core/csapi/badge.git] / packaging / csapi-badge.spec
1 Name:       csapi-badge
2 Summary:    Tizen Badge API for C#
3 Version:    1.1.0
4 Release:    1
5 Group:      Development/Libraries
6 License:    Apache-2.0
7 URL:        https://www.tizen.org
8 Source0:    %{name}-%{version}.tar.gz
9 Source1:    %{name}.manifest
10
11 AutoReqProv: no
12 ExcludeArch: aarch64
13
14 BuildRequires: dotnet-build-tools
15
16 # C# API Requires
17 BuildRequires: csapi-tizen-nuget
18
19 %define Assemblies Tizen.Applications.Badge
20
21 %description
22 %{summary}
23
24 %dotnet_import_sub_packages
25
26 %prep
27 %setup -q
28 cp %{SOURCE1} .
29
30 %build
31 for ASM in %{Assemblies}; do
32 %dotnet_build $ASM
33 %dotnet_pack $ASM
34 done
35
36 %install
37 for ASM in %{Assemblies}; do
38 %dotnet_install $ASM
39 done
40
41 %files
42 %manifest %{name}.manifest
43 %license LICENSE
44 %attr(644,root,root) %{dotnet_assembly_files}