Update release version
[platform/core/connectivity/smartcard-service.git] / packaging / smartcard-service.spec
1 Name:       smartcard-service
2 Summary:    Smartcard Service FW
3 Version:    0.1.19
4 Release:    1
5 Group:      libs
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 #IFNDEF USE_AUTOSTART
9 #Source1:    smartcard-service-server.init
10 #ENDIF
11 BuildRequires: pkgconfig(glib-2.0)
12 BuildRequires: pkgconfig(security-server)
13 BuildRequires: pkgconfig(dlog)
14 BuildRequires: pkgconfig(vconf)
15 BuildRequires: pkgconfig(aul)
16 BuildRequires: pkgconfig(libssl)
17 BuildRequires: pkgconfig(dbus-glib-1)
18 BuildRequires: pkgconfig(pkgmgr)
19 BuildRequires: pkgconfig(pkgmgr-info)
20 BuildRequires: cmake
21 BuildRequires: gettext-tools
22
23 Requires(post):   /sbin/ldconfig
24 Requires(post):   /usr/bin/vconftool
25 requires(postun): /sbin/ldconfig
26
27 %description
28 Smartcard Service FW.
29
30 %prep
31 %setup -q
32
33 %package    devel
34 Summary:    smartcard service
35 Group:      Development/Libraries
36 Requires:   %{name} = %{version}-%{release}
37
38 %description devel
39 smartcard service.
40
41 %package -n smartcard-service-common
42 Summary:    common smartcard service
43 Group:      Development/Libraries
44 Requires:   %{name} = %{version}-%{release}
45
46 %description -n smartcard-service-common
47 common smartcard service.
48
49 %package -n smartcard-service-common-devel
50 Summary:    common smartcard service
51 Group:      Development/Libraries
52 Requires:   %{name} = %{version}-%{release}
53 Requires:   smartcard-service-common = %{version}-%{release}
54
55 %description -n smartcard-service-common-devel
56 common smartcard service.
57
58 %package -n smartcard-service-server
59 Summary:    server smartcard service
60 Group:      Development/Libraries
61 Requires:   %{name} = %{version}-%{release}
62
63 %description -n smartcard-service-server
64 smartcard service.
65
66 %build
67 mkdir obj-arm-limux-qnueabi
68 cd obj-arm-limux-qnueabi
69 #IFNDEF USE_AUTOSTART
70 #cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix}
71 #ELSE
72 %cmake .. -DUSE_AUTOSTART=1 # daemon will be started when client makes instance by DBUS
73 #ENDIF
74 #make %{?jobs:-j%jobs}
75
76 %install
77 cd obj-arm-limux-qnueabi
78 %make_install
79 #IFNDEF USE_AUTOSTART
80 #%__mkdir -p  %{buildroot}/etc/init.d/
81 #%__mkdir -p  %{buildroot}/etc/rc.d/rc3.d/
82 #%__mkdir -p  %{buildroot}/etc/rc.d/rc5.d/
83 #%__cp -af %SOURCE1 %{buildroot}/etc/init.d/smartcard-service-server
84 #chmod 755 %{buildroot}/etc/init.d/smartcard-service-server
85 #ENDIF
86 mkdir -p %{buildroot}/usr/share/license
87 cp -af %{_builddir}/%{name}-%{version}/packaging/smartcard-service %{buildroot}/usr/share/license/
88 cp -af %{_builddir}/%{name}-%{version}/packaging/smartcard-service-common %{buildroot}/usr/share/license/
89 cp -af %{_builddir}/%{name}-%{version}/packaging/smartcard-service-server %{buildroot}/usr/share/license/
90
91 %post
92 /sbin/ldconfig
93 #IFNDEF USE_AUTOSTART
94 #ln -sf /etc/init.d/smartcard-service-server /etc/rc.d/rc3.d/S79smartcard-service-server
95 #ln -sf /etc/init.d/smartcard-service-server /etc/rc.d/rc5.d/S79smartcard-service-server
96 #ENDIF
97
98 %postun
99 /sbin/ldconfig
100 #IFNDEF USE_AUTOSTART
101 #rm -f /etc/rc.d/rc3.d/S79smartcard-service-server
102 #rm -f /etc/rc.d/rc5.d/S79smartcard-service-server
103 #ENDIF
104
105 %files
106 %manifest smartcard-service.manifest
107 %defattr(-,root,root,-)
108 %{_libdir}/libsmartcard-service.so.*
109 /usr/share/license/smartcard-service
110
111 %files  devel
112 %manifest smartcard-service-devel.manifest
113 %defattr(-,root,root,-)
114 %{_includedir}/smartcard-service/*
115 %{_libdir}/libsmartcard-service.so
116 %{_libdir}/pkgconfig/smartcard-service.pc
117
118 %files -n smartcard-service-common
119 %manifest smartcard-service-common.manifest
120 %defattr(-,root,root,-)
121 %{_libdir}/libsmartcard-service-common.so.*
122 /usr/share/license/smartcard-service-common
123
124 %files -n smartcard-service-common-devel
125 %manifest smartcard-service-common-devel.manifest
126 %defattr(-,root,root,-)
127 %{_includedir}/smartcard-service-common/*
128 %{_libdir}/libsmartcard-service-common.so
129 %{_libdir}/pkgconfig/smartcard-service-common.pc
130
131 %files -n smartcard-service-server
132 %manifest smartcard-service-server.manifest
133 %defattr(-,root,root,-)
134 %{_bindir}/smartcard-daemon
135 #/usr/bin/smartcard-test-client
136 #IFNDEF USE_AUTOSTART
137 #/etc/init.d/smartcard-service-server
138 #ELSE
139 /usr/share/dbus-1/services/org.tizen.smartcard_service.service
140 #ENDIF
141 /usr/share/license/smartcard-service-server