Remove license file in file section
[platform/core/connectivity/smartcard-service.git] / packaging / smartcard-service.spec
1 Name:       smartcard-service
2 Summary:    Smartcard Service FW
3 Version:    0.1.19
4 Release:    1
5 Group:      libs
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 #Source1:    smartcard-service-server.init
9
10 BuildRequires: pkgconfig(glib-2.0)
11 BuildRequires: pkgconfig(security-server)
12 BuildRequires: pkgconfig(dlog)
13 BuildRequires: pkgconfig(vconf)
14 BuildRequires: pkgconfig(aul)
15 BuildRequires: pkgconfig(libssl)
16 BuildRequires: pkgconfig(dbus-glib-1)
17 BuildRequires: pkgconfig(pkgmgr)
18 BuildRequires: pkgconfig(pkgmgr-info)
19 BuildRequires: cmake
20 BuildRequires: gettext-tools
21
22 Requires(post):   /sbin/ldconfig
23 Requires(post):   /usr/bin/vconftool
24 requires(postun): /sbin/ldconfig
25
26 %description
27 Smartcard Service FW.
28
29 %prep
30 %setup -q
31
32 %package    devel
33 Summary:    smartcard service
34 Group:      Development/Libraries
35 Requires:   %{name} = %{version}-%{release}
36
37 %description devel
38 smartcard service.
39
40 %package -n smartcard-service-common
41 Summary:    common smartcard service
42 Group:      Development/Libraries
43 Requires:   %{name} = %{version}-%{release}
44
45 %description -n smartcard-service-common
46 common smartcard service.
47
48 %package -n smartcard-service-common-devel
49 Summary:    common smartcard service
50 Group:      Development/Libraries
51 Requires:   %{name} = %{version}-%{release}
52 Requires:   smartcard-service-common = %{version}-%{release}
53
54 %description -n smartcard-service-common-devel
55 common smartcard service.
56
57 %package -n smartcard-service-server
58 Summary:    server smartcard service
59 Group:      Development/Libraries
60 Requires:   %{name} = %{version}-%{release}
61
62 %description -n smartcard-service-server
63 smartcard service.
64
65
66 %build
67 mkdir obj-arm-limux-qnueabi
68 cd obj-arm-limux-qnueabi
69 #IFNDEF USE_AUTOSTART
70 #cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix}
71 #ELSE
72 %cmake .. -DUSE_AUTOSTART=1 # daemon will be started when client makes instance by DBUS
73 #ENDIF
74 #make %{?jobs:-j%jobs}
75
76 %install
77 cd obj-arm-limux-qnueabi
78 %make_install
79 %__mkdir -p  %{buildroot}/etc/init.d/
80 %__mkdir -p  %{buildroot}/etc/rc.d/rc3.d/
81 %__mkdir -p  %{buildroot}/etc/rc.d/rc5.d/
82 #IFNDEF USE_AUTOSTART
83 #%__cp -af %SOURCE1 %{buildroot}/etc/init.d/smartcard-service-server
84 #chmod 755 %{buildroot}/etc/init.d/smartcard-service-server
85 #ENDIF
86
87 %post
88 /sbin/ldconfig
89 ln -sf /etc/init.d/smartcard-service-server /etc/rc.d/rc3.d/S79smartcard-service-server
90 ln -sf /etc/init.d/smartcard-service-server /etc/rc.d/rc5.d/S79smartcard-service-server
91
92 %postun
93 /sbin/ldconfig
94 rm -f /etc/rc.d/rc3.d/S79smartcard-service-server
95 rm -f /etc/rc.d/rc5.d/S79smartcard-service-server
96
97 %files
98 %manifest smartcard-service.manifest
99 %defattr(-,root,root,-)
100 %{_libdir}/libsmartcard-service.so.*
101
102 %files  devel
103 %manifest smartcard-service-devel.manifest
104 %defattr(-,root,root,-)
105 %{_includedir}/smartcard-service/*
106 %{_libdir}/libsmartcard-service.so
107 %{_libdir}/pkgconfig/smartcard-service.pc
108
109 %files -n smartcard-service-common
110 %manifest smartcard-service-common.manifest
111 %defattr(-,root,root,-)
112 %{_libdir}/libsmartcard-service-common.so.*
113
114 %files -n smartcard-service-common-devel
115 %manifest smartcard-service-common-devel.manifest
116 %defattr(-,root,root,-)
117 %{_includedir}/smartcard-service-common/*
118 %{_libdir}/libsmartcard-service-common.so
119 %{_libdir}/pkgconfig/smartcard-service-common.pc
120
121 %files -n smartcard-service-server
122 %manifest smartcard-service-server.manifest
123 %defattr(-,root,root,-)
124 %{_bindir}/smartcard-daemon
125 #/usr/bin/smartcard-test-client
126 #IFNDEF USE_AUTOSTART
127 #/etc/init.d/smartcard-service-server
128 #ELSE
129 /usr/share/dbus-1/services/org.tizen.smartcard_service.service
130 #ENDIF
131