- Add smack manifest
[platform/core/connectivity/smartcard-service.git] / packaging / smartcard-service.spec
1 Name:       smartcard-service
2 Summary:    Smartcard Service FW
3 Version:    0.1.0
4 Release:    9
5 Group:      libs
6 License:    Samsung Proprietary License
7 Source0:    %{name}-%{version}.tar.gz
8 Source1:    smartcard-service-server.init
9 BuildRequires: pkgconfig(glib-2.0)
10 BuildRequires: pkgconfig(vconf)
11 BuildRequires: pkgconfig(security-server)
12 BuildRequires: pkgconfig(dlog)
13 BuildRequires: pkgconfig(libssl)
14 BuildRequires: pkgconfig(aul)
15 BuildRequires: pkgconfig(dpl-wrt-dao-ro)
16 BuildRequires: cmake
17 BuildRequires: gettext-tools
18 Requires(post):   /sbin/ldconfig
19 Requires(post):   /usr/bin/vconftool
20 requires(postun): /sbin/ldconfig
21
22 %description
23 Smartcard Service FW.
24
25 %prep
26 %setup -q
27
28 %package    devel
29 Summary:    smartcard service
30 Group:      Development/Libraries
31 Requires:   %{name} = %{version}-%{release}
32
33 %description devel
34 smartcard service.
35
36 %package -n smartcard-service-common
37 Summary:    common smartcard service
38 Group:      Development/Libraries
39 Requires:   %{name} = %{version}-%{release}
40
41 %description -n smartcard-service-common
42 common smartcard service.
43
44 %package -n smartcard-service-common-devel
45 Summary:    common smartcard service
46 Group:      Development/Libraries
47 Requires:   %{name} = %{version}-%{release}
48
49 %description -n smartcard-service-common-devel
50 common smartcard service.
51
52 %package -n smartcard-service-server
53 Summary:    server smartcard service
54 Group:      Development/Libraries
55 Requires:   %{name} = %{version}-%{release}
56
57 %description -n smartcard-service-server
58 smartcard service.
59
60 %build
61 mkdir obj-arm-limux-qnueabi
62 cd obj-arm-limux-qnueabi
63 cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix}
64 #make %{?jobs:-j%jobs}
65
66 %install
67 cd obj-arm-limux-qnueabi
68 %make_install
69 %__mkdir -p  %{buildroot}/etc/init.d/
70 %__mkdir -p  %{buildroot}/etc/rc.d/rc3.d/
71 %__mkdir -p  %{buildroot}/etc/rc.d/rc5.d/
72 %__cp -af %SOURCE1 %{buildroot}/etc/init.d/smartcard-service-server
73 chmod 755 %{buildroot}/etc/init.d/smartcard-service-server
74
75 %post
76 /sbin/ldconfig
77
78 ln -sf /etc/init.d/smartcard-service-server /etc/rc.d/rc3.d/S79smartcard-service-server
79 ln -sf /etc/init.d/smartcard-service-server /etc/rc.d/rc5.d/S79smartcard-service-server
80
81 %postun
82 /sbin/ldconfig
83
84 rm -f /etc/rc.d/rc3.d/S79smartcard-service-server
85 rm -f /etc/rc.d/rc5.d/S79smartcard-service-server
86
87 #%post
88 # -n nfc-common-lib -p /sbin/ldconfig
89
90 #%postun
91 # -n nfc-common-lib -p /sbin/ldconfig
92
93 %files
94 %defattr(-,root,root,-)
95 /usr/lib/libsmartcard-service.so.*
96
97 %files  devel
98 %defattr(-,root,root,-)
99 /usr/include/smartcard-service/*
100 /usr/lib/libsmartcard-service.so
101 /usr/lib/pkgconfig/smartcard-service.pc
102
103 %files -n smartcard-service-common
104 %defattr(-,root,root,-)
105 /usr/lib/libsmartcard-service-common.so.*
106
107 %files -n smartcard-service-common-devel
108 %defattr(-,root,root,-)
109 /usr/include/smartcard-service-common/*
110 /usr/lib/libsmartcard-service-common.so
111 /usr/lib/pkgconfig/smartcard-service-common.pc
112
113 %files -n smartcard-service-server
114 %manifest smartcard-service-server.manifest
115 %defattr(-,root,root,-)
116 /usr/bin/smartcard-daemon
117 #/usr/bin/smartcard-test-client
118 /etc/init.d/smartcard-service-server