Change License name in spec file
[platform/core/connectivity/smartcard-service.git] / packaging / smartcard-service.spec
1 Name:       smartcard-service
2 Summary:    Smartcard Service FW
3 Version:    0.1.9
4 Release:    1
5 Group:      libs
6 License:    Apache License, Version 2.0
7 Source0:    %{name}-%{version}.tar.gz
8 #IFNDEF USE_AUTOSTART
9 #Source1:    smartcard-service-server.init
10 #ENDIF
11 BuildRequires: pkgconfig(glib-2.0)
12 BuildRequires: pkgconfig(security-server)
13 BuildRequires: pkgconfig(dlog)
14 BuildRequires: pkgconfig(libssl)
15 BuildRequires: pkgconfig(dbus-glib-1)
16 BuildRequires: pkgconfig(pkgmgr)
17 BuildRequires: pkgconfig(vconf)
18 BuildRequires: pkgconfig(aul)
19 BuildRequires: cmake
20 BuildRequires: gettext-tools
21
22 Requires(post):   /sbin/ldconfig
23 Requires(post):   /usr/bin/vconftool
24 requires(postun): /sbin/ldconfig
25
26 %description
27 Smartcard Service FW.
28
29 %prep
30 %setup -q
31
32 %package    devel
33 Summary:    smartcard service
34 Group:      Development/Libraries
35 Requires:   %{name} = %{version}-%{release}
36
37 %description devel
38 smartcard service.
39
40 %package -n smartcard-service-common
41 Summary:    common smartcard service
42 Group:      Development/Libraries
43 Requires:   %{name} = %{version}-%{release}
44
45 %description -n smartcard-service-common
46 common smartcard service.
47
48 %package -n smartcard-service-common-devel
49 Summary:    common smartcard service
50 Group:      Development/Libraries
51 Requires:   %{name} = %{version}-%{release}
52
53 %description -n smartcard-service-common-devel
54 common smartcard service.
55
56 %package -n smartcard-service-server
57 Summary:    server smartcard service
58 Group:      Development/Libraries
59 Requires:   %{name} = %{version}-%{release}
60
61 %description -n smartcard-service-server
62 smartcard service.
63
64 %build
65 mkdir obj-arm-limux-qnueabi
66 cd obj-arm-limux-qnueabi
67 #IFNDEF USE_AUTOSTART
68 #cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix}
69 #ELSE
70 cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix} -DUSE_AUTOSTART=1 # daemon will be started when client makes instance by DBUS
71 #ENDIF
72 #make %{?jobs:-j%jobs}
73
74 %install
75 cd obj-arm-limux-qnueabi
76 %make_install
77 #IFNDEF USE_AUTOSTART
78 #%__mkdir -p  %{buildroot}/etc/init.d/
79 #%__mkdir -p  %{buildroot}/etc/rc.d/rc3.d/
80 #%__mkdir -p  %{buildroot}/etc/rc.d/rc5.d/
81 #%__cp -af %SOURCE1 %{buildroot}/etc/init.d/smartcard-service-server
82 #chmod 755 %{buildroot}/etc/init.d/smartcard-service-server
83 #ENDIF
84 mkdir -p %{buildroot}/usr/share/license
85 cp -af %{_builddir}/%{name}-%{version}/packaging/smartcard-service %{buildroot}/usr/share/license/
86 cp -af %{_builddir}/%{name}-%{version}/packaging/smartcard-service-common %{buildroot}/usr/share/license/
87 cp -af %{_builddir}/%{name}-%{version}/packaging/smartcard-service-server %{buildroot}/usr/share/license/
88
89 %post
90 /sbin/ldconfig
91 #IFNDEF USE_AUTOSTART
92 #ln -sf /etc/init.d/smartcard-service-server /etc/rc.d/rc3.d/S79smartcard-service-server
93 #ln -sf /etc/init.d/smartcard-service-server /etc/rc.d/rc5.d/S79smartcard-service-server
94 #ENDIF
95
96 %postun
97 /sbin/ldconfig
98 #IFNDEF USE_AUTOSTART
99 #rm -f /etc/rc.d/rc3.d/S79smartcard-service-server
100 #rm -f /etc/rc.d/rc5.d/S79smartcard-service-server
101 #ENDIF
102
103 %files
104 %manifest smartcard-service.manifest
105 %defattr(-,root,root,-)
106 /usr/lib/libsmartcard-service.so.*
107 /usr/share/license/smartcard-service
108
109 %files  devel
110 %manifest smartcard-service-devel.manifest
111 %defattr(-,root,root,-)
112 /usr/include/smartcard-service/*
113 /usr/lib/libsmartcard-service.so
114 /usr/lib/pkgconfig/smartcard-service.pc
115
116 %files -n smartcard-service-common
117 %manifest smartcard-service-common.manifest
118 %defattr(-,root,root,-)
119 /usr/lib/libsmartcard-service-common.so.*
120 /usr/share/license/smartcard-service-common
121
122 %files -n smartcard-service-common-devel
123 %manifest smartcard-service-common-devel.manifest
124 %defattr(-,root,root,-)
125 /usr/include/smartcard-service-common/*
126 /usr/lib/libsmartcard-service-common.so
127 /usr/lib/pkgconfig/smartcard-service-common.pc
128
129 %files -n smartcard-service-server
130 %manifest smartcard-service-server.manifest
131 %defattr(-,root,root,-)
132 /usr/bin/smartcard-daemon
133 #/usr/bin/smartcard-test-client
134 #IFNDEF USE_AUTOSTART
135 #/etc/init.d/smartcard-service-server
136 #ELSE
137 /usr/share/dbus-1/services/smartcard-service.service
138 #ENDIF
139 /usr/share/license/smartcard-service-server