Modify for NFC operation
[platform/core/connectivity/smartcard-plugin-nfc.git] / packaging / smartcard-plugin-nfc.spec
1 Name:             smartcard-plugin-nfc
2 Summary:          Smartcard plugin nfc
3 Version:          0.0.11
4 Release:          0
5 Group:            Network & Connectivity/NFC
6 License:          Apache-2.0
7 Source0:          %{name}-%{version}.tar.gz
8 Source1001:     smartcard-plugin-nfc.manifest
9 #ExclusiveArch:    %%arm
10 BuildRequires:    cmake
11 BuildRequires:    pkgconfig(glib-2.0)
12 BuildRequires:    pkgconfig(dlog)
13 BuildRequires:    pkgconfig(smartcard-service-common)
14 BuildRequires:    pkgconfig(capi-network-nfc)
15 BuildRequires:    pkgconfig(vconf)
16 Requires(post):   /sbin/ldconfig
17 Requires(postun): /sbin/ldconfig
18
19
20 %description
21 Smartcard Service plugin nfc
22
23 %prep
24 %setup -q
25 cp %{SOURCE1001} .
26
27 %build
28 %cmake .
29
30 %install
31 %make_install
32
33 %post -p /sbin/ldconfig
34
35 %postun -p /sbin/ldconfig
36
37 %files
38 %manifest %{name}.manifest
39 %defattr(-,root,root,-)
40 %{_libdir}/se/lib*.so
41 %license LICENSE.APLv2