Tizen 2.1 base
[platform/core/connectivity/smartcard-plugin-nfc.git] / packaging / smartcard-plugin-nfc.spec
1 Name:             smartcard-plugin-nfc
2 Summary:          Smartcard plugin nfc
3 Version:          0.0.3
4 Release:          1
5 Group:            libs
6 License:          Apache License, Version 2.0
7 Source0:          %{name}-%{version}.tar.gz
8 BuildRequires:    pkgconfig(glib-2.0)
9 BuildRequires:    pkgconfig(dlog)
10 BuildRequires:    pkgconfig(nfc)
11 BuildRequires:    pkgconfig(smartcard-service-common)
12 BuildRequires:    cmake
13 BuildRequires:    gettext-tools
14 Requires(post):   /sbin/ldconfig
15 Requires(post):   /usr/bin/vconftool
16 requires(postun): /sbin/ldconfig
17 %description
18 Smartcard Service plugin nfc
19
20 %prep
21 %setup -q
22
23
24 %package    devel
25 Summary:    smartcard service
26 Group:      Development/Libraries
27 Requires:   %{name} = %{version}-%{release}
28
29 %description devel
30 smartcard service.
31
32
33 %build
34 mkdir obj-arm-limux-qnueabi
35 cd obj-arm-limux-qnueabi
36 cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix}
37 #make %{?jobs:-j%jobs}
38
39
40 %install
41 cd obj-arm-limux-qnueabi
42 %make_install
43 mkdir -p %{buildroot}/usr/share/license
44 cp -af %{_builddir}/%{name}-%{version}/packaging/smartcard-plugin-nfc %{buildroot}/usr/share/license/
45
46 %post
47 /sbin/ldconfig
48
49
50 %postun
51 /sbin/ldconfig
52
53 #%post
54 # -n nfc-common-lib -p /sbin/ldconfig
55
56 #%postun
57 # -n nfc-common-lib -p /sbin/ldconfig
58
59 %files
60 %manifest smartcard-plugin-nfc.manifest
61 %defattr(-,root,root,-)
62 /usr/lib/se/lib*.so
63 /usr/share/license/smartcard-plugin-nfc