Modify the bt-stack-up.sh script
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
1 Name:       bluetooth-tools
2 Summary:    Bluetooth-tools
3 Version:    0.2.37
4 Release:    0
5 Group:      Network & Connectivity/Bluetooth
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 #Source1001: bluetooth-address.service
9 BuildRequires:  cmake
10 Suggests:       bluetooth-share
11 Requires:       tizen-platform-config-tools
12 Requires:      bluetooth-scripts
13 Requires:   %{name}-compat = %{version}-%{release}
14 Recommends:   %{name}-profile_common = %{version}-%{release}
15
16 %description
17 Tools fo bluetooth run/stop and set address
18
19 %package profile_common
20 Summary:    Bluetooth-tools extension for common/tv
21 Provides:   %{name}-compat = %{version}-%{release}
22 Provides:   %{name}-profile_tv = %{version}-%{release}
23 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
24 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
25 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
26 %description profile_common
27 Bluetooth-tools extension for Tizen common / tv profile.
28
29 %package profile_mobile
30 Summary:    Bluetooth-tools extension for mobile/tv
31 Provides:   %{name}-compat = %{version}-%{release}
32 Conflicts:  %{name}-profile_common = %{version}-%{release}
33 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
34 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
35 %description profile_mobile
36 Bluetooth-tools extension for Tizen mobile profile.
37
38 %package profile_wearable
39 Summary:    Bluetooth-tools extension for wearable/tv
40 Provides:   %{name}-compat = %{version}-%{release}
41 Conflicts:  %{name}-profile_common = %{version}-%{release}
42 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
43 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
44 %description profile_wearable
45 Bluetooth-tools extension for Tizen wearable profile.
46
47 %package profile_ivi
48 Summary:    Bluetooth-tools extension for ivi/tv
49 Provides:   %{name}-compat = %{version}-%{release}
50 Conflicts:  %{name}-profile_common = %{version}-%{release}
51 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
52 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
53 %description profile_ivi
54 Bluetooth-tools extension for Tizen ivi profile.
55
56 %package no-firmware
57 Summary:    On/Off Bluetooth adapter
58 Group:      Network & Connectivity/Bluetooth
59 Requires:   %{name} = %{version}-%{release}
60 Requires:   rfkill
61 Provides:   bluetooth-scripts
62 Conflicts:  bluetooth-firmware-bcm
63
64 %description no-firmware
65 On/Off bluetooth device
66
67 %prep
68 %setup -q
69
70 %build
71 export CFLAGS+=" -fpie -fvisibility=hidden"
72 export CXXFLAGS+=" -fpie -fvisibility=hidden"
73 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
74
75 %cmake
76 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
77 %if 0%{?tizen_build_binary_release_type_eng}
78         -DBT_HCI_LOG_SIZE=10
79 %else
80         -DBT_HCI_LOG_SIZE=5
81 %endif
82
83 %__make %{?_smp_mflags}
84
85 %install
86 rm -rf %{buildroot}
87 %make_install
88
89 mkdir -p %{buildroot}%{_prefix}/etc/bluetooth/
90 mkdir -p %{buildroot}/run/bluetooth
91 install -m 0755 scripts/bt-dev-start.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-start.sh
92 install -m 0755 scripts/bt-dev-end.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-end.sh
93
94 install -D -m 0644 packaging/bluetooth-hci-logger.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger.service
95 install -D -m 0644 packaging/bluetooth-hci-logger.path %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger.path
96
97 install -D -m 0644 packaging/bluetooth-hci-logger-stop.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger-stop.service
98 install -D -m 0644 packaging/bluetooth-hci-logger-stop.path %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger-stop.path
99
100 install -D -m 0644 packaging/bluez-start.service %{buildroot}%{_libdir}/systemd/system/bluez-start.service
101 install -D -m 0644 packaging/bluez-start.path %{buildroot}%{_libdir}/systemd/system/bluez-start.path
102
103 install -D -m 0644 packaging/bluetooth-share-start.service %{buildroot}%{_libdir}/systemd/system/bluetooth-share-start.service
104 install -D -m 0644 packaging/bluetooth-share-start.path %{buildroot}%{_libdir}/systemd/system/bluetooth-share-start.path
105
106 install -D -m 0644 packaging/bluetooth-force-hci-logger.service %{buildroot}%{_libdir}/systemd/system/bluetooth-force-hci-logger.service
107 install -D -m 0644 packaging/bluetooth-hci-dump@.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-dump@.service
108
109 %post
110 mkdir -p %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
111 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
112 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hci-logger.path
113
114 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger-stop.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
115 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger-stop.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hci-logger-stop.path
116
117 ln -sf %{_libdir}/systemd/system/bluez-start.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
118 ln -sf %{_libdir}/systemd/system/bluez-start.path %{_libdir}/systemd/system/multi-user.target.wants/bluez-start.path
119
120 ln -sf %{_libdir}/systemd/system/bluetooth-share-start.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
121 ln -sf %{_libdir}/systemd/system/bluetooth-share-start.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-share-start.path
122
123 ln -sf %{_libdir}/systemd/system/bluetooth-force-hci-logger.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
124
125
126 %files
127 %manifest %{name}.manifest
128 %license LICENSE.APLv2
129 %defattr(-,root,root,-)
130 #%exclude %{_sysconfdir}/rc.d/init.d/bluetooth-address
131 #%{_sysconfdir}/rc.d/rc3.d/S60bluetooth-address
132 #%{_sysconfdir}/rc.d/rc5.d/S60bluetooth-address
133 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-on.sh
134 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-dev-up.sh
135 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-mode-on.sh
136 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-off.sh
137 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-hci-logdump.sh
138 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-run-hci-logger.sh
139 #%{_unitdir}/multi-user.target.wants/bluetooth-address.service
140 #%{_unitdir}/bluetooth-address.service
141 %{_libdir}/systemd/system/bluetooth-hci-logger.service
142 %{_libdir}/systemd/system/bluetooth-hci-logger.path
143 %{_libdir}/systemd/system/bluetooth-hci-logger-stop.service
144 %{_libdir}/systemd/system/bluetooth-hci-logger-stop.path
145 %{_libdir}/systemd/system/bluez-start.service
146 %{_libdir}/systemd/system/bluez-start.path
147 %{_libdir}/systemd/system/bluetooth-share-start.service
148 %{_libdir}/systemd/system/bluetooth-share-start.path
149 %{_libdir}/systemd/system/bluetooth-force-hci-logger.service
150 %{_libdir}/systemd/system/bluetooth-hci-dump@.service
151
152 %post profile_common
153 pushd %{_prefix}/etc/bluetooth/
154 ln -sf common/bt-stack-up.sh bt-stack-up.sh
155 ln -sf common/bt-stack-down.sh bt-stack-down.sh
156 ln -sf common/bt-reset-env.sh bt-reset-env.sh
157 popd
158 %preun profile_common
159 pushd %{_prefix}/etc/bluetooth/
160 rm bt-stack-up.sh
161 rm bt-stack-down.sh
162 rm bt-reset-env.sh
163 popd
164 %files profile_common
165 %license LICENSE.APLv2
166 #%{_sysconfdir}/rc.d/init.d/bluetooth-address
167 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-up.sh
168 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-down.sh
169 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-reset-env.sh
170
171 %post profile_mobile
172 pushd %{_prefix}/etc/bluetooth/
173 ln -sf mobile/bt-stack-up.sh bt-stack-up.sh
174 ln -sf mobile/bt-stack-down.sh bt-stack-down.sh
175 ln -sf mobile/bt-stack-down-with-radio.sh bt-stack-down-with-radio.sh
176 ln -sf mobile/bt-reset-env.sh bt-reset-env.sh
177 popd
178 %preun profile_mobile
179 pushd %{_prefix}/etc/bluetooth/
180 rm bt-stack-up.sh
181 rm bt-stack-down.sh
182 rm bt-stack-down-with-radio.sh
183 rm bt-reset-env.sh
184 popd
185 %files profile_mobile
186 %license LICENSE.APLv2
187 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-up.sh
188 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down.sh
189 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-reset-env.sh
190 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down-with-radio.sh
191
192 %post profile_ivi
193 pushd %{_prefix}/etc/bluetooth/
194 ln -sf ivi/bt-stack-up.sh bt-stack-up.sh
195 ln -sf ivi/bt-stack-down.sh bt-stack-down.sh
196 ln -sf ivi/bt-reset-env.sh bt-reset-env.sh
197 popd
198 %preun profile_ivi
199 pushd %{_prefix}/etc/bluetooth/
200 rm bt-stack-up.sh
201 rm bt-stack-down.sh
202 rm bt-reset-env.sh
203 popd
204 %files profile_ivi
205 %license LICENSE.APLv2
206 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-up.sh
207 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-down.sh
208 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-reset-env.sh
209
210 %post profile_wearable
211 pushd %{_prefix}/etc/bluetooth/
212 ln -sf wearable/bt-stack-up.sh bt-stack-up.sh
213 ln -sf wearable/bt-stack-down.sh bt-stack-down.sh
214 ln -sf wearable/bt-reset-env.sh bt-reset-env.sh
215 popd
216 %preun profile_wearable
217 pushd %{_prefix}/etc/bluetooth/
218 rm bt-stack-up.sh
219 rm bt-stack-down.sh
220 rm bt-reset-env.sh
221 popd
222 %files profile_wearable
223 %license LICENSE.APLv2
224 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-up.sh
225 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-down.sh
226 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-reset-env.sh
227
228 %files no-firmware
229 %manifest %{name}.manifest
230 %license LICENSE.APLv2
231 %defattr(-, root, root)
232 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
233 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh