Don't detach HCI when BT is off for the common profile
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
1 Name:       bluetooth-tools
2 Summary:    Bluetooth-tools
3 Version:    0.2.37
4 Release:    0
5 Group:      Network & Connectivity/Bluetooth
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 #Source1001: bluetooth-address.service
9 BuildRequires:  cmake
10 Suggests:       bluetooth-share
11 Requires:       tizen-platform-config-tools
12 Requires:      bluetooth-scripts
13 Requires:   %{name}-compat = %{version}-%{release}
14 Recommends:   %{name}-profile_common = %{version}-%{release}
15
16 %description
17 Tools fo bluetooth run/stop and set address
18
19 %package profile_common
20 Summary:    Bluetooth-tools extension for common/tv
21 Provides:   %{name}-compat = %{version}-%{release}
22 Provides:   %{name}-profile_tv = %{version}-%{release}
23 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
24 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
25 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
26 %description profile_common
27 Bluetooth-tools extension for Tizen common / tv profile.
28
29 %package profile_mobile
30 Summary:    Bluetooth-tools extension for mobile/tv
31 Provides:   %{name}-compat = %{version}-%{release}
32 Conflicts:  %{name}-profile_common = %{version}-%{release}
33 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
34 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
35 %description profile_mobile
36 Bluetooth-tools extension for Tizen mobile profile.
37
38 %package profile_wearable
39 Summary:    Bluetooth-tools extension for wearable/tv
40 Provides:   %{name}-compat = %{version}-%{release}
41 Conflicts:  %{name}-profile_common = %{version}-%{release}
42 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
43 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
44 %description profile_wearable
45 Bluetooth-tools extension for Tizen wearable profile.
46
47 %package profile_ivi
48 Summary:    Bluetooth-tools extension for ivi/tv
49 Provides:   %{name}-compat = %{version}-%{release}
50 Conflicts:  %{name}-profile_common = %{version}-%{release}
51 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
52 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
53 %description profile_ivi
54 Bluetooth-tools extension for Tizen ivi profile.
55
56 %package no-firmware
57 Summary:    On/Off Bluetooth adapter
58 Group:      Network & Connectivity/Bluetooth
59 Requires:   %{name} = %{version}-%{release}
60 Requires:   rfkill
61 Provides:   bluetooth-scripts
62 Conflicts:  bluetooth-firmware-bcm
63
64 %description no-firmware
65 On/Off bluetooth device
66
67 %prep
68 %setup -q
69
70 %build
71 export CFLAGS+=" -fpie -fvisibility=hidden"
72 export CXXFLAGS+=" -fpie -fvisibility=hidden"
73 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
74
75 %cmake
76 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
77 %if 0%{?tizen_build_binary_release_type_eng}
78         -DBT_HCI_LOG_SIZE=10
79 %else
80         -DBT_HCI_LOG_SIZE=5
81 %endif
82
83 %__make %{?_smp_mflags}
84
85 %install
86 rm -rf %{buildroot}
87 %make_install
88
89 mkdir -p %{buildroot}%{_prefix}/etc/bluetooth/
90 mkdir -p %{buildroot}/run/bluetooth
91 install -m 0755 scripts/bt-dev-start.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-start.sh
92 install -m 0755 scripts/bt-dev-end.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-end.sh
93
94 #install -D -m 0644 packaging/bluetooth-hci-logger.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger.service
95 #install -D -m 0644 packaging/bluetooth-hci-logger.path %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger.path
96
97 #install -D -m 0644 packaging/bluetooth-hci-logger-stop.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger-stop.service
98 #install -D -m 0644 packaging/bluetooth-hci-logger-stop.path %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger-stop.path
99
100 install -D -m 0644 packaging/bluez-start.service %{buildroot}%{_libdir}/systemd/system/bluez-start.service
101 install -D -m 0644 packaging/bluez-start.path %{buildroot}%{_libdir}/systemd/system/bluez-start.path
102
103 install -D -m 0644 packaging/bluetooth-stack-up.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-up.service
104 install -D -m 0644 packaging/bluetooth-stack-up.path %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-up.path
105
106 install -D -m 0644 packaging/bluetooth-stack-down.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down.service
107 install -D -m 0644 packaging/bluetooth-stack-down.path %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down.path
108
109 install -D -m 0644 packaging/bluetooth-stack-down-with-radio.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down-with-radio.service
110 install -D -m 0644 packaging/bluetooth-stack-down-with-radio.path %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down-with-radio.path
111
112 #install -D -m 0644 packaging/bluetooth-force-hci-logger.service %{buildroot}%{_libdir}/systemd/system/bluetooth-force-hci-logger.service
113 #install -D -m 0644 packaging/bluetooth-hci-dump@.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-dump@.service
114
115 install -D -m 0644 packaging/bluetooth-hci-up.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-up.service
116 install -D -m 0644 packaging/bluetooth-hci-up.path %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-up.path
117 install -D -m 0644 packaging/bluetooth-hci-down.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-down.service
118 install -D -m 0644 packaging/bluetooth-hci-down.path %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-down.path
119
120 install -D -m 0644 packaging/bluetooth-stack-up-common.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-up-common.service
121 install -D -m 0644 packaging/bluetooth-stack-down-common.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down-common.service
122
123 %post
124 mkdir -p %{_libdir}/systemd/system/multi-user.target.wants/
125 #ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hci-logger.path
126 #ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger-stop.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hci-logger-stop.path
127 ln -sf %{_libdir}/systemd/system/bluez-start.path %{_libdir}/systemd/system/multi-user.target.wants/bluez-start.path
128 ln -sf %{_libdir}/systemd/system/bluetooth-stack-up.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-stack-up.path
129 ln -sf %{_libdir}/systemd/system/bluetooth-stack-down.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-stack-down.path
130 ln -sf %{_libdir}/systemd/system/bluetooth-hci-up.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hci-up.path
131 ln -sf %{_libdir}/systemd/system/bluetooth-hci-down.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hci-down.path
132
133 %files
134 %manifest %{name}.manifest
135 %license LICENSE.APLv2
136 %defattr(-,root,root,-)
137 #%exclude %{_sysconfdir}/rc.d/init.d/bluetooth-address
138 #%{_sysconfdir}/rc.d/rc3.d/S60bluetooth-address
139 #%{_sysconfdir}/rc.d/rc5.d/S60bluetooth-address
140 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-on.sh
141 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-dev-up.sh
142 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-mode-on.sh
143 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-off.sh
144 #%attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-hci-logdump.sh
145 #%attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-run-hci-logger.sh
146 #%{_unitdir}/multi-user.target.wants/bluetooth-address.service
147 #%{_unitdir}/bluetooth-address.service
148 #%{_libdir}/systemd/system/bluetooth-hci-logger.service
149 #%{_libdir}/systemd/system/bluetooth-hci-logger.path
150 #%{_libdir}/systemd/system/bluetooth-hci-logger-stop.service
151 #%{_libdir}/systemd/system/bluetooth-hci-logger-stop.path
152 %{_libdir}/systemd/system/bluez-start.service
153 %{_libdir}/systemd/system/bluez-start.path
154 #%{_libdir}/systemd/system/bluetooth-force-hci-logger.service
155 #%{_libdir}/systemd/system/bluetooth-hci-dump@.service
156 %{_libdir}/systemd/system/bluetooth-stack-up.service
157 %{_libdir}/systemd/system/bluetooth-stack-up.path
158 %{_libdir}/systemd/system/bluetooth-stack-down.service
159 %{_libdir}/systemd/system/bluetooth-stack-down.path
160 %{_libdir}/systemd/system/bluetooth-hci-up.service
161 %{_libdir}/systemd/system/bluetooth-hci-up.path
162 %{_libdir}/systemd/system/bluetooth-hci-down.service
163 %{_libdir}/systemd/system/bluetooth-hci-down.path
164
165 %post profile_common
166 pushd %{_prefix}/etc/bluetooth/
167 ln -sf common/bt-stack-up.sh bt-stack-up.sh
168 ln -sf common/bt-stack-down.sh bt-stack-down.sh
169 ln -sf common/bt-reset-env.sh bt-reset-env.sh
170 popd
171 pushd %{_unitdir}
172 mv bluetooth-stack-up-common.service bluetooth-stack-up.service
173 mv bluetooth-stack-down-common.service bluetooth-stack-down.service
174 popd
175 %preun profile_common
176 pushd %{_prefix}/etc/bluetooth/
177 rm bt-stack-up.sh
178 rm bt-stack-down.sh
179 rm bt-reset-env.sh
180 popd
181 pushd %{_unitdir}
182 rm bluetooth-stack-up.service
183 rm bluetooth-stack-down.service
184 popd
185 %files profile_common
186 %license LICENSE.APLv2
187 #%{_sysconfdir}/rc.d/init.d/bluetooth-address
188 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-up.sh
189 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-down.sh
190 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-reset-env.sh
191 %{_libdir}/systemd/system/bluetooth-stack-up-common.service
192 %{_libdir}/systemd/system/bluetooth-stack-down-common.service
193
194 %post profile_mobile
195 pushd %{_prefix}/etc/bluetooth/
196 ln -sf mobile/bt-stack-up.sh bt-stack-up.sh
197 ln -sf mobile/bt-stack-down.sh bt-stack-down.sh
198 ln -sf mobile/bt-stack-down-with-radio.sh bt-stack-down-with-radio.sh
199 ln -sf mobile/bt-reset-env.sh bt-reset-env.sh
200 ln -sf %{_libdir}/systemd/system/bluetooth-stack-down-with-radio.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-stack-down-with-radio.path
201 popd
202 %preun profile_mobile
203 pushd %{_prefix}/etc/bluetooth/
204 rm bt-stack-up.sh
205 rm bt-stack-down.sh
206 rm bt-stack-down-with-radio.sh
207 rm bt-reset-env.sh
208 popd
209 %files profile_mobile
210 %license LICENSE.APLv2
211 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-up.sh
212 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down.sh
213 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-reset-env.sh
214 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down-with-radio.sh
215 %{_libdir}/systemd/system/bluetooth-stack-down-with-radio.service
216 %{_libdir}/systemd/system/bluetooth-stack-down-with-radio.path
217
218 %post profile_ivi
219 pushd %{_prefix}/etc/bluetooth/
220 ln -sf ivi/bt-stack-up.sh bt-stack-up.sh
221 ln -sf ivi/bt-stack-down.sh bt-stack-down.sh
222 ln -sf ivi/bt-reset-env.sh bt-reset-env.sh
223 popd
224 %preun profile_ivi
225 pushd %{_prefix}/etc/bluetooth/
226 rm bt-stack-up.sh
227 rm bt-stack-down.sh
228 rm bt-reset-env.sh
229 popd
230 %files profile_ivi
231 %license LICENSE.APLv2
232 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-up.sh
233 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-down.sh
234 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-reset-env.sh
235
236 %post profile_wearable
237 pushd %{_prefix}/etc/bluetooth/
238 ln -sf wearable/bt-stack-up.sh bt-stack-up.sh
239 ln -sf wearable/bt-stack-down.sh bt-stack-down.sh
240 ln -sf wearable/bt-reset-env.sh bt-reset-env.sh
241 popd
242 %preun profile_wearable
243 pushd %{_prefix}/etc/bluetooth/
244 rm bt-stack-up.sh
245 rm bt-stack-down.sh
246 rm bt-reset-env.sh
247 popd
248 %files profile_wearable
249 %license LICENSE.APLv2
250 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-up.sh
251 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-down.sh
252 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-reset-env.sh
253
254 %files no-firmware
255 %manifest %{name}.manifest
256 %license LICENSE.APLv2
257 %defattr(-, root, root)
258 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
259 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh