Remove the path activation files
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
1 Name:       bluetooth-tools
2 Summary:    Bluetooth-tools
3 Version:    0.2.37
4 Release:    0
5 Group:      Network & Connectivity/Bluetooth
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 #Source1001: bluetooth-address.service
9 BuildRequires:  cmake
10 Suggests:       bluetooth-share
11 Requires:       tizen-platform-config-tools
12 Requires:      bluetooth-scripts
13 Requires:   %{name}-compat = %{version}-%{release}
14 Recommends:   %{name}-profile_common = %{version}-%{release}
15
16 %description
17 Tools fo bluetooth run/stop and set address
18
19 %package profile_common
20 Summary:    Bluetooth-tools extension for common/tv
21 Provides:   %{name}-compat = %{version}-%{release}
22 Provides:   %{name}-profile_tv = %{version}-%{release}
23 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
24 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
25 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
26 %description profile_common
27 Bluetooth-tools extension for Tizen common / tv profile.
28
29 %package profile_mobile
30 Summary:    Bluetooth-tools extension for mobile/tv
31 Provides:   %{name}-compat = %{version}-%{release}
32 Conflicts:  %{name}-profile_common = %{version}-%{release}
33 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
34 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
35 %description profile_mobile
36 Bluetooth-tools extension for Tizen mobile profile.
37
38 %package profile_wearable
39 Summary:    Bluetooth-tools extension for wearable/tv
40 Provides:   %{name}-compat = %{version}-%{release}
41 Conflicts:  %{name}-profile_common = %{version}-%{release}
42 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
43 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
44 %description profile_wearable
45 Bluetooth-tools extension for Tizen wearable profile.
46
47 %package profile_ivi
48 Summary:    Bluetooth-tools extension for ivi/tv
49 Provides:   %{name}-compat = %{version}-%{release}
50 Conflicts:  %{name}-profile_common = %{version}-%{release}
51 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
52 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
53 %description profile_ivi
54 Bluetooth-tools extension for Tizen ivi profile.
55
56 %package no-firmware
57 Summary:    On/Off Bluetooth adapter
58 Group:      Network & Connectivity/Bluetooth
59 Requires:   %{name} = %{version}-%{release}
60 Requires:   rfkill
61 Provides:   bluetooth-scripts
62 Conflicts:  bluetooth-firmware-bcm
63
64 %description no-firmware
65 On/Off bluetooth device
66
67 %prep
68 %setup -q
69
70 %build
71 export CFLAGS+=" -fpie -fvisibility=hidden"
72 export CXXFLAGS+=" -fpie -fvisibility=hidden"
73 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
74
75 %cmake
76 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
77 %if 0%{?tizen_build_binary_release_type_eng}
78         -DBT_HCI_LOG_SIZE=10
79 %else
80         -DBT_HCI_LOG_SIZE=5
81 %endif
82
83 %__make %{?_smp_mflags}
84
85 %install
86 rm -rf %{buildroot}
87 %make_install
88
89 mkdir -p %{buildroot}%{_prefix}/etc/bluetooth/
90 mkdir -p %{buildroot}/run/bluetooth
91 install -m 0755 scripts/bt-dev-start.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-start.sh
92 install -m 0755 scripts/bt-dev-end.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-end.sh
93
94 install -D -m 0644 packaging/bluez-start.service %{buildroot}%{_libdir}/systemd/system/bluez-start.service
95
96 install -D -m 0644 packaging/bluetooth-stack-up.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-up.service
97
98 install -D -m 0644 packaging/bluetooth-stack-down.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down.service
99
100 install -D -m 0644 packaging/bluetooth-stack-down-with-radio.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down-with-radio.service
101
102 #install -D -m 0644 packaging/bluetooth-force-hci-logger.service %{buildroot}%{_libdir}/systemd/system/bluetooth-force-hci-logger.service
103 #install -D -m 0644 packaging/bluetooth-hci-dump@.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-dump@.service
104
105 install -D -m 0644 packaging/bluetooth-hci-up.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-up.service
106 install -D -m 0644 packaging/bluetooth-hci-down.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-down.service
107
108 install -D -m 0644 packaging/bluetooth-stack-up-common.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-up-common.service
109 install -D -m 0644 packaging/bluetooth-stack-down-common.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down-common.service
110
111 %post
112 mkdir -p %{_libdir}/systemd/system/multi-user.target.wants/
113
114 %files
115 %manifest %{name}.manifest
116 %license LICENSE.APLv2
117 %defattr(-,root,root,-)
118 #%exclude %{_sysconfdir}/rc.d/init.d/bluetooth-address
119 #%{_sysconfdir}/rc.d/rc3.d/S60bluetooth-address
120 #%{_sysconfdir}/rc.d/rc5.d/S60bluetooth-address
121 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-on.sh
122 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-dev-up.sh
123 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-mode-on.sh
124 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-off.sh
125 #%attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-hci-logdump.sh
126 #%attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-run-hci-logger.sh
127 #%{_unitdir}/multi-user.target.wants/bluetooth-address.service
128 #%{_unitdir}/bluetooth-address.service
129 #%{_libdir}/systemd/system/bluetooth-hci-logger.service
130 #%{_libdir}/systemd/system/bluetooth-hci-logger-stop.service
131 %{_libdir}/systemd/system/bluez-start.service
132 #%{_libdir}/systemd/system/bluetooth-force-hci-logger.service
133 #%{_libdir}/systemd/system/bluetooth-hci-dump@.service
134 %{_libdir}/systemd/system/bluetooth-stack-up.service
135 %{_libdir}/systemd/system/bluetooth-stack-down.service
136 %{_libdir}/systemd/system/bluetooth-hci-up.service
137 %{_libdir}/systemd/system/bluetooth-hci-down.service
138
139 %post profile_common
140 pushd %{_prefix}/etc/bluetooth/
141 ln -sf common/bt-stack-up.sh bt-stack-up.sh
142 ln -sf common/bt-stack-down.sh bt-stack-down.sh
143 ln -sf common/bt-reset-env.sh bt-reset-env.sh
144 popd
145 pushd %{_unitdir}
146 mv bluetooth-stack-up-common.service bluetooth-stack-up.service
147 mv bluetooth-stack-down-common.service bluetooth-stack-down.service
148 popd
149 %preun profile_common
150 pushd %{_prefix}/etc/bluetooth/
151 rm bt-stack-up.sh
152 rm bt-stack-down.sh
153 rm bt-reset-env.sh
154 popd
155 pushd %{_unitdir}
156 rm bluetooth-stack-up.service
157 rm bluetooth-stack-down.service
158 popd
159 %files profile_common
160 %license LICENSE.APLv2
161 #%{_sysconfdir}/rc.d/init.d/bluetooth-address
162 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-up.sh
163 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-down.sh
164 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-reset-env.sh
165 %{_libdir}/systemd/system/bluetooth-stack-up-common.service
166 %{_libdir}/systemd/system/bluetooth-stack-down-common.service
167
168 %post profile_mobile
169 pushd %{_prefix}/etc/bluetooth/
170 ln -sf mobile/bt-stack-up.sh bt-stack-up.sh
171 ln -sf mobile/bt-stack-down.sh bt-stack-down.sh
172 ln -sf mobile/bt-stack-down-with-radio.sh bt-stack-down-with-radio.sh
173 ln -sf mobile/bt-reset-env.sh bt-reset-env.sh
174 popd
175 %preun profile_mobile
176 pushd %{_prefix}/etc/bluetooth/
177 rm bt-stack-up.sh
178 rm bt-stack-down.sh
179 rm bt-stack-down-with-radio.sh
180 rm bt-reset-env.sh
181 popd
182 %files profile_mobile
183 %license LICENSE.APLv2
184 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-up.sh
185 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down.sh
186 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-reset-env.sh
187 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down-with-radio.sh
188 %{_libdir}/systemd/system/bluetooth-stack-down-with-radio.service
189
190 %post profile_ivi
191 pushd %{_prefix}/etc/bluetooth/
192 ln -sf ivi/bt-stack-up.sh bt-stack-up.sh
193 ln -sf ivi/bt-stack-down.sh bt-stack-down.sh
194 ln -sf ivi/bt-reset-env.sh bt-reset-env.sh
195 popd
196 %preun profile_ivi
197 pushd %{_prefix}/etc/bluetooth/
198 rm bt-stack-up.sh
199 rm bt-stack-down.sh
200 rm bt-reset-env.sh
201 popd
202 %files profile_ivi
203 %license LICENSE.APLv2
204 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-up.sh
205 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-down.sh
206 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-reset-env.sh
207
208 %post profile_wearable
209 pushd %{_prefix}/etc/bluetooth/
210 ln -sf wearable/bt-stack-up.sh bt-stack-up.sh
211 ln -sf wearable/bt-stack-down.sh bt-stack-down.sh
212 ln -sf wearable/bt-reset-env.sh bt-reset-env.sh
213 popd
214 %preun profile_wearable
215 pushd %{_prefix}/etc/bluetooth/
216 rm bt-stack-up.sh
217 rm bt-stack-down.sh
218 rm bt-reset-env.sh
219 popd
220 %files profile_wearable
221 %license LICENSE.APLv2
222 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-up.sh
223 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-down.sh
224 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-reset-env.sh
225
226 %files no-firmware
227 %manifest %{name}.manifest
228 %license LICENSE.APLv2
229 %defattr(-, root, root)
230 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
231 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh