8b0e76159f2a6186db41fa561fb161dc998c9577
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
1 Name:       bluetooth-tools
2 Summary:    Bluetooth-tools
3 Version:    0.2.37
4 Release:    0
5 Group:      Network & Connectivity/Bluetooth
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 #Source1001: bluetooth-address.service
9 BuildRequires:  cmake
10 Suggests:       bluetooth-share
11 Requires:       tizen-platform-config-tools
12 Requires:      bluetooth-scripts
13 Requires:   %{name}-compat = %{version}-%{release}
14 Recommends:   %{name}-profile_common = %{version}-%{release}
15
16 %description
17 Tools fo bluetooth run/stop and set address
18
19 %package profile_common
20 Summary:    Bluetooth-tools extension for common/tv
21 Provides:   %{name}-compat = %{version}-%{release}
22 Provides:   %{name}-profile_tv = %{version}-%{release}
23 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
24 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
25 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
26 %description profile_common
27 Bluetooth-tools extension for Tizen common / tv profile.
28
29 %package profile_mobile
30 Summary:    Bluetooth-tools extension for mobile/tv
31 Provides:   %{name}-compat = %{version}-%{release}
32 Conflicts:  %{name}-profile_common = %{version}-%{release}
33 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
34 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
35 %description profile_mobile
36 Bluetooth-tools extension for Tizen mobile profile.
37
38 %package profile_wearable
39 Summary:    Bluetooth-tools extension for wearable/tv
40 Provides:   %{name}-compat = %{version}-%{release}
41 Conflicts:  %{name}-profile_common = %{version}-%{release}
42 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
43 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
44 %description profile_wearable
45 Bluetooth-tools extension for Tizen wearable profile.
46
47 %package profile_ivi
48 Summary:    Bluetooth-tools extension for ivi/tv
49 Provides:   %{name}-compat = %{version}-%{release}
50 Conflicts:  %{name}-profile_common = %{version}-%{release}
51 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
52 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
53 %description profile_ivi
54 Bluetooth-tools extension for Tizen ivi profile.
55
56 %package no-firmware
57 Summary:    On/Off Bluetooth adapter
58 Group:      Network & Connectivity/Bluetooth
59 Requires:   %{name} = %{version}-%{release}
60 Requires:   rfkill
61 Provides:   bluetooth-scripts
62 Conflicts:  bluetooth-firmware-bcm
63
64 %description no-firmware
65 On/Off bluetooth device
66
67 %prep
68 %setup -q
69
70 %build
71 export CFLAGS+=" -fpie -fvisibility=hidden"
72 export CXXFLAGS+=" -fpie -fvisibility=hidden"
73 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
74
75 %cmake
76 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
77 %if 0%{?tizen_build_binary_release_type_eng}
78         -DBT_HCI_LOG_SIZE=10
79 %else
80         -DBT_HCI_LOG_SIZE=5
81 %endif
82
83 %__make %{?_smp_mflags}
84
85 %install
86 rm -rf %{buildroot}
87 %make_install
88
89 mkdir -p %{buildroot}%{_prefix}/etc/bluetooth/
90 install -m 0755 scripts/bt-dev-start.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-start.sh
91 install -m 0755 scripts/bt-dev-end.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-end.sh
92
93 install -D -m 0644 packaging/bluetooth-hci-logger.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger.service
94 install -D -m 0644 packaging/bluetooth-force-hci-logger.service %{buildroot}%{_libdir}/systemd/system/bluetooth-force-hci-logger.service
95 install -D -m 0644 packaging/bluetooth-hci-dump@.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-dump@.service
96
97 %post
98 mkdir -p %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
99 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
100 ln -sf %{_libdir}/systemd/system/bluetooth-force-hci-logger.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
101
102
103 %files
104 %manifest %{name}.manifest
105 %license LICENSE.APLv2
106 %defattr(-,root,root,-)
107 #%exclude %{_sysconfdir}/rc.d/init.d/bluetooth-address
108 #%{_sysconfdir}/rc.d/rc3.d/S60bluetooth-address
109 #%{_sysconfdir}/rc.d/rc5.d/S60bluetooth-address
110 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-on.sh
111 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-dev-up.sh
112 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-mode-on.sh
113 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-off.sh
114 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-hci-logdump.sh
115 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-run-hci-logger.sh
116 #%{_unitdir}/multi-user.target.wants/bluetooth-address.service
117 #%{_unitdir}/bluetooth-address.service
118 %{_libdir}/systemd/system/bluetooth-hci-logger.service
119 %{_libdir}/systemd/system/bluetooth-force-hci-logger.service
120 %{_libdir}/systemd/system/bluetooth-hci-dump@.service
121
122 %post profile_common
123 pushd %{_prefix}/etc/bluetooth/
124 ln -sf common/bt-stack-up.sh bt-stack-up.sh
125 ln -sf common/bt-stack-down.sh bt-stack-down.sh
126 ln -sf common/bt-reset-env.sh bt-reset-env.sh
127 popd
128 %preun profile_common
129 pushd %{_prefix}/etc/bluetooth/
130 rm bt-stack-up.sh
131 rm bt-stack-down.sh
132 rm bt-reset-env.sh
133 popd
134 %files profile_common
135 %license LICENSE.APLv2
136 #%{_sysconfdir}/rc.d/init.d/bluetooth-address
137 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-up.sh
138 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-down.sh
139 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-reset-env.sh
140
141 %post profile_mobile
142 pushd %{_prefix}/etc/bluetooth/
143 ln -sf mobile/bt-stack-up.sh bt-stack-up.sh
144 ln -sf mobile/bt-stack-down.sh bt-stack-down.sh
145 ln -sf mobile/bt-stack-down-with-radio.sh bt-stack-down-with-radio.sh
146 ln -sf mobile/bt-reset-env.sh bt-reset-env.sh
147 popd
148 %preun profile_mobile
149 pushd %{_prefix}/etc/bluetooth/
150 rm bt-stack-up.sh
151 rm bt-stack-down.sh
152 rm bt-stack-down-with-radio.sh
153 rm bt-reset-env.sh
154 popd
155 %files profile_mobile
156 %license LICENSE.APLv2
157 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-up.sh
158 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down.sh
159 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-reset-env.sh
160 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down-with-radio.sh
161
162 %post profile_ivi
163 pushd %{_prefix}/etc/bluetooth/
164 ln -sf ivi/bt-stack-up.sh bt-stack-up.sh
165 ln -sf ivi/bt-stack-down.sh bt-stack-down.sh
166 ln -sf ivi/bt-reset-env.sh bt-reset-env.sh
167 popd
168 %preun profile_ivi
169 pushd %{_prefix}/etc/bluetooth/
170 rm bt-stack-up.sh
171 rm bt-stack-down.sh
172 rm bt-reset-env.sh
173 popd
174 %files profile_ivi
175 %license LICENSE.APLv2
176 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-up.sh
177 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-down.sh
178 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-reset-env.sh
179
180 %post profile_wearable
181 pushd %{_prefix}/etc/bluetooth/
182 ln -sf wearable/bt-stack-up.sh bt-stack-up.sh
183 ln -sf wearable/bt-stack-down.sh bt-stack-down.sh
184 ln -sf wearable/bt-reset-env.sh bt-reset-env.sh
185 popd
186 %preun profile_wearable
187 pushd %{_prefix}/etc/bluetooth/
188 rm bt-stack-up.sh
189 rm bt-stack-down.sh
190 rm bt-reset-env.sh
191 popd
192 %files profile_wearable
193 %license LICENSE.APLv2
194 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-up.sh
195 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-down.sh
196 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-reset-env.sh
197
198 %files no-firmware
199 %manifest %{name}.manifest
200 %license LICENSE.APLv2
201 %defattr(-, root, root)
202 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
203 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh