79ccf1ecd927c24275250a90e7959121ef7783c4
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
1 Name:       bluetooth-tools
2 Summary:    Bluetooth-tools
3 Version:    0.2.37
4 Release:    0
5 Group:      Network & Connectivity/Bluetooth
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 #Source1001: bluetooth-address.service
9 BuildRequires:  cmake
10 Suggests:       bluetooth-share
11 Requires:       tizen-platform-config-tools
12 Requires:      bluetooth-scripts
13 Requires:   %{name}-compat = %{version}-%{release}
14 Recommends:   %{name}-profile_common = %{version}-%{release}
15
16 %description
17 Tools fo bluetooth run/stop and set address
18
19 %package profile_common
20 Summary:    Bluetooth-tools extension for common/tv
21 Provides:   %{name}-compat = %{version}-%{release}
22 Provides:   %{name}-profile_tv = %{version}-%{release}
23 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
24 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
25 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
26 %description profile_common
27 Bluetooth-tools extension for Tizen common / tv profile.
28
29 %package profile_mobile
30 Summary:    Bluetooth-tools extension for mobile/tv
31 Provides:   %{name}-compat = %{version}-%{release}
32 Conflicts:  %{name}-profile_common = %{version}-%{release}
33 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
34 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
35 %description profile_mobile
36 Bluetooth-tools extension for Tizen mobile profile.
37
38 %package profile_wearable
39 Summary:    Bluetooth-tools extension for wearable/tv
40 Provides:   %{name}-compat = %{version}-%{release}
41 Conflicts:  %{name}-profile_common = %{version}-%{release}
42 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
43 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
44 %description profile_wearable
45 Bluetooth-tools extension for Tizen wearable profile.
46
47 %package profile_ivi
48 Summary:    Bluetooth-tools extension for ivi/tv
49 Provides:   %{name}-compat = %{version}-%{release}
50 Conflicts:  %{name}-profile_common = %{version}-%{release}
51 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
52 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
53 %description profile_ivi
54 Bluetooth-tools extension for Tizen ivi profile.
55
56 %package no-firmware
57 Summary:    On/Off Bluetooth adapter
58 Group:      Network & Connectivity/Bluetooth
59 Requires:   %{name} = %{version}-%{release}
60 Requires:   rfkill
61 Provides:   bluetooth-scripts
62 Conflicts:  bluetooth-firmware-bcm
63
64 %description no-firmware
65 On/Off bluetooth device
66
67 %prep
68 %setup -q
69
70 %build
71 export CFLAGS+=" -fpie -fvisibility=hidden"
72 export CXXFLAGS+=" -fpie -fvisibility=hidden"
73 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
74
75 %cmake
76 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
77 %if 0%{?tizen_build_binary_release_type_eng}
78         -DBT_HCI_LOG_SIZE=10
79 %else
80         -DBT_HCI_LOG_SIZE=5
81 %endif
82
83 %__make %{?_smp_mflags}
84
85 %install
86 rm -rf %{buildroot}
87 %make_install
88
89 mkdir -p %{buildroot}%{_prefix}/etc/bluetooth/
90 mkdir -p %{buildroot}/run/bluetooth
91 install -m 0755 scripts/bt-dev-start.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-start.sh
92 install -m 0755 scripts/bt-dev-end.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-end.sh
93
94 install -D -m 0644 packaging/bluetooth-hci-logger.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger.service
95 install -D -m 0644 packaging/bluetooth-hci-logger.path %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger.path
96
97 install -D -m 0644 packaging/bluetooth-hci-logger-stop.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger-stop.service
98 install -D -m 0644 packaging/bluetooth-hci-logger-stop.path %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger-stop.path
99
100 install -D -m 0644 packaging/bluez-start.service %{buildroot}%{_libdir}/systemd/system/bluez-start.service
101 install -D -m 0644 packaging/bluez-start.path %{buildroot}%{_libdir}/systemd/system/bluez-start.path
102
103 install -D -m 0644 packaging/bluetooth-share-start.service %{buildroot}%{_libdir}/systemd/system/bluetooth-share-start.service
104 install -D -m 0644 packaging/bluetooth-share-start.path %{buildroot}%{_libdir}/systemd/system/bluetooth-share-start.path
105
106 install -D -m 0644 packaging/bluetooth-stack-down.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down.service
107 install -D -m 0644 packaging/bluetooth-stack-down.path %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down.path
108
109 install -D -m 0644 packaging/bluetooth-force-hci-logger.service %{buildroot}%{_libdir}/systemd/system/bluetooth-force-hci-logger.service
110 install -D -m 0644 packaging/bluetooth-hci-dump@.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-dump@.service
111
112 %post
113 mkdir -p %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
114 mkdir -p %{_libdir}/systemd/system/multi-user.target.wants/
115 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
116 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hci-logger.path
117 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger.path %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
118
119 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger-stop.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
120 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger-stop.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hci-logger-stop.path
121 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger-stop.path %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
122
123 ln -sf %{_libdir}/systemd/system/bluez-start.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
124 ln -sf %{_libdir}/systemd/system/bluez-start.path %{_libdir}/systemd/system/multi-user.target.wants/bluez-start.path
125 ln -sf %{_libdir}/systemd/system/bluez-start.path %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
126
127 ln -sf %{_libdir}/systemd/system/bluetooth-share-start.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
128 ln -sf %{_libdir}/systemd/system/bluetooth-share-start.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-share-start.path
129 ln -sf %{_libdir}/systemd/system/bluetooth-share-start.path %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
130
131 ln -sf %{_libdir}/systemd/system/bluetooth-stack-down.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
132 ln -sf %{_libdir}/systemd/system/bluetooth-stack-down.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-stack-down.path
133 ln -sf %{_libdir}/systemd/system/bluetooth-stack-down.path %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
134
135 ln -sf %{_libdir}/systemd/system/bluetooth-force-hci-logger.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
136
137
138 %files
139 %manifest %{name}.manifest
140 %license LICENSE.APLv2
141 %defattr(-,root,root,-)
142 #%exclude %{_sysconfdir}/rc.d/init.d/bluetooth-address
143 #%{_sysconfdir}/rc.d/rc3.d/S60bluetooth-address
144 #%{_sysconfdir}/rc.d/rc5.d/S60bluetooth-address
145 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-on.sh
146 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-dev-up.sh
147 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-mode-on.sh
148 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-off.sh
149 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-hci-logdump.sh
150 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-run-hci-logger.sh
151 #%{_unitdir}/multi-user.target.wants/bluetooth-address.service
152 #%{_unitdir}/bluetooth-address.service
153 %{_libdir}/systemd/system/bluetooth-hci-logger.service
154 %{_libdir}/systemd/system/bluetooth-hci-logger.path
155 %{_libdir}/systemd/system/bluetooth-hci-logger-stop.service
156 %{_libdir}/systemd/system/bluetooth-hci-logger-stop.path
157 %{_libdir}/systemd/system/bluez-start.service
158 %{_libdir}/systemd/system/bluez-start.path
159 %{_libdir}/systemd/system/bluetooth-share-start.service
160 %{_libdir}/systemd/system/bluetooth-share-start.path
161 %{_libdir}/systemd/system/bluetooth-force-hci-logger.service
162 %{_libdir}/systemd/system/bluetooth-hci-dump@.service
163 %{_libdir}/systemd/system/bluetooth-stack-down.service
164 %{_libdir}/systemd/system/bluetooth-stack-down.path
165
166 %post profile_common
167 pushd %{_prefix}/etc/bluetooth/
168 ln -sf common/bt-stack-up.sh bt-stack-up.sh
169 ln -sf common/bt-stack-down.sh bt-stack-down.sh
170 ln -sf common/bt-reset-env.sh bt-reset-env.sh
171 popd
172 %preun profile_common
173 pushd %{_prefix}/etc/bluetooth/
174 rm bt-stack-up.sh
175 rm bt-stack-down.sh
176 rm bt-reset-env.sh
177 popd
178 %files profile_common
179 %license LICENSE.APLv2
180 #%{_sysconfdir}/rc.d/init.d/bluetooth-address
181 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-up.sh
182 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-down.sh
183 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-reset-env.sh
184
185 %post profile_mobile
186 pushd %{_prefix}/etc/bluetooth/
187 ln -sf mobile/bt-stack-up.sh bt-stack-up.sh
188 ln -sf mobile/bt-stack-down.sh bt-stack-down.sh
189 ln -sf mobile/bt-stack-down-with-radio.sh bt-stack-down-with-radio.sh
190 ln -sf mobile/bt-reset-env.sh bt-reset-env.sh
191 popd
192 %preun profile_mobile
193 pushd %{_prefix}/etc/bluetooth/
194 rm bt-stack-up.sh
195 rm bt-stack-down.sh
196 rm bt-stack-down-with-radio.sh
197 rm bt-reset-env.sh
198 popd
199 %files profile_mobile
200 %license LICENSE.APLv2
201 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-up.sh
202 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down.sh
203 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-reset-env.sh
204 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down-with-radio.sh
205
206 %post profile_ivi
207 pushd %{_prefix}/etc/bluetooth/
208 ln -sf ivi/bt-stack-up.sh bt-stack-up.sh
209 ln -sf ivi/bt-stack-down.sh bt-stack-down.sh
210 ln -sf ivi/bt-reset-env.sh bt-reset-env.sh
211 popd
212 %preun profile_ivi
213 pushd %{_prefix}/etc/bluetooth/
214 rm bt-stack-up.sh
215 rm bt-stack-down.sh
216 rm bt-reset-env.sh
217 popd
218 %files profile_ivi
219 %license LICENSE.APLv2
220 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-up.sh
221 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-down.sh
222 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-reset-env.sh
223
224 %post profile_wearable
225 pushd %{_prefix}/etc/bluetooth/
226 ln -sf wearable/bt-stack-up.sh bt-stack-up.sh
227 ln -sf wearable/bt-stack-down.sh bt-stack-down.sh
228 ln -sf wearable/bt-reset-env.sh bt-reset-env.sh
229 popd
230 %preun profile_wearable
231 pushd %{_prefix}/etc/bluetooth/
232 rm bt-stack-up.sh
233 rm bt-stack-down.sh
234 rm bt-reset-env.sh
235 popd
236 %files profile_wearable
237 %license LICENSE.APLv2
238 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-up.sh
239 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-down.sh
240 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-reset-env.sh
241
242 %files no-firmware
243 %manifest %{name}.manifest
244 %license LICENSE.APLv2
245 %defattr(-, root, root)
246 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
247 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh