6facd2b4e40b4c6c2af9e06ba2d16fee49d04b69
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
1 Name:       bluetooth-tools
2 Summary:    Bluetooth-tools
3 Version:    0.2.37
4 Release:    0
5 Group:      Network & Connectivity/Bluetooth
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 #Source1001: bluetooth-address.service
9 BuildRequires:  cmake
10 Suggests:       bluetooth-share
11 Requires:       tizen-platform-config-tools
12 Requires:      bluetooth-scripts
13 Requires:   %{name}-compat = %{version}-%{release}
14 Recommends:   %{name}-profile_common = %{version}-%{release}
15
16 %description
17 Tools fo bluetooth run/stop and set address
18
19 %package profile_common
20 Summary:    Bluetooth-tools extension for common/tv
21 Provides:   %{name}-compat = %{version}-%{release}
22 Provides:   %{name}-profile_tv = %{version}-%{release}
23 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
24 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
25 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
26 %description profile_common
27 Bluetooth-tools extension for Tizen common / tv profile.
28
29 %package profile_mobile
30 Summary:    Bluetooth-tools extension for mobile/tv
31 Provides:   %{name}-compat = %{version}-%{release}
32 Conflicts:  %{name}-profile_common = %{version}-%{release}
33 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
34 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
35 %description profile_mobile
36 Bluetooth-tools extension for Tizen mobile profile.
37
38 %package profile_wearable
39 Summary:    Bluetooth-tools extension for wearable/tv
40 Provides:   %{name}-compat = %{version}-%{release}
41 Conflicts:  %{name}-profile_common = %{version}-%{release}
42 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
43 Conflicts:  %{name}-profile_ivi = %{version}-%{release}
44 %description profile_wearable
45 Bluetooth-tools extension for Tizen wearable profile.
46
47 %package profile_ivi
48 Summary:    Bluetooth-tools extension for ivi/tv
49 Provides:   %{name}-compat = %{version}-%{release}
50 Conflicts:  %{name}-profile_common = %{version}-%{release}
51 Conflicts:  %{name}-profile_mobile = %{version}-%{release}
52 Conflicts:  %{name}-profile_wearable = %{version}-%{release}
53 %description profile_ivi
54 Bluetooth-tools extension for Tizen ivi profile.
55
56 %package no-firmware
57 Summary:    On/Off Bluetooth adapter
58 Group:      Network & Connectivity/Bluetooth
59 Requires:   %{name} = %{version}-%{release}
60 Requires:   rfkill
61 Provides:   bluetooth-scripts
62 Conflicts:  bluetooth-firmware-bcm
63
64 %description no-firmware
65 On/Off bluetooth device
66
67 %prep
68 %setup -q
69
70 %build
71 export CFLAGS+=" -fpie -fvisibility=hidden"
72 export CXXFLAGS+=" -fpie -fvisibility=hidden"
73 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
74
75 %cmake
76 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
77 %if 0%{?tizen_build_binary_release_type_eng}
78         -DBT_HCI_LOG_SIZE=10
79 %else
80         -DBT_HCI_LOG_SIZE=5
81 %endif
82
83 %__make %{?_smp_mflags}
84
85 %install
86 rm -rf %{buildroot}
87 %make_install
88
89 mkdir -p %{buildroot}%{_prefix}/etc/bluetooth/
90 mkdir -p %{buildroot}/run/bluetooth
91 install -m 0755 scripts/bt-dev-start.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-start.sh
92 install -m 0755 scripts/bt-dev-end.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-end.sh
93
94 install -D -m 0644 packaging/bluetooth-hci-logger.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger.service
95 install -D -m 0644 packaging/bluetooth-hci-logger.path %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger.path
96
97 install -D -m 0644 packaging/bluetooth-hci-logger-stop.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger-stop.service
98 install -D -m 0644 packaging/bluetooth-hci-logger-stop.path %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger-stop.path
99
100 install -D -m 0644 packaging/bluez-start.service %{buildroot}%{_libdir}/systemd/system/bluez-start.service
101 install -D -m 0644 packaging/bluez-start.path %{buildroot}%{_libdir}/systemd/system/bluez-start.path
102
103 install -D -m 0644 packaging/bluetooth-share-start.service %{buildroot}%{_libdir}/systemd/system/bluetooth-share-start.service
104 install -D -m 0644 packaging/bluetooth-share-start.path %{buildroot}%{_libdir}/systemd/system/bluetooth-share-start.path
105
106 install -D -m 0644 packaging/bluetooth-force-hci-logger.service %{buildroot}%{_libdir}/systemd/system/bluetooth-force-hci-logger.service
107 install -D -m 0644 packaging/bluetooth-hci-dump@.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-dump@.service
108
109 %post
110 mkdir -p %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
111 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
112 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hci-logger.path
113 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger.path %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
114
115 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger-stop.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
116 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger-stop.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hci-logger-stop.path
117 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger-stop.path %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
118
119 ln -sf %{_libdir}/systemd/system/bluez-start.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
120 ln -sf %{_libdir}/systemd/system/bluez-start.path %{_libdir}/systemd/system/multi-user.target.wants/bluez-start.path
121 ln -sf %{_libdir}/systemd/system/bluez-start.path %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
122
123 ln -sf %{_libdir}/systemd/system/bluetooth-share-start.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
124 ln -sf %{_libdir}/systemd/system/bluetooth-share-start.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-share-start.path
125 ln -sf %{_libdir}/systemd/system/bluetooth-share-start.path %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
126
127 ln -sf %{_libdir}/systemd/system/bluetooth-force-hci-logger.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
128
129
130 %files
131 %manifest %{name}.manifest
132 %license LICENSE.APLv2
133 %defattr(-,root,root,-)
134 #%exclude %{_sysconfdir}/rc.d/init.d/bluetooth-address
135 #%{_sysconfdir}/rc.d/rc3.d/S60bluetooth-address
136 #%{_sysconfdir}/rc.d/rc5.d/S60bluetooth-address
137 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-on.sh
138 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-dev-up.sh
139 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-mode-on.sh
140 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-off.sh
141 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-hci-logdump.sh
142 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-run-hci-logger.sh
143 #%{_unitdir}/multi-user.target.wants/bluetooth-address.service
144 #%{_unitdir}/bluetooth-address.service
145 %{_libdir}/systemd/system/bluetooth-hci-logger.service
146 %{_libdir}/systemd/system/bluetooth-hci-logger.path
147 %{_libdir}/systemd/system/bluetooth-hci-logger-stop.service
148 %{_libdir}/systemd/system/bluetooth-hci-logger-stop.path
149 %{_libdir}/systemd/system/bluez-start.service
150 %{_libdir}/systemd/system/bluez-start.path
151 %{_libdir}/systemd/system/bluetooth-share-start.service
152 %{_libdir}/systemd/system/bluetooth-share-start.path
153 %{_libdir}/systemd/system/bluetooth-force-hci-logger.service
154 %{_libdir}/systemd/system/bluetooth-hci-dump@.service
155
156 %post profile_common
157 pushd %{_prefix}/etc/bluetooth/
158 ln -sf common/bt-stack-up.sh bt-stack-up.sh
159 ln -sf common/bt-stack-down.sh bt-stack-down.sh
160 ln -sf common/bt-reset-env.sh bt-reset-env.sh
161 popd
162 %preun profile_common
163 pushd %{_prefix}/etc/bluetooth/
164 rm bt-stack-up.sh
165 rm bt-stack-down.sh
166 rm bt-reset-env.sh
167 popd
168 %files profile_common
169 %license LICENSE.APLv2
170 #%{_sysconfdir}/rc.d/init.d/bluetooth-address
171 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-up.sh
172 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-down.sh
173 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-reset-env.sh
174
175 %post profile_mobile
176 pushd %{_prefix}/etc/bluetooth/
177 ln -sf mobile/bt-stack-up.sh bt-stack-up.sh
178 ln -sf mobile/bt-stack-down.sh bt-stack-down.sh
179 ln -sf mobile/bt-stack-down-with-radio.sh bt-stack-down-with-radio.sh
180 ln -sf mobile/bt-reset-env.sh bt-reset-env.sh
181 popd
182 %preun profile_mobile
183 pushd %{_prefix}/etc/bluetooth/
184 rm bt-stack-up.sh
185 rm bt-stack-down.sh
186 rm bt-stack-down-with-radio.sh
187 rm bt-reset-env.sh
188 popd
189 %files profile_mobile
190 %license LICENSE.APLv2
191 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-up.sh
192 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down.sh
193 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-reset-env.sh
194 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down-with-radio.sh
195
196 %post profile_ivi
197 pushd %{_prefix}/etc/bluetooth/
198 ln -sf ivi/bt-stack-up.sh bt-stack-up.sh
199 ln -sf ivi/bt-stack-down.sh bt-stack-down.sh
200 ln -sf ivi/bt-reset-env.sh bt-reset-env.sh
201 popd
202 %preun profile_ivi
203 pushd %{_prefix}/etc/bluetooth/
204 rm bt-stack-up.sh
205 rm bt-stack-down.sh
206 rm bt-reset-env.sh
207 popd
208 %files profile_ivi
209 %license LICENSE.APLv2
210 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-up.sh
211 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-down.sh
212 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-reset-env.sh
213
214 %post profile_wearable
215 pushd %{_prefix}/etc/bluetooth/
216 ln -sf wearable/bt-stack-up.sh bt-stack-up.sh
217 ln -sf wearable/bt-stack-down.sh bt-stack-down.sh
218 ln -sf wearable/bt-reset-env.sh bt-reset-env.sh
219 popd
220 %preun profile_wearable
221 pushd %{_prefix}/etc/bluetooth/
222 rm bt-stack-up.sh
223 rm bt-stack-down.sh
224 rm bt-reset-env.sh
225 popd
226 %files profile_wearable
227 %license LICENSE.APLv2
228 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-up.sh
229 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-down.sh
230 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-reset-env.sh
231
232 %files no-firmware
233 %manifest %{name}.manifest
234 %license LICENSE.APLv2
235 %defattr(-, root, root)
236 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
237 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh