77696e685bd7f38b29354e2e3e63b74f61f94aa3
[platform/core/connectivity/bluetooth-frwk.git] / packaging / bluetooth-frwk.spec
1 # Do not create provides from emulator .so files because the main package
2 # should anchor any reverse-dependencies
3 %global __provides_exclude_from ^(.*\\.emulator)$
4
5 %bcond_with x
6 %define _dumpdir /opt/etc/dump.d/module.d
7 %define _varlibdir /opt/var/lib
8 %define _meshdir /opt/usr/mesh
9
10 Name:       bluetooth-frwk
11 Summary:    Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
12 Version:    0.6.0
13 Release:    1
14 Group:      Network & Connectivity/Bluetooth
15 License:    Apache-2.0
16 Source0:    %{name}-%{version}.tar.gz
17 Source1001: bluetooth-frwk.manifest
18
19 Requires: bluetooth-tools
20
21 %define bt_bluez_hal ENABLED
22 %define bt_gatt_client_fd ENABLED
23 %define bt_permanent_log DISABLED
24 %define bt_http_proxy DISABLED
25 %define bt_factory_mode DISABLED
26 %define bt_vendor_operation DISABLED
27
28 BuildRequires:  pkgconfig(aul)
29 %if %{bt_factory_mode} == ENABLED
30 BuildRequires:  pkgconfig(bincfg)
31 %endif
32 BuildRequires:  pkgconfig(dlog)
33 BuildRequires:  pkgconfig(glib-2.0)
34 BuildRequires:  pkgconfig(gio-2.0)
35 BuildRequires:  pkgconfig(gio-unix-2.0)
36 BuildRequires:  pkgconfig(syspopup-caller)
37 BuildRequires:  pkgconfig(vconf)
38 BuildRequires:  pkgconfig(libxml-2.0)
39 BuildRequires:  pkgconfig(capi-network-connection)
40 BuildRequires:  pkgconfig(alarm-service)
41 BuildRequires:  pkgconfig(capi-content-mime-type)
42 BuildRequires:  pkgconfig(eventsystem)
43 %if %{bt_http_proxy} == ENABLED
44 BuildRequires:  pkgconfig(libsoup-2.4)
45 %endif
46 BuildRequires:  pkgconfig(capi-network-tethering)
47 BuildRequires:  cmake
48 BuildRequires:  pkgconfig(cynara-client)
49 BuildRequires:  pkgconfig(cynara-creds-gdbus)
50 BuildRequires:  pkgconfig(libtzplatform-config)
51 BuildRequires:  pkgconfig(json-c)
52 BuildRequires:  pkgconfig(ell)
53 BuildRequires:  pkgconfig(storage)
54 BuildRequires:  pkgconfig(capi-system-info)
55 BuildRequires:  pkgconfig(capi-appfw-app-control)
56 BuildRequires:  pkgconfig(gmock)
57 BuildRequires:  pkgconfig(libactd)
58 BuildRequires:  pkgconfig(libsystemd)
59 BuildRequires:  pkgconfig(hal-api-bluetooth)
60
61 Requires(post): /usr/bin/vconftool
62 Requires(post): /sbin/ldconfig
63 Requires(postun): /sbin/ldconfig
64
65 %description
66 Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
67 This package contains API set for BT GAP, BT SDP, BT RFCOMM and BLE Mesh.
68
69 %package profile_common
70 Summary:    bluetooth-frwk service and conf files for common profile
71 Requires:   %{name} = %{version}-%{release}
72 Conflicts:  %{name}-profile_mobile
73 Conflicts:  %{name}-profile_wearable
74 Conflicts:  %{name}-profile_tv
75 Conflicts:  %{name}-profile_ivi
76 %description profile_common
77 Bluetooth framework configuration and service files for Tizen common profile
78
79 %package profile_mobile
80 Summary:    bluetooth-frwk service and conf files for mobile profile
81 Requires:   %{name} = %{version}-%{release}
82 Conflicts:  %{name}-profile_common
83 Conflicts:  %{name}-profile_wearable
84 Conflicts:  %{name}-profile_tv
85 Conflicts:  %{name}-profile_ivi
86 %description profile_mobile
87 Bluetooth framework configuration and service files for Tizen mobile profile
88
89 # extension-TM1
90 %ifarch %{ix86} || %{arm}
91 %package extension-TM1
92 Summary:    bluetooth-frwk service and conf files for mobile TM1
93 Requires:   %{name}-profile_mobile = %{version}-%{release}
94 %description extension-TM1
95 Bluetooth framework configuration and service files for Tizen mobile TM1
96 %endif
97
98 %package profile_wearable
99 Summary:    bluetooth-frwk service and conf files for wearable profile
100 Requires:   %{name} = %{version}-%{release}
101 Conflicts:  %{name}-profile_mobile
102 Conflicts:  %{name}-profile_common
103 Conflicts:  %{name}-profile_tv
104 Conflicts:  %{name}-profile_ivi
105 %description profile_wearable
106 Bluetooth framework configuration and service files for Tizen wearable profile
107
108 %package profile_tv
109 Summary:    bluetooth-frwk service and conf files for tv profile
110 Requires:   %{name} = %{version}-%{release}
111 Conflicts:  %{name}-profile_mobile
112 Conflicts:  %{name}-profile_wearable
113 Conflicts:  %{name}-profile_common
114 Conflicts:  %{name}-profile_ivi
115 %description profile_tv
116 Bluetooth framework configuration and service files for Tizen tv profile
117
118 %package profile_ivi
119 Summary:    bluetooth-frwk service and conf files for ivi profile
120 Requires:   %{name} = %{version}-%{release}
121 Conflicts:  %{name}-profile_mobile
122 Conflicts:  %{name}-profile_wearable
123 Conflicts:  %{name}-profile_tv
124 Conflicts:  %{name}-profile_common
125 %description profile_ivi
126 Bluetooth framework configuration and service files for Tizen ivi profile
127
128 %ifarch %{ix86} x86_64
129 %package extension-emulator
130 Summary:    bluetooth-frwk service and conf files for emulator
131 Requires:   %{name} = %{version}-%{release}
132 %description extension-emulator
133 bluetooth-frwk service and conf files for emulator
134 %endif // ifarch %{ix86} x86_64
135
136 %package devel
137 Summary:    Bluetooth framework for BlueZ and Obexd
138 Group:      Development/Libraries
139 Requires:   %{name} = %{version}-%{release}
140
141 %description devel
142 This package is development files for Bluetooth framework based on BlueZ and Obexd stack.
143 This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
144
145 %package service
146 Summary:    Bluetooth Service daemon
147 Group:      Network & Connectivity/Bluetooth
148 Requires:   %{name} = %{version}-%{release}
149
150 %description service
151 This package is Bluetooth Service daemon to manage BT services.
152
153 %if %{bt_http_proxy} == ENABLED
154 %package httpproxy
155 Summary:    Bluetooth HTTP Proxy Service daemon
156 Group:      Network & Connectivity/Bluetooth
157 Requires:   %{name} = %{version}-%{release}
158
159 %description httpproxy
160 This package is Bluetooth HTTP Proxy Service daemon
161 %endif
162
163 %package otp
164 Summary:    Bluetooth OTP Service daemon
165 Group:      Network & Connectivity/Bluetooth
166 Requires:   %{name} = %{version}-%{release}
167
168 %description otp
169 This package is Bluetooth OTP Service daemon
170
171 %package core
172 Summary:    Bluetooth Core daemon
173 Group:      Network & Connectivity/Bluetooth
174 Requires:   %{name} = %{version}-%{release}
175
176 %description core
177 This package is Bluetooth core daemon to manage activation / deactivation.
178
179 %package test
180 Summary:    Bluetooth test application
181 Group:      Network & Connectivity/Bluetooth
182 Requires:   %{name} = %{version}-%{release}
183
184 %description test
185 This package is Bluetooth test application.
186
187 %package oal
188 Summary:    Bluetooth OAL
189 Group:      Network & Connectivity/Bluetooth
190 Requires:   %{name} = %{version}-%{release}
191
192 %description oal
193 This package is BT stack common interface.
194
195 %package plugin-headed
196 Summary:    Bluetooth plugin Headed
197 Group:      Network & Connectivity/Bluetooth
198 Requires:   %{name} = %{version}-%{release}
199
200 %description plugin-headed
201 This package is Bluetooth plugin to manage UI and syspopup
202
203 %package -n bluetooth-haltests
204 Summary: HAL Test package for bluetooth OAL
205 Group:   TO_BE/FILLED
206 Requires: %{name} = %{version}-%{release}
207
208 %description -n bluetooth-haltests
209 This package is C-API test application.
210
211 %prep
212 %setup -q
213 cp %{SOURCE1001} .
214
215
216 %build
217 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
218 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_OBEX"
219 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_PAN_NAP"
220 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_IPSP"
221 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
222 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
223
224 %define _servicefile packaging/bluetooth-frwk-common.service
225 %define _servicedir starter.target.wants
226
227 %if "%{?profile}" == "mobile"
228 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_NETWORK_TETHERING_ENABLE -DTIZEN_FEATURE_FLIGHTMODE_ENABLED -DTIZEN_PROFILE_MOBILE -DTIZEN_FEATURE_TELEPHONY_ENABLED"
229 %if "%{?tizen_target_name}" == "TM1"
230 %define _servicefile packaging/bluetooth-frwk-mobile-sprd.service
231 %else
232 %define _servicefile packaging/bluetooth-frwk-mobile.service
233 %endif
234 %define _servicedir multi-user.target.wants
235 %endif
236
237 %if "%{?profile}" == "wearable"
238 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_WEARABLE -DTIZEN_FEATURE_FLIGHTMODE_ENABLED"
239 %define _servicefile packaging/bluetooth-frwk-wearable.service
240 %define _servicedir multi-user.target.wants
241 %endif
242
243 %if "%{?profile}" == "tv"
244 export CFLAGS="$CFLAGS -DUSB_BLUETOOTH -DTIZEN_TV -DAUTO_ACCEPT"
245 %define _servicefile packaging/bluetooth-frwk-tv.service
246 %define _servicedir multi-user.target.wants
247 %endif
248
249 %if "%{?profile}" == "ivi"
250 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_IVI"
251 %define _servicefile packaging/bluetooth-frwk-wearable.service
252 %define _servicedir multi-user.target.wants
253 %endif
254
255 %ifarch x86_64
256 #export CFLAGS="$CFLAGS -Wall -g -fvisibility=hidden -fPIC"
257 export CFLAGS="$CFLAGS -fpie"
258 export CFLAGS+=" -DARCH64"
259 export CXXFLAGS+=" -DARCH64"
260 export FFLAGS+=" -DARCH64"
261 %else
262 export CFLAGS="$CFLAGS -fpie"
263 export LDFLAGS="$CFLAGS -pie"
264 %endif
265
266 %if %{bt_bluez_hal} == ENABLED
267 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_RFCOMM_DIRECT -DTIZEN_BT_HAL"
268 %else
269 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
270 %endif
271 export LDFLAGS="$CFLAGS -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs"
272
273 %if %{bt_gatt_client_fd} == DISABLED
274 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_GATT_CLIENT_FD_DISABLE"
275 %endif
276
277 %if %{bt_permanent_log} == ENABLED
278 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_PERMANENT_LOG"
279 %endif
280
281 %if %{bt_http_proxy} == ENABLED
282 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_HTTP_PROXY"
283 %endif
284
285 %if %{bt_factory_mode} == ENABLED
286 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_FACTORY_MODE"
287 %endif
288
289 %if %{bt_vendor_operation} == ENABLED
290 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_VENDOR_OPERATION"
291 %endif
292
293 %if %{bt_bluez_hal} == ENABLED
294 export BT_INCLUDE_OAL_BLUEZ=ENABLED
295 export CFLAGS="$CFLAGS -DTIZEN_BT_INCLUDE_OAL_BLUEZ"
296 %else
297 export BT_INCLUDE_OAL_BLUEZ=DISABLED
298 %endif
299
300 export CFLAGS_DEFAULT="$CFLAGS"
301 export CXXFLAGS_DEFAULT="$CXXFLAGS"
302 export FFLAGS_DEFAULT="$FFLAGS"
303
304 # extension-TM1
305 %ifarch %{ix86} || %{arm}
306 mkdir -p tm1
307 export CFLAGS="$CFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
308 export CXXFLAGS="$CXXFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
309 export FFLAGS="$FFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
310
311 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
312 -DCMAKE_LIB_DIR=%{_libdir} \
313 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
314 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
315         -DLIBNOTIFY_SUPPORT=Off \
316         -DLIBNOTIFICATION_SUPPORT=Off
317 make %{?_smp_mflags}
318
319 %cmake
320
321 %make_install
322 cp %{buildroot}%{_bindir}/bt-core tm1/bt-core.tm1
323 %endif
324
325 # extension-emulator
326 %ifarch %{ix86} x86_64
327 export CFLAGS="${CFLAGS} -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
328 export CXXFLAGS="${CXXFLAGS} -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
329 export FFLAGS="${FFLAGS} -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
330
331 mkdir -p build_emulator
332
333 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
334 -DCMAKE_LIB_DIR=%{_libdir} \
335 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
336 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
337         -DLIBNOTIFY_SUPPORT=Off \
338         -DLIBNOTIFICATION_SUPPORT=Off
339 make %{?_smp_mflags}
340
341 %cmake
342
343 %make_install
344 cp %{buildroot}%{_libdir}/libbluetooth-api.so* build_emulator/
345 pushd build_emulator/
346 for FILE in libbluetooth-api.so*; do mv "${FILE}" "${FILE}.emulator"; done
347 popd
348 %endif
349
350 # non-extension-TM1 / non-extension-emulator
351
352 export CFLAGS="$CFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
353 export CXXFLAGS="$CXXFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
354 export FFLAGS="$FFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
355
356 %ifarch aarch64
357 echo arch64
358 export CFLAGS+=" -DARCH64"
359 export CXXFLAGS+=" -DARCH64"
360 export FFLAGS+=" -DARCH64"
361 %endif
362
363 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
364 -DCMAKE_LIB_DIR=%{_libdir} \
365 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
366 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
367         -DLIBNOTIFY_SUPPORT=Off \
368         -DLIBNOTIFICATION_SUPPORT=Off
369 make %{?_smp_mflags}
370
371 %cmake
372
373 %install
374 rm -rf %{buildroot}
375 %make_install
376
377 mkdir -p %{buildroot}%{_unitdir}/starter.target.wants
378 mkdir -p %{buildroot}%{_unitdir}/delayed.target.wants
379 mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants
380 mkdir -p %{buildroot}/%{_prefix}/lib/udev/rules.d
381 mkdir -p %{buildroot}%{_meshdir}
382
383 cp packaging/99-bluetooth-rfkill.rules %{buildroot}/%{_prefix}/lib/udev/rules.d/99-bluetooth-rfkill.rules
384
385 # extension-emulator
386 %ifarch %{ix86} x86_64
387 cp build_emulator/libbluetooth-api.so*.emulator %{buildroot}%{_libdir}/
388 #mv %{buildroot}/%{_bindir}/bt-service-emul %{buildroot}/%{_bindir}/bt-service
389 %endif
390
391 # Rename the postfix (.mobile, .tv, ..) at post script
392 # mobile
393 install -m 0644 packaging/bluetooth-frwk-mobile.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.mobile
394
395 # extension-TM1
396 %ifarch %{ix86} || %{arm}
397 cp tm1/bt-core.tm1 %{buildroot}%{_bindir}/
398 install -m 0644 packaging/bluetooth-frwk-mobile-sprd.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.tm1
399 %endif
400
401 # wearable / ivi
402 install -m 0644 packaging/bluetooth-frwk-wearable.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.wearable
403 # On IVI bt-service needs to be run as 'app' even if there is a 'guest' user.
404 cp %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
405 sed -i 's/%TZ_SYS_DEFAULT_USER/app/' %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
406
407 # tv
408 install -m 0644 packaging/bluetooth-frwk-tv.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.tv
409
410 # common
411 install -m 0644 packaging/bluetooth-frwk-common.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.common
412
413 # bt-core
414 install -m 0644 bt-core/bluetooth-frwk-core.service %{buildroot}%{_unitdir}/bluetooth-frwk-core.service
415
416 ln -s ../bluetooth-frwk.service %{buildroot}%{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
417 ln -s ../bluetooth-frwk.service %{buildroot}%{_unitdir}/starter.target.wants/bluetooth-frwk.service
418
419 %postun -p /sbin/ldconfig
420
421 %post service
422 /usr/bin/chsmack -a '_' %{_varlibdir}/bluetooth/auto-pair-blacklist
423 /usr/bin/chown network_fw:network_fw %{_varlibdir}/bluetooth/auto-pair-blacklist
424 /usr/bin/chown network_fw:network_fw %{_meshdir}
425
426 %files
427 %manifest %{name}.manifest
428 %license LICENSE
429 %defattr(-, root, root)
430 %{_libdir}/libbluetooth-api.so.*
431 %exclude %{_libdir}/libbluetooth-api.so*.emulator
432
433 %files devel
434 %defattr(-, root, root)
435 %{_includedir}/bt-service/bluetooth-api.h
436 %{_includedir}/bt-service/bluetooth-hid-api.h
437 %{_includedir}/bt-service/bluetooth-audio-api.h
438 %{_includedir}/bt-service/bluetooth-telephony-api.h
439 %{_includedir}/bt-service/bluetooth-media-control.h
440 %{_includedir}/bt-service/bluetooth-scmst-api.h
441 %{_includedir}/bt-service/bluetooth-ipsp-api.h
442 %{_includedir}/bt-service/bluetooth-gatt-server-api.h
443 %{_includedir}/bt-service/bluetooth-gatt-client-api.h
444 %{_includedir}/bt-service/bluetooth-mesh-api.h
445 %{_libdir}/pkgconfig/bluetooth-api.pc
446 %{_libdir}/libbluetooth-api.so
447
448 # extension-emulator
449 %ifarch %{ix86} x86_64
450 %post extension-emulator
451 pushd %{_libdir}
452 for FILE in libbluetooth-api.so*.emulator; do mv "${FILE}" "${FILE%.emulator}"; done
453 popd
454 %preun extension-emulator
455 pushd %{_libdir}
456 for FILE in libbluetooth-api.so*; do mv "${FILE}" "${FILE}.emulator"; done
457 popd
458 %files extension-emulator
459 %manifest %{name}.manifest
460 %defattr(-, root, root)
461 %{_libdir}/libbluetooth-api.so.*.emulator
462 %{_libdir}/libbluetooth-api.so.emulator
463 %endif
464
465 %files service
466 %manifest %{name}.manifest
467 %license LICENSE
468 %defattr(-, root, root)
469 %{_bindir}/bt-service
470 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-service.conf
471 %{_bindir}/bluetooth-frwk-test
472 %{_varlibdir}/bluetooth
473 %{_prefix}/etc/bluetooth
474 %{_meshdir}
475 %attr(-,network_fw,network_fw) %{_varlibdir}/bluetooth/auto-pair-blacklist
476
477 %if %{bt_http_proxy} == ENABLED
478 %files httpproxy
479 %manifest %{name}.manifest
480 %license LICENSE
481 %defattr(-, root, root)
482 %{_bindir}/bt-httpproxy
483 %{_datadir}/dbus-1/system-services/org.projectx.httpproxy.service
484 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-httpproxy.conf
485 %endif
486
487 %files otp
488 %manifest %{name}.manifest
489 %license LICENSE
490 %defattr(-, root, root)
491 %{_bindir}/bt-otp
492 %{_datadir}/dbus-1/system-services/org.projectx.otp.service
493 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-otp.conf
494
495 %files core
496 %manifest %{name}.manifest
497 %license LICENSE
498 %defattr(-, root, root)
499 %{_unitdir}/bluetooth-frwk-core.service
500 %{_datadir}/dbus-1/system-services/org.projectx.bt_core.service
501 %{_bindir}/bt-core
502 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-core.conf
503 %{_prefix}/lib/udev/rules.d/99-bluetooth-rfkill.rules
504
505 %files test
506 %manifest %{name}.manifest
507 %license LICENSE
508 %defattr(-, root, root)
509 %{_bindir}/bluetooth-frwk-test
510 #%{_bindir}/bluetooth-gatt-test
511 #%{_bindir}/bluetooth-advertising-test
512
513 %files plugin-headed
514 %manifest %{name}.manifest
515 %license LICENSE
516 %defattr(-, root, root)
517 %{_libdir}/bt-plugin-headed.so
518
519 %post profile_common
520 pushd %{_unitdir}
521 mv bluetooth-frwk.service.common bluetooth-frwk.service
522 popd
523 %preun profile_common
524 pushd %{_unitdir}
525 mv bluetooth-frwk.service bluetooth-frwk.service.common
526 popd
527 %files profile_common
528 %license LICENSE
529 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
530 %exclude %{_unitdir}/starter.target.wants/bluetooth-frwk.service
531 %{_unitdir}/bluetooth-frwk.service.common
532 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
533
534 %post profile_mobile
535 pushd %{_unitdir}
536 mv bluetooth-frwk.service.mobile bluetooth-frwk.service
537 popd
538 %preun profile_mobile
539 pushd %{_unitdir}
540 mv bluetooth-frwk.service bluetooth-frwk.service.mobile
541 popd
542 %files profile_mobile
543 %license LICENSE
544 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
545 %{_unitdir}/bluetooth-frwk.service.mobile
546 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
547
548 # extension-TM1
549 %ifarch %{ix86} || %{arm}
550 %post extension-TM1
551 pushd %{_unitdir}
552 mv bluetooth-frwk.service.tm1 bluetooth-frwk.service
553 popd
554 pushd %{_bindir}
555 mv bt-core.tm1 bt-core
556 popd
557 %preun extension-TM1
558 pushd %{_unitdir}
559 mv bluetooth-frwk.service bluetooth-frwk.service.tm1
560 popd
561 pushd %{_bindir}
562 mv bt-core bt-core.tm1
563 popd
564 %files extension-TM1
565 %{_unitdir}/bluetooth-frwk.service.tm1
566 %license LICENSE
567 %defattr(-, root, root)
568 %{_bindir}/bt-core.tm1
569 %endif
570
571 %post profile_wearable
572 pushd %{_unitdir}
573 mv bluetooth-frwk.service.wearable bluetooth-frwk.service
574 popd
575 %preun profile_wearable
576 pushd %{_unitdir}
577 mv bluetooth-frwk.service bluetooth-frwk.service.wearable
578 popd
579 %files profile_wearable
580 %license LICENSE
581 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
582 %{_unitdir}/bluetooth-frwk.service.wearable
583 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
584
585 %post profile_tv
586 pushd %{_unitdir}
587 mv bluetooth-frwk.service.tv bluetooth-frwk.service
588 popd
589 %preun profile_tv
590 pushd %{_unitdir}
591 mv bluetooth-frwk.service bluetooth-frwk.service.tv
592 popd
593 %files profile_tv
594 %license LICENSE
595 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
596 %{_unitdir}/bluetooth-frwk.service.tv
597 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
598
599 # Note: ivi reuses bluetooth-frwk.service.wearable
600 %post profile_ivi
601 pushd %{_unitdir}
602 mv bluetooth-frwk.service.wearable bluetooth-frwk.service
603 popd
604 pushd %{_datadir}/dbus-1/system-services
605 mv org.projectx.bt.service.ivi org.projectx.bt.service
606 popd
607 %preun profile_ivi
608 pushd %{_unitdir}
609 mv bluetooth-frwk.service bluetooth-frwk.service.wearable
610 popd
611 pushd %{_datadir}/dbus-1/system-services
612 mv org.projectx.bt.service org.projectx.bt.service.ivi
613 popd
614 %files profile_ivi
615 %license LICENSE
616 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
617 %{_unitdir}/bluetooth-frwk.service.wearable
618 %{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
619
620 %files oal
621 %manifest %{name}.manifest
622 %defattr(-, root, root)
623 %{_libdir}/libbt-oal.so*
624 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-gap-agent.conf
625
626 %if %{bt_bluez_hal} == ENABLED
627 %{_libdir}/libbluetooth.default.so*
628 %endif
629
630 %files -n bluetooth-haltests
631 %manifest %{name}.manifest
632 %{_bindir}/bluetooth-haltests