Disable HTTP proxy feature
[platform/core/connectivity/bluetooth-frwk.git] / packaging / bluetooth-frwk.spec
1 # Do not create provides from emulator .so files because the main package
2 # should anchor any reverse-dependencies
3 %global __provides_exclude_from ^(.*\\.emulator)$
4
5 %bcond_with x
6 %define _dumpdir /opt/etc/dump.d/module.d
7 %define _varlibdir /opt/var/lib
8
9 Name:       bluetooth-frwk
10 Summary:    Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
11 Version:    0.3.0
12 Release:    1
13 Group:      Network & Connectivity/Bluetooth
14 License:    Apache-2.0
15 Source0:    %{name}-%{version}.tar.gz
16 Source1001: bluetooth-frwk.manifest
17
18 Requires: bluetooth-tools
19
20 %define bt_bluez_hal ENABLED
21 %define bt_gatt_client_fd ENABLED
22 %define bt_permanent_log DISABLED
23 %define bt_http_proxy DISABLED
24
25 BuildRequires:  pkgconfig(aul)
26 BuildRequires:  pkgconfig(dlog)
27 BuildRequires:  pkgconfig(glib-2.0)
28 BuildRequires:  pkgconfig(gio-2.0)
29 BuildRequires:  pkgconfig(gio-unix-2.0)
30 BuildRequires:  pkgconfig(syspopup-caller)
31 BuildRequires:  pkgconfig(vconf)
32 BuildRequires:  pkgconfig(libxml-2.0)
33 BuildRequires:  pkgconfig(capi-network-connection)
34 BuildRequires:  pkgconfig(alarm-service)
35 BuildRequires:  pkgconfig(capi-content-mime-type)
36 BuildRequires:  pkgconfig(eventsystem)
37 %if %{bt_http_proxy} == ENABLED
38 BuildRequires:  pkgconfig(libsoup-2.4)
39 %endif
40 BuildRequires:  pkgconfig(capi-network-tethering)
41 BuildRequires:  cmake
42 BuildRequires:  pkgconfig(cynara-client)
43 BuildRequires:  pkgconfig(cynara-creds-gdbus)
44 BuildRequires:  pkgconfig(libtzplatform-config)
45 BuildRequires:  pkgconfig(storage)
46 BuildRequires:  pkgconfig(capi-system-info)
47 BuildRequires:  pkgconfig(capi-appfw-app-control)
48 BuildRequires:  pkgconfig(gmock)
49 BuildRequires:  pkgconfig(libactd)
50 BuildRequires:  pkgconfig(libsystemd-daemon)
51
52 Requires(post): /usr/bin/vconftool
53 Requires(post): /sbin/ldconfig
54 Requires(postun): /sbin/ldconfig
55
56 %description
57 Bluetooth framework for BlueZ and Obexd. This package is Bluetooth framework based on BlueZ and Obexd stack.
58  This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
59
60 %package profile_common
61 Summary:    bluetooth-frwk service and conf files for common profile
62 Requires:   %{name} = %{version}-%{release}
63 Conflicts:  %{name}-profile_mobile
64 Conflicts:  %{name}-profile_wearable
65 Conflicts:  %{name}-profile_tv
66 Conflicts:  %{name}-profile_ivi
67 %description profile_common
68 Bluetooth framework configuration and service files for Tizen common profile
69
70 %package profile_mobile
71 Summary:    bluetooth-frwk service and conf files for mobile profile
72 Requires:   %{name} = %{version}-%{release}
73 Conflicts:  %{name}-profile_common
74 Conflicts:  %{name}-profile_wearable
75 Conflicts:  %{name}-profile_tv
76 Conflicts:  %{name}-profile_ivi
77 %description profile_mobile
78 Bluetooth framework configuration and service files for Tizen mobile profile
79
80 # extension-TM1
81 %ifarch %{ix86} || %{arm}
82 %package extension-TM1
83 Summary:    bluetooth-frwk service and conf files for mobile TM1
84 Requires:   %{name}-profile_mobile = %{version}-%{release}
85 %description extension-TM1
86 Bluetooth framework configuration and service files for Tizen mobile TM1
87 %endif
88
89 %package profile_wearable
90 Summary:    bluetooth-frwk service and conf files for wearable profile
91 Requires:   %{name} = %{version}-%{release}
92 Conflicts:  %{name}-profile_mobile
93 Conflicts:  %{name}-profile_common
94 Conflicts:  %{name}-profile_tv
95 Conflicts:  %{name}-profile_ivi
96 %description profile_wearable
97 Bluetooth framework configuration and service files for Tizen wearable profile
98
99 %package profile_tv
100 Summary:    bluetooth-frwk service and conf files for tv profile
101 Requires:   %{name} = %{version}-%{release}
102 Conflicts:  %{name}-profile_mobile
103 Conflicts:  %{name}-profile_wearable
104 Conflicts:  %{name}-profile_common
105 Conflicts:  %{name}-profile_ivi
106 %description profile_tv
107 Bluetooth framework configuration and service files for Tizen tv profile
108
109 %package profile_ivi
110 Summary:    bluetooth-frwk service and conf files for ivi profile
111 Requires:   %{name} = %{version}-%{release}
112 Conflicts:  %{name}-profile_mobile
113 Conflicts:  %{name}-profile_wearable
114 Conflicts:  %{name}-profile_tv
115 Conflicts:  %{name}-profile_common
116 %description profile_ivi
117 Bluetooth framework configuration and service files for Tizen ivi profile
118
119 %ifarch %{ix86} x86_64
120 %package extension-emulator
121 Summary:    bluetooth-frwk service and conf files for emulator
122 Requires:   %{name} = %{version}-%{release}
123 %description extension-emulator
124 bluetooth-frwk service and conf files for emulator
125 %endif // ifarch %{ix86} x86_64
126
127 %package devel
128 Summary:    Bluetooth framework for BlueZ and Obexd
129 Group:      Development/Libraries
130 Requires:   %{name} = %{version}-%{release}
131
132 %description devel
133 This package is development files for Bluetooth framework based on BlueZ and Obexd stack.
134 This package contains API set for BT GAP, BT SDP, and BT RFCOMM.
135
136 %package service
137 Summary:    Bluetooth Service daemon
138 Group:      Network & Connectivity/Bluetooth
139 Requires:   %{name} = %{version}-%{release}
140
141 %description service
142 This package is Bluetooth Service daemon to manage BT services.
143
144 %if %{bt_http_proxy} == ENABLED
145 %package httpproxy
146 Summary:    Bluetooth HTTP Proxy Service daemon
147 Group:      Network & Connectivity/Bluetooth
148 Requires:   %{name} = %{version}-%{release}
149
150 %description httpproxy
151 This package is Bluetooth HTTP Proxy Service daemon
152 %endif
153
154 %package otp
155 Summary:    Bluetooth OTP Service daemon
156 Group:      Network & Connectivity/Bluetooth
157 Requires:   %{name} = %{version}-%{release}
158
159 %description otp
160 This package is Bluetooth OTP Service daemon
161
162 %package core
163 Summary:    Bluetooth Core daemon
164 Group:      Network & Connectivity/Bluetooth
165 Requires:   %{name} = %{version}-%{release}
166
167 %description core
168 This package is Bluetooth core daemon to manage activation / deactivation.
169
170 %package test
171 Summary:    Bluetooth test application
172 Group:      Network & Connectivity/Bluetooth
173 Requires:   %{name} = %{version}-%{release}
174
175 %description test
176 This package is Bluetooth test application.
177
178 %package oal
179 Summary:    Bluetooth OAL
180 Group:      Network & Connectivity/Bluetooth
181 Requires:   %{name} = %{version}-%{release}
182
183 %description oal
184 This package is BT stack common interface.
185
186 %package plugin-headed
187 Summary:    Bluetooth plugin Headed
188 Group:      Network & Connectivity/Bluetooth
189 Requires:   %{name} = %{version}-%{release}
190
191 %description plugin-headed
192 This package is Bluetooth plugin to manage UI and syspopup
193
194 %package -n bluetooth-haltests
195 Summary: HAL Test package for bluetooth OAL
196 Group:   TO_BE/FILLED
197 Requires: %{name} = %{version}-%{release}
198
199 %description -n bluetooth-haltests
200 This package is C-API test application.
201
202 %prep
203 %setup -q
204 cp %{SOURCE1001} .
205
206
207 %build
208 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
209 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_OBEX"
210 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_PAN_NAP"
211 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_IPSP"
212 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
213 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
214 export CFLAGS="$CFLAGS -DTIZEN_GATT_CLIENT"
215 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_ACTD"
216
217 %define _servicefile packaging/bluetooth-frwk-common.service
218 %define _servicedir starter.target.wants
219
220 %if "%{?profile}" == "mobile"
221 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_NETWORK_TETHERING_ENABLE -DTIZEN_FEATURE_FLIGHTMODE_ENABLED -DTIZEN_PROFILE_MOBILE -DTIZEN_FEATURE_TELEPHONY_ENABLED"
222 %if "%{?tizen_target_name}" == "TM1"
223 %define _servicefile packaging/bluetooth-frwk-mobile-sprd.service
224 %else
225 %define _servicefile packaging/bluetooth-frwk-mobile.service
226 %endif
227 %define _servicedir multi-user.target.wants
228 %endif
229
230 %if "%{?profile}" == "wearable"
231 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_WEARABLE -DTIZEN_FEATURE_FLIGHTMODE_ENABLED"
232 %define _servicefile packaging/bluetooth-frwk-wearable.service
233 %define _servicedir multi-user.target.wants
234 %endif
235
236 %if "%{?profile}" == "tv"
237 export CFLAGS="$CFLAGS -DUSB_BLUETOOTH -DTIZEN_TV -DAUTO_ACCEPT"
238 %define _servicefile packaging/bluetooth-frwk-tv.service
239 %define _servicedir multi-user.target.wants
240 %endif
241
242 %if "%{?profile}" == "ivi"
243 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_IVI"
244 %define _servicefile packaging/bluetooth-frwk-wearable.service
245 %define _servicedir multi-user.target.wants
246 %endif
247
248 %ifarch x86_64
249 #export CFLAGS="$CFLAGS -Wall -g -fvisibility=hidden -fPIC"
250 export CFLAGS="$CFLAGS -fpie"
251 export CFLAGS+=" -DARCH64"
252 export CXXFLAGS+=" -DARCH64"
253 export FFLAGS+=" -DARCH64"
254 %else
255 export CFLAGS="$CFLAGS -fpie"
256 export LDFLAGS="$CFLAGS -pie"
257 %endif
258
259 %if %{bt_bluez_hal} == ENABLED
260 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_RFCOMM_DIRECT -DTIZEN_BT_HAL"
261 %else
262 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
263 %endif
264 export LDFLAGS="$CFLAGS -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs"
265
266 %if %{bt_gatt_client_fd} == DISABLED
267 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_GATT_CLIENT_FD_DISABLE"
268 %endif
269
270 %if %{bt_permanent_log} == ENABLED
271 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_PERMANENT_LOG"
272 %endif
273
274 %if %{bt_http_proxy} == ENABLED
275 export CFLAGS="$CFLAGS -DTIZEN_FEATURE_BT_HTTP_PROXY"
276 %endif
277
278 %ifarch %{ix86} x86_64
279 export CFLAGS+=" -DTIZEN_TEST_EMUL"
280 export CXXFLAGS+=" -DTIZEN_TEST_EMUL"
281 export FFLAGS+=" -DTIZEN_TEST_EMUL"
282 %endif
283
284 %if %{bt_bluez_hal} == ENABLED
285 export BT_INCLUDE_OAL_BLUEZ=ENABLED
286 export CFLAGS="$CFLAGS -DTIZEN_BT_INCLUDE_OAL_BLUEZ"
287 %else
288 export BT_INCLUDE_OAL_BLUEZ=DISABLED
289 %endif
290
291 export CFLAGS_DEFAULT="$CFLAGS"
292 export CXXFLAGS_DEFAULT="$CXXFLAGS"
293 export FFLAGS_DEFAULT="$FFLAGS"
294
295 # extension-TM1
296 %ifarch %{ix86} || %{arm}
297 mkdir -p tm1
298 export CFLAGS="$CFLAGS_DEFAULT -DTIZEN_FEATURE_RADIO -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
299 export CXXFLAGS="$CXXFLAGS_DEFAULT -DTIZEN_FEATURE_RADIO -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
300 export FFLAGS="$FFLAGS_DEFAULT -DTIZEN_FEATURE_RADIO -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
301
302 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
303 -DCMAKE_LIB_DIR=%{_libdir} \
304 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
305 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
306         -DLIBNOTIFY_SUPPORT=Off \
307         -DLIBNOTIFICATION_SUPPORT=Off
308 make %{?_smp_mflags}
309
310 %cmake
311
312 %make_install
313 cp %{buildroot}%{_bindir}/bt-core tm1/bt-core.tm1
314 %endif
315
316 # extension-emulator
317 %ifarch %{ix86} x86_64
318 export CFLAGS="${CFLAGS} -DTIZEN_TEST_EMUL -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
319 export CXXFLAGS="${CXXFLAGS} -DTIZEN_TEST_EMUL -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
320 export FFLAGS="${FFLAGS} -DTIZEN_TEST_EMUL -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
321
322 mkdir -p build_emulator
323
324 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
325 -DCMAKE_LIB_DIR=%{_libdir} \
326 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
327 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
328         -DLIBNOTIFY_SUPPORT=Off \
329         -DLIBNOTIFICATION_SUPPORT=Off
330 make %{?_smp_mflags}
331
332 %cmake
333
334 %make_install
335 cp %{buildroot}%{_libdir}/libbluetooth-api.so* build_emulator/
336 pushd build_emulator/
337 for FILE in libbluetooth-api.so*; do mv "${FILE}" "${FILE}.emulator"; done
338 popd
339 %endif
340
341 # non-extension-TM1 / non-extension-emulator
342
343 export CFLAGS="$CFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
344 export CXXFLAGS="$CXXFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
345 export FFLAGS="$FFLAGS_DEFAULT -DTIZEN_FEATURE_BT_RFCOMM_DIRECT"
346
347 %ifarch aarch64
348 echo arch64
349 export CFLAGS+=" -DARCH64"
350 export CXXFLAGS+=" -DARCH64"
351 export FFLAGS+=" -DARCH64"
352 %endif
353
354 cmake . -DCMAKE_INSTALL_PREFIX=/usr \
355 -DCMAKE_LIB_DIR=%{_libdir} \
356 -DTZ_SYS_USER_GROUP=%TZ_SYS_USER_GROUP \
357 -DTZ_SYS_DEFAULT_USER=%TZ_SYS_DEFAULT_USER \
358         -DLIBNOTIFY_SUPPORT=Off \
359         -DLIBNOTIFICATION_SUPPORT=Off
360 make %{?_smp_mflags}
361
362 %cmake
363
364 %install
365 rm -rf %{buildroot}
366 %make_install
367
368 mkdir -p %{buildroot}%{_unitdir}/starter.target.wants
369 mkdir -p %{buildroot}%{_unitdir}/delayed.target.wants
370 mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants
371 mkdir -p %{buildroot}/%{_prefix}/lib/udev/rules.d
372
373 cp packaging/99-bluetooth-rfkill.rules %{buildroot}/%{_prefix}/lib/udev/rules.d/99-bluetooth-rfkill.rules
374
375 # extension-emulator
376 %ifarch %{ix86} x86_64
377 cp build_emulator/libbluetooth-api.so*.emulator %{buildroot}%{_libdir}/
378 #mv %{buildroot}/%{_bindir}/bt-service-emul %{buildroot}/%{_bindir}/bt-service
379 %endif
380
381 # Rename the postfix (.mobile, .tv, ..) at post script
382 # mobile
383 install -m 0644 packaging/bluetooth-frwk-mobile.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.mobile
384
385 # extension-TM1
386 %ifarch %{ix86} || %{arm}
387 cp tm1/bt-core.tm1 %{buildroot}%{_bindir}/
388 install -m 0644 packaging/bluetooth-frwk-mobile-sprd.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.tm1
389 %endif
390
391 # wearable / ivi
392 install -m 0644 packaging/bluetooth-frwk-wearable.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.wearable
393 # On IVI bt-service needs to be run as 'app' even if there is a 'guest' user.
394 cp %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
395 sed -i 's/%TZ_SYS_DEFAULT_USER/app/' %{buildroot}%{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
396
397 # tv
398 install -m 0644 packaging/bluetooth-frwk-tv.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.tv
399
400 # common
401 install -m 0644 packaging/bluetooth-frwk-common.service %{buildroot}%{_unitdir}/bluetooth-frwk.service.common
402
403 # bt-core
404 install -m 0644 bt-core/bluetooth-frwk-core.service %{buildroot}%{_unitdir}/bluetooth-frwk-core.service
405
406 ln -s ../bluetooth-frwk.service %{buildroot}%{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
407 ln -s ../bluetooth-frwk.service %{buildroot}%{_unitdir}/starter.target.wants/bluetooth-frwk.service
408
409 %postun -p /sbin/ldconfig
410
411 %post service
412 /usr/bin/chsmack -a '_' %{_varlibdir}/bluetooth/auto-pair-blacklist
413 /usr/bin/chown network_fw:network_fw %{_varlibdir}/bluetooth/auto-pair-blacklist
414
415 %files
416 %manifest %{name}.manifest
417 %license LICENSE
418 %defattr(-, root, root)
419 %{_libdir}/libbluetooth-api.so.*
420 %exclude %{_libdir}/libbluetooth-api.so*.emulator
421
422 %files devel
423 %defattr(-, root, root)
424 %{_includedir}/bt-service/bluetooth-api.h
425 %{_includedir}/bt-service/bluetooth-hid-api.h
426 %{_includedir}/bt-service/bluetooth-audio-api.h
427 %{_includedir}/bt-service/bluetooth-telephony-api.h
428 %{_includedir}/bt-service/bluetooth-media-control.h
429 %{_includedir}/bt-service/bluetooth-scmst-api.h
430 %{_includedir}/bt-service/bluetooth-ipsp-api.h
431 %{_includedir}/bt-service/bluetooth-gatt-server-api.h
432 %{_includedir}/bt-service/bluetooth-gatt-client-api.h
433 %{_libdir}/pkgconfig/bluetooth-api.pc
434 %{_libdir}/libbluetooth-api.so
435
436 # extension-emulator
437 %ifarch %{ix86} x86_64
438 %post extension-emulator
439 pushd %{_libdir}
440 for FILE in libbluetooth-api.so*.emulator; do mv "${FILE}" "${FILE%.emulator}"; done
441 popd
442 %preun extension-emulator
443 pushd %{_libdir}
444 for FILE in libbluetooth-api.so*; do mv "${FILE}" "${FILE}.emulator"; done
445 popd
446 %files extension-emulator
447 %manifest %{name}.manifest
448 %defattr(-, root, root)
449 %{_libdir}/libbluetooth-api.so.*.emulator
450 %{_libdir}/libbluetooth-api.so.emulator
451 %endif
452
453 %files service
454 %manifest %{name}.manifest
455 %license LICENSE
456 %defattr(-, root, root)
457 %{_bindir}/bt-service
458 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-service.conf
459 %{_bindir}/bluetooth-frwk-test
460 %{_varlibdir}/bluetooth
461 %{_prefix}/etc/bluetooth
462 %attr(-,network_fw,network_fw) %{_varlibdir}/bluetooth/auto-pair-blacklist
463
464 %if %{bt_http_proxy} == ENABLED
465 %files httpproxy
466 %manifest %{name}.manifest
467 %license LICENSE
468 %defattr(-, root, root)
469 %{_bindir}/bt-httpproxy
470 %{_datadir}/dbus-1/system-services/org.projectx.httpproxy.service
471 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-httpproxy.conf
472 %endif
473
474 %files otp
475 %manifest %{name}.manifest
476 %license LICENSE
477 %defattr(-, root, root)
478 %{_bindir}/bt-otp
479 %{_datadir}/dbus-1/system-services/org.projectx.otp.service
480 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-otp.conf
481
482 %files core
483 %manifest %{name}.manifest
484 %license LICENSE
485 %defattr(-, root, root)
486 %{_unitdir}/bluetooth-frwk-core.service
487 %{_datadir}/dbus-1/system-services/org.projectx.bt_core.service
488 %{_bindir}/bt-core
489 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-core.conf
490 %{_prefix}/lib/udev/rules.d/99-bluetooth-rfkill.rules
491
492 %files test
493 %manifest %{name}.manifest
494 %license LICENSE
495 %defattr(-, root, root)
496 %{_bindir}/bluetooth-frwk-test
497 #%{_bindir}/bluetooth-gatt-test
498 #%{_bindir}/bluetooth-advertising-test
499
500 %files plugin-headed
501 %manifest %{name}.manifest
502 %license LICENSE
503 %defattr(-, root, root)
504 %{_libdir}/bt-plugin-headed.so
505
506 %post profile_common
507 pushd %{_unitdir}
508 mv bluetooth-frwk.service.common bluetooth-frwk.service
509 popd
510 %preun profile_common
511 pushd %{_unitdir}
512 mv bluetooth-frwk.service bluetooth-frwk.service.common
513 popd
514 %files profile_common
515 %license LICENSE
516 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
517 %exclude %{_unitdir}/starter.target.wants/bluetooth-frwk.service
518 %{_unitdir}/bluetooth-frwk.service.common
519 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
520
521 %post profile_mobile
522 pushd %{_unitdir}
523 mv bluetooth-frwk.service.mobile bluetooth-frwk.service
524 popd
525 %preun profile_mobile
526 pushd %{_unitdir}
527 mv bluetooth-frwk.service bluetooth-frwk.service.mobile
528 popd
529 %files profile_mobile
530 %license LICENSE
531 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
532 %{_unitdir}/bluetooth-frwk.service.mobile
533 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
534
535 # extension-TM1
536 %ifarch %{ix86} || %{arm}
537 %post extension-TM1
538 pushd %{_unitdir}
539 mv bluetooth-frwk.service.tm1 bluetooth-frwk.service
540 popd
541 pushd %{_bindir}
542 mv bt-core.tm1 bt-core
543 popd
544 %preun extension-TM1
545 pushd %{_unitdir}
546 mv bluetooth-frwk.service bluetooth-frwk.service.tm1
547 popd
548 pushd %{_bindir}
549 mv bt-core bt-core.tm1
550 popd
551 %files extension-TM1
552 %{_unitdir}/bluetooth-frwk.service.tm1
553 %license LICENSE
554 %defattr(-, root, root)
555 %{_bindir}/bt-core.tm1
556 %endif
557
558 %post profile_wearable
559 pushd %{_unitdir}
560 mv bluetooth-frwk.service.wearable bluetooth-frwk.service
561 popd
562 %preun profile_wearable
563 pushd %{_unitdir}
564 mv bluetooth-frwk.service bluetooth-frwk.service.wearable
565 popd
566 %files profile_wearable
567 %license LICENSE
568 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
569 %{_unitdir}/bluetooth-frwk.service.wearable
570 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
571
572 %post profile_tv
573 pushd %{_unitdir}
574 mv bluetooth-frwk.service.tv bluetooth-frwk.service
575 popd
576 %preun profile_tv
577 pushd %{_unitdir}
578 mv bluetooth-frwk.service bluetooth-frwk.service.tv
579 popd
580 %files profile_tv
581 %license LICENSE
582 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
583 %{_unitdir}/bluetooth-frwk.service.tv
584 %{_datadir}/dbus-1/system-services/org.projectx.bt.service
585
586 # Note: ivi reuses bluetooth-frwk.service.wearable
587 %post profile_ivi
588 pushd %{_unitdir}
589 mv bluetooth-frwk.service.wearable bluetooth-frwk.service
590 popd
591 pushd %{_datadir}/dbus-1/system-services
592 mv org.projectx.bt.service.ivi org.projectx.bt.service
593 popd
594 %preun profile_ivi
595 pushd %{_unitdir}
596 mv bluetooth-frwk.service bluetooth-frwk.service.wearable
597 popd
598 pushd %{_datadir}/dbus-1/system-services
599 mv org.projectx.bt.service org.projectx.bt.service.ivi
600 popd
601 %files profile_ivi
602 %license LICENSE
603 %{_unitdir}/multi-user.target.wants/bluetooth-frwk.service
604 %{_unitdir}/bluetooth-frwk.service.wearable
605 %{_datadir}/dbus-1/system-services/org.projectx.bt.service.ivi
606
607 %files oal
608 %manifest %{name}.manifest
609 %defattr(-, root, root)
610 %{_libdir}/libbt-oal.so*
611 %{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-gap-agent.conf
612
613 %if %{bt_bluez_hal} == ENABLED
614 %{_libdir}/libbluetooth.default.so*
615 %endif
616
617 %files -n bluetooth-haltests
618 %manifest %{name}.manifest
619 %{_bindir}/bluetooth-haltests