2b27e3f68e3d79e84c0e8e52a90e7fe22b6f8438
[platform/core/appfw/xdgmime.git] / packaging / xdgmime.spec
1 Name:           xdgmime
2 Version:        0.0.14
3 Release:        0
4 License:        LGPL-2.1+ and AFL-2.0
5 Summary:        Querying information about file type
6 Group:          Applications/Other
7 Source0:        xdgmime-%{version}.tar.gz
8 Source1001:     xdgmime.manifest
9 BuildRequires:  cmake
10
11 %description
12 Querying information about file type package.
13
14 %package devel
15 Summary:        Querying information about file type (devel)
16 Group:          Development/Libraries
17 Requires:       %{name} = %{version}
18
19 %description devel
20 Querying information about file type (devel) package.
21
22 %prep
23 %setup -q
24 cp %{SOURCE1001} .
25
26 %build
27 %cmake . 
28 %__make %{?_smp_mflags}
29
30 %install
31 %make_install
32
33 %post -p /sbin/ldconfig
34
35 %postun -p /sbin/ldconfig
36
37 %files
38 %manifest %{name}.manifest
39 %defattr(-,root,root,-)
40 %{_libdir}/libxdgmime.so.*
41 %license COPYING
42
43 %files devel
44 %manifest %{name}.manifest
45 %defattr(-,root,root,-)
46 %{_includedir}/xdgmime.h
47 %{_libdir}/libxdgmime.so
48 %{_libdir}/pkgconfig/xdgmime.pc