Release version 0.15.33
[platform/core/appfw/wgt-backend.git] / packaging / wgt-backend.spec
1 Name:           wgt-backend
2 Summary:        Application installer backend for WGT
3 Version:        0.15.33
4 Release:        1
5 Group:          Application Framework/Package Management
6 License:        Apache-2.0
7 Source0:        %{name}-%{version}.tar.gz
8
9 Source1000:     wgt-backend.manifest
10 Source1001:     wgt-installer.manifest
11 Source1002:     wgt-installer-tests.manifest
12
13 Requires:       wgt-installer = %{version}
14 BuildRequires:  boost-devel
15 BuildRequires:  cmake
16 BuildRequires:  app-installers-tests
17 BuildRequires:  pkgconfig(app-installers)
18 BuildRequires:  pkgconfig(manifest-parser)
19 BuildRequires:  pkgconfig(wgt-manifest-handlers)
20 BuildRequires:  pkgconfig(pkgmgr-installer)
21 BuildRequires:  pkgconfig(pkgmgr-types)
22 BuildRequires:  pkgconfig(libwebappenc)
23 BuildRequires:  pkgconfig(tpk-installer)
24 BuildRequires:  pkgconfig(vconf)
25 BuildRequires:  pkgconfig(libgum)
26 BuildRequires:  pkgconfig(gmock)
27
28 %description
29 This is a package that installs the WGT backend of pkgmgr.
30
31 %package -n wgt-installer
32 Summary: Wgt-installer library
33 Group:   Application Framework/Package Management
34
35 %description -n wgt-installer
36 This package contains wgt-installer library
37
38 %package -n wgt-installer-devel
39 Summary:  Wgt-installer development files
40 Group:    Application Framework/Package Management
41 Requires: wgt-installer = %{version}
42
43 %description -n wgt-installer-devel
44 This package contains header files of wgt-installer library
45
46 %package -n wgt-installer-tests
47 Summary: Unit tests for wgt-installer
48 Requires: wgt-installer = %{version}
49
50 %description -n wgt-installer-tests
51 Unit tests for wgt-installer
52
53 %prep
54 %setup -q
55
56 cp %{SOURCE1000} .
57 cp %{SOURCE1001} .
58 cp %{SOURCE1002} .
59
60 %build
61 %ifnarch x86_64 aarch64
62 ISARC64=0
63 %else
64 ISARC64=1
65 %endif
66 %cmake . -DCMAKE_BUILD_TYPE=%{?build_type:%build_type} \
67          -DISARC64=${ISARC64}
68 make %{?_smp_mflags}
69
70 %install
71 %make_install
72 mkdir -p %{buildroot}/etc/package-manager/backend
73 ln -s %{_bindir}/wgt-backend %{buildroot}%{_sysconfdir}/package-manager/backend/wgt
74
75 %post -n wgt-installer-tests
76 /usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner,cap_mac_override=eip %{_bindir}/wgt-installer-ut/smoke-test
77 /usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner,cap_mac_override=eip %{_bindir}/wgt-installer-ut/smoke-test-helper
78 /usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner,cap_mac_override=eip %{_bindir}/wgt-installer-ut/hybrid-smoke-test-helper
79 /usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner,cap_mac_override=eip %{_bindir}/wgt-installer-ut/extensive-smoke-test
80
81 %files
82 %manifest wgt-backend.manifest
83 %license LICENSE
84 %{_sysconfdir}/package-manager/backend/wgt
85 %{_bindir}/wgt-backend
86 %{_datadir}/wgt-backend/default.png
87
88 %files -n wgt-installer
89 %manifest wgt-installer.manifest
90 %{_sysconfdir}/package-manager/backendlib/libwgt.so
91 %{_libdir}/libwgt-installer.so*
92 %{_libdir}/libhybrid-installer.so*
93
94 %files -n wgt-installer-devel
95 %{_includedir}/app-installers/wgt/*.h
96 %{_includedir}/app-installers/wgt/*/*.h
97 %{_includedir}/app-installers/wgt/*/*/*.h
98 %{_includedir}/app-installers/hybrid/*.h
99 %{_includedir}/app-installers/hybrid/*/*/*.h
100 %{_libdir}/pkgconfig/wgt-installer.pc
101
102 %files -n wgt-installer-tests
103 %manifest wgt-installer-tests.manifest
104 %{_bindir}/wgt-installer-ut/*
105 %ifnarch x86_64 aarch64
106 %{_datadir}/wgt-installer-ut/*
107 %endif
108 %{_libdir}/libwgt-smoke-utils.so*
109 %{_includedir}/app-installers/smoke_tests/wgt_smoke_utils.h
110
111 %changelog
112 * Thu Dec 18 2015 Pawel Sikorski <p.sikorski@samsung.com> 0.1-1
113 - initial files creation