Add packaging
[platform/core/appfw/notification-service.git] / packaging / notification-service.spec
1 Name:       notification-service
2 Summary:    Simple notification service
3 Version:    0.0.1
4 Release:    1
5 Group:      Application Framework/Notifications
6 License:    Flora
7 Source0:    %{name}-%{version}.tar.bz2
8 BuildRequires: pkgconfig(eina) 
9 BuildRequires: pkgconfig(ecore) 
10 BuildRequires: pkgconfig(com-core) 
11 BuildRequires: pkgconfig(notification)
12
13 %description
14 Headless notification service that collects incoming notifications from the
15 the platform, maintains a database of active notifications, and broadcast updates
16 to all listeners.
17
18 %prep
19 %setup -q -n %{name}-%{version}
20
21 %define PREFIX %{_prefix}/apps/
22
23 %build
24 %autogen
25 make %{?_smp_mflags}
26
27 %install
28 rm -rf %{buildroot}
29 %make_install
30
31 %files
32 %defattr(-,root,root,-)
33 %{_bindir}/notification-service
34 %{_libdir}/systemd/system/notifications.service
35 %{_libdir}/systemd/system/notifications.socket
36 %{_libdir}/systemd/system/sockets.target.wants/notifications.socket